
®

RigPi Station Server Version 3

USER MANUAL

© 2021 Howard Nurse, W6HN
Howard Nurse, W6HN



This  page i s  intentional ly left blank.
Remove this  text from the manual
template i f you want i t completely blank.



3

RigPi Station Server Version 3 
 
                                                                                                                                                                                                                          © 2021 Howard Nurse, W6HN

Table of Contents

1. Introduction
 
                                                                                                   7

1.1 Welcome to RSS .................................................................................................................. 9

1.2 Quick Start Guide .............................................................................................................. 11

1.3 What's New ....................................................................................................................... 17

1.4 Raspberry Pi Desktop ........................................................................................................ 20

1.5 Universal Functions ........................................................................................................... 22

1.6 RSS on Mobile Devices ...................................................................................................... 25

1.7 Security .............................................................................................................................. 27

1.8 Passwords .......................................................................................................................... 29

1.9 Accounts ............................................................................................................................ 30

1.10 Acknowlegements ............................................................................................................. 32

2. RSS Connections
 
                                                                                         35

2.1 Radio Control ..................................................................................................................... 37

2.2 Rotor Control ..................................................................................................................... 38

2.3 RigPi Audio ........................................................................................................................ 39

2.4 RigPi Keyer ......................................................................................................................... 45

2.5 Internet Connections ........................................................................................................ 47

2.6 Remote Connections ......................................................................................................... 47

2.7 Using a Dynamic DNS Service ........................................................................................... 50

3. Views
 
                                                                                                            51

3.1 Tuner .................................................................................................................................. 53

3.2 Keyer .................................................................................................................................. 61

3.3 Log ...................................................................................................................................... 63

Log Editor .................................................................................................................... 663.3.1

3.4 Spots ................................................................................................................................... 67

3.5 Web .................................................................................................................................... 71

4. Settings
 
                                                                                                        75

4.1 Account .............................................................................................................................. 76

Account Editor ............................................................................................................. 774.1.1

4.2 Basic Radio ......................................................................................................................... 80

4.3 Advanced Radio ................................................................................................................ 82

4.4 Rotor .................................................................................................................................. 89

4.5 Keyer .................................................................................................................................. 91



4

RigPi Station Server Version 3 
 
                                                                                                                                                                                                                          © 2021 Howard Nurse, W6HN

Table of Contents

4.6 Log Designer ...................................................................................................................... 97

4.7 Spots ................................................................................................................................. 100

4.8 Band Filter ........................................................................................................................ 101

4.9 Slider Overrides ............................................................................................................... 102

4.10 Macros .............................................................................................................................. 103

4.11 System .............................................................................................................................. 115

5. Other Programs
 
                                                                                         119

5.1 Overview .......................................................................................................................... 122

5.2 Alsamixer .......................................................................................................................... 123

5.3 Connecting to RSS with External Programs .................................................................. 124

5.4 Contour ShuttleXpress .................................................................................................... 126

5.5 Fail2ban ............................................................................................................................ 128

5.6 Flarq .................................................................................................................................. 128

5.7 Fldigi ................................................................................................................................. 128

5.8 Flic Switch and iOS Shortcuts ........................................................................................ 129

5.9 JS8Call ............................................................................................................................... 133

5.10 Message Aggregator ....................................................................................................... 134

5.11 Motion (Video) ................................................................................................................ 134

5.12 Mumble ............................................................................................................................ 138

5.13 Mumble Autostart .......................................................................................................... 143

5.14 Panadapter ...................................................................................................................... 144

5.15 Relay Switching ............................................................................................................... 144

5.16 TrustedQSL ....................................................................................................................... 145

5.17 Update RSS Files .............................................................................................................. 145

5.18 USB ID ............................................................................................................................... 145

5.19 WSJT-X .............................................................................................................................. 146

6. Technical
 
                                                                                                    149

6.1 Glossary ............................................................................................................................ 150

6.2 Installing the latest Hamlib ............................................................................................ 152

6.3 Panels ............................................................................................................................... 153

6.4 Programming ................................................................................................................... 159

6.5 Raspberry Pi Settings ...................................................................................................... 161

6.6 Resetting RigPi ................................................................................................................. 161

6.7 Rigpi.local on Windows computers ............................................................................... 162



5

RigPi Station Server Version 3 
 
                                                                                                                                                                                                                          © 2021 Howard Nurse, W6HN

Table of Contents

6.8 RigPi Audio Update ......................................................................................................... 162

6.9 RigPi Keyer PTT ................................................................................................................ 166

6.10 RigPi Remote Keyer ......................................................................................................... 168

6.11 Schematics ....................................................................................................................... 176

6.12 Sharing Radios, Rotors and Keyers ................................................................................ 178

6.13 Supported Radio Features .............................................................................................. 180

6.14 System .............................................................................................................................. 182

6.15 Troubleshooting .............................................................................................................. 184

Index 0



This  page i s  intentional ly left blank.
Remove this  text from the manual
template i f you want i t completely blank.



Introduction



8

RigPi Station Server Version 3 
 
                                                                                                                                                                                                                          © 2021 Howard Nurse, W6HN

Introduction

1 Introduction

MFJ-1234C

RigPi™ Station Server v 3.0
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Introduction

RigPi Station Server (RSS) is a computer system designed to control your station and

facilitate on-the-air activities. RSS introduces a radically new way of station control by

using a server model for allowing multiple users and radios to be accommodated

simultaneously through standard Internet browsers.

RSS  Block Diagram

Account Controlled Radio Controlled By

Account 1 Radio 1 iPad and iPhone

Account 2 Radio 1 through Account 1 Google Nexus

Account 3 Radio 3 iPhone using CommCat Mobile

(discontinued)

Account 4 Not used None

RigPi is a Trademark of Howard L. Nurse, W6HN

1.1 Welcome to RSS

Welcome to RigPi Station Server!

RigPi Station Server (RSS) is an easy-to-use multi-operator, multi-radio (MOMR) amateur

radio control, logging, CW keying, spot management and call lookup system.
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Raspberry Pi 3 B+

Raspberry Pi 4 B

RSS is based on a Raspberry Pi computer running Linux plus RigPi Keyer and RigPi Audio

boards. RigPi Keyer uses the popular K1EL WinKeyer chip for keyboard or paddle input.

RigPi Audio is used for Voice-Over IP (VoIP) and remote operations, or for digital modes

and I/Q spectral display (panadapter).

The MFJ-1234 uses the Raspberry Pi 3B+ while the MFJ-1234B/C uses the 4B..  The 3B+ has

been superseded by the Raspberry Pi 4 Model B.  (RigPi 3 runs on either.) The Raspberry Pi

4 B is a small computer providing processing, 2-8 GB RAM, four USB ports, Ethernet port,

Wi-Fi and Bluetooth. The RigPi Keyer and RigPi Audio boards are connected through

Raspberry Pi GPIO connectors.

RSS is browser based. Radio control is through a browser, no other apps are required for

control.  It can be used with any Internet browser including those on Windows, Mac,

Chromebook, Android, iOS and Linux computers, laptops, and phones. You can open RSS

web pages on several devices at once. Because RSS is multi-radio, one browser can control

one radio and a second browser can control another radio.
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Many Windows logging programs can control RigPi using a free Windows program called

RigPi Hub.

RSS radio control uses Hamlib, a library of over 200 radio models and 30 rotors. As new

radios and rotors are added you can update the lists to keep current.

Other programs are provided with RSS for ham radio and general use. Fldigi and WSJT-X

provide a wide range of digital modes. TQSL prepares and uploads log files to ARRL LoTW.

Included software can replace programs on a desktop PC, including an email client, and

Office software including word processing, paint, spreadsheet, and database programs.

You can even play games on RSS!

RSS uses open source HTML5, PHP7, jQuery and Ajax, and MySQL (MariaDB). The three

Tuner graphics panels: frequency, s-meter and tuning knob, are proprietary and provided as

closed source under a distribution license. RSS uses Twitter Bootstrap for responsive web

pages. You can easily view and modify RSS programs to make changes or add your own

features. No specialized software coding tools are required.

1.2 Quick Start Guide

What is Needed

1. RigPi Station Server (RSS)

a. A Raspberry Pi 3B+ or Raspberry Pi 4B*

b. 5.1-volt, 3-amp Power Supply with a microUSB connector if using a Raspberry Pi 3B+

or a USB-C connector if using a Raspberry Pi 4B.

c. An Ethernet cable or Wi-Fi Internet connection to your router

d. Another computer or mobile device on the same network, or

e. A monitor with an HDMI connector for the Raspberry Pi 3B+ or a micro HDMI

connector for a Raspberry Pi 4B.  USB keyboard and USB mouse

f. For remote operations, a browser and Mumble VoIP client on your mobile device

2.   Ham Radio Transceiver

a. CAT connection for computer control

b. CAT USB interface cable (or serial-to-USB adapter)

https://rigpi.net/downloads.html
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c. Audio cables for VoIP or digital mode software, CW and PTT keying cables or a radio

with internal CODECs.

*Note: the MFJ-1234 cabinet is not compatible with the Raspberry Pi 4B because of

connector locations.

Connecting RSS to the Internet (Ethernet Connection)

The drawings below are for the MFJ-1234 which uses a Raspberry Pi3B+ board.  The MFJ-

1234B/C have a slightly different design to accomodate the connectors on a Raspberry Pi

4B.

1. Connect an Ethernet cable from your router to RigPi Station Server.

2. Plug in the RSS 5.1-volt power supply. 

The two lights below the RSS KEY jack indicate power (red) and activity

(green). The green light blinks as RigPi boots.  The red light should not blink.

 If it does, the power supply may be underrated or faulty.

3. On another computer or mobile device connected to the same network, open a

browser window. Navigate to rigpi3.local.

Apple Bonjour is required on Windows computers to find rigpi3.local.  See

the Technical topic in Help for more information on Bonjour.
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Without Bonjour, you can use the RigPi IP address instead. Log in to your

router and look at connected devices. You will see the Raspberry Pi listed

there along with its IP address.

4. The RSS Login screen appears after RSS has completed the boot process. (See

below.)

Connecting RSS to the Internet (Wi-Fi Connection)

RSS has built-in Wi-Fi if an Ethernet cable isn't convenient.  If you need to connect using

Wi-Fi rather than using an Ethernet connection, a monitor/keyboard/mouse must be

connected to RSS.

1.  Connect a computer monitor having an HDMI input (micro HDMI input if using a

Raspberry Pi 4B), USB keyboard and USB mouse to RSS.

2. Plug in the RSS 5.1-volt power supply.

The two lights below the RSS KEY jack indicate power (red) and activity

(green). The green light blinks as RigPi boots.  The red light should not blink.

 If it does, the power supply may be underrated or faulty.

3. The Raspbian PIXEL Desktop appears after RSS has completed the boot process.

4. In the upper-right corner of the Desktop click the Network icon (Up/Down arrow).

5. Select Turn on Wi-Fi, then click the Network button again.

6. Select the network you wish to join from the list.

7. In the Pre Shared Key box enter your Wi-Fi password, then click OK.

8. While the Desktop is open, click the Raspberry Menu icon and navigate to

Preferences>Raspberry Pi Configuration>Localization.

9. Enter the Locale, Timezone, Keyboard and Wi-Fi Country for your location.

10. Click the RSS icon (a Pi symbol) to start RSS.  The RSS Login screen appears.
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Set Screen Resolution

The Raspberry Pi desktop is set to a resolution of 640 X 480.  To change to a higher

resolution, open the Application menu on the desktop and go to Preferences>Screen Con-

figuration.  In the Configuration window go to Configure->Screens>HDMI-1>Resolution

and select the resolution you wish to use.  Go to Configure->Apply to set the resolution.

Connecting to your Radio

RigPi controls the frequency and mode of your radio through a CAT (Computer Aided

Tuning) connection to a USB port.  Most modern radios provide a USB connection which

require a USB A-B cable.  Older radios have a variety of connection requirements, although

each manufacturer is usually consistent from one radio to another.  Check the manual for

your radio for specifics on what type of cable is required.

Manufacturer Older Model CAT Connection

Kenwood DB9 Serial, requires serial-to-USB adapter

Icom CI-V 3.5mm, requires CI-V-to-USB adapter

Yaesu DB9 Serial, requires serial-to-USB adapter.

Older Yaesu radios also require a level

converter.

 Audio connections to your radio are covered later in this manual.  CW Keying requires a

cable between the KEY jack on RSS and your radio's keying input (more later).

Accessing RigPi

RigPi 3 can be accessed by entering rigpi3.local in a browser's navigation bar.  If your

browser can't find rigpi3.local, it may be necessary to install Bonjour on your computer. 

See Bonjour Help elsewhere in this manual for details.  Alternatively you can use the IP

address of RigPi 3 as found in the list of connected devices in your router.

Exploring RSS, Startup Windows
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1. RSS is shipped with Username 'admin' and no (blank) Password.  

2. Enter admin in the Username box.

3. Press Enter (leaving the Password field blank).

4. The RigPi Express User Settings window appears
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RSS Express Setup has two windows, each containing settings required to get you going

rapidly.  Express User Settings allows you to enter your Call, location, and optional QRZ

XML subscription credentials.

Click Fill Below from Callbook to enter your name, state and grid square.  If you haven't

specified QRZ credentials, RigPi uses the onboard FCC database to fill in the information. 

This only works for US hams.

 

Express Radio Settings is configured with the Hamlib simulated radio, Dummy.  You can set

up your own radio or  continue to use Dummy by skipping the Express Radio Settings.

Note: RigPi uses the default Baud rate for your radio.  If you have  changed the radio's

Baud rate you must use that Baud rate in RigPi.  Enter the Baud rate in SETTINGS-

>Advanced Radio.

Back Up Your Memory Card

Memory cards have a limited lifetime, so it is good practice to back up your card as

insurance.  For details on how to make a backup copy please refer to the System topic  in

the Troubleshooting section of Help.

Shutting Down

182
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Never disconnect the RigPi Station Server power supply without shutting down the

RigPi Raspberry Pi first. Disrupting the power before shutting down can corrupt the

microSD memory card.

1. Go to SETTINGS>System.

2. Click the Shutdown button.

3. Wait for the green activity light to stop blinking.

4. Disconnect the power.

Enjoy RigPi! Additional Help is available

· RSS Toolbar Help

· Online forum: RigPi Forum

· RigPi online help: Online Help

· PDF Help file: Help PDF

· MFJ Online technical support: support

· MFJ telephone support: 1-662-323-0549

1.3 What's New

This topic will contain information about new features as they are added, bug fixes and

other improvements.

3.0 changes 11/1/2021 (MFJ-1234C)

· Latest Mumble  client, 1.4 Release Candidate

· New bands added: 1.25m, 70cm, 23cm

· New Modes added: RTTY, RTTY-R, PKTUSB (USB-D)

· Remote character-based CW  (in addition to currently supported element-based,

requires RigPi Hub 2.0.1 for Windows)

· iOS shortcuts  to control RigPi

· "Tune To" macro  for setting frequency, mode and passband

· Set max level for sliders  or disable them

· Assign macros to F-keys  (F1-F12)

138

168

129

103

102

103

https://rigpi.groups.io
https://rigpi.net/help
https://rigpi.net/help/RigPi.pdf
http://mfjenterprises.com/custsupport.php
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· Latching macros  for toggling commands

· Assign colors  to latching macros

· Disable/enable band buttons  in Tuner window

· Continent setting in User Editor now a drop-down

· WSJT-X logged QSO's now properly transfer to RigPi (fix)

· Bank buttons on Tuner window separated, lock button moved

· Macro, Open web page  (such as QRZ.com) to current DX call

· Macro, Open web page  (such as DXSummit.fi) to current DX call or current

band/mode

· Macro, set CW speed

· Last used macro bank is shown in Tuner and Keyer windows.

· Additional Flic commands : send CW message; send arbitrary radio command; tune

to band; start radio

· Latest amateur radio program updates

· Web view uses map resource  that doesn't require intermediate server

· RigPi Hub updated to support character CW.

· Added BleachBit as System Utility for cleaning disk

· Select PTT Toggle or PTT Momentary

2.0 changes 10/1/2020 (MFJ-1234B)

· Raspbian Buster operating system, compatible with Raspberry Pi 4 Model B and

earlier.

· New settings for hardware, CAT and custom PTT control.

· Tap PTT or space bar to transmit, tap again to receive.

· Auto repeat for Tuning Knob +/- buttons.

· Lock Tuning Knob button.

· "Connect Radio" on Tuner turns on radio (supported radios only).

· Now use long ID name  for devices, better than USB ID for ambiguous connections.

· Remote CW Keyer .

· Delete text using backspace key when in CW HOLD mode.

· Settable PTT delay to remove noise at the beginning of a transmission.

· Macro stacking  (more than one macro in each definition) fixed.

· Save/Restore Macros , Macro sharing.

· Over 27 new radios and numerous fixes added with updated Hamlib 4.0.

· Security improvements, including addition of Fail2ban.

· Auto update Raspbian files.

· Auto expand image to fill SD card.

· Bug fixes when adding more than 3-4 users, rotor control and METER setting for

transmit meter.

· Hardware PTT for WSJT-X when radio requires it to switch audio paths.

· New PTT On and PTT Off macros for controlling a power switch.

· Access level 4 added that prevents transmitting (PTT and Keyer).

103

103

101

103

103

103

129

71

82

82

168

103

103
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· Support for Flic  remote switch (PTT, Power On/Off, Relay control)

· Slave port, using Kenwood CAT commands, for controlling SteppIR antennas,

compatible power amplifiers and Kenwood radios.

· Control the Ameritron RCS-12  Automatic Antenna Switch or other antenna

switches (requires special cable).

· Control 8 on/off devices with macros (requires special cable).

· Control 8 on/off relays  with macros or LED graphics.

· Detailed radio, rotor and RigPi access logging.

· 128 Macros, 4 banks of 32.

· New easy-access Macro button layout.

· RigPi Video  to watch your radio when operating remotely.

· Support for Contour ShuttleXpress  multimedia controller to control RigPi

frequency and PTT.

· Improved operation with CommCat Mobile  for iOS including direct radio macros.

· Sliders for AF, RF, Power and Mic levels in Tuner and Keyer windows (only for radios

that support changing these levels by CAT).*

· Slider for setting CW speed in Keyer window.

· Additional meter readings for transmit.

· Updated Help.

*If you find your radio is not responding correctly to sliders, analog level reading for that radio may not be fully
implemented.  In addition, some radios only support several fixed levels for a slider rather than a continuous
range.  Please post a note on the RigPi Forum to let us know of any problems you encounter.

1.05 Bug fixes 6/21/2019

· Power On for Elecraft KX3 operates only when that radio is selected for the current

account.

· Adds information  in Help for a new overlay for RigPi Audio to fix several issues.

· Improved security in several modules.

· Addition of Security Topic  to Help

1.04 Bug fixes 6/12/2019

· Split for Icom radios when Split Polling is disabled is now working.

· KEYPAD double entry using smaller iPhones fixed.

· Improvements in TCP connections for RigPi Hub.

1.03 Bug fixes 5/29/2019

· Fixed Power On/Off for some radios that support it.

· Password issues fixed.

· Icom CI-V instructions in Help fixed.

129

82

144

134

126

124

162

27
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1.02  Bug fixes 5/13/2019

· Disconnect radio from Tuner to permit manual entry of frequencies and mode for

new contacts in Log Editor.

1.01  Bug fixes 5/11/2019

· Log Editor for new contact, TX and RX frequencies are equal when in simplex mode.

· Express User Settings, change to Username doesn't require a new login.

· Help updates

1.0  Initial release (MFJ-1234)

1.4 Raspberry Pi Desktop

The Raspberry Pi Desktop is similar to many graphics desktops. The Raspberry Menu button

in the lower left on the Task Bar is similar to a Windows File menu. Most buttons and icons

have a right-mouse menu for additional options.  You can access the Desktop by

connecting an HDMI monitor to RSS, or by using VNC Viewer to access it from another

computer.

The position of the Task Bar can be set to top, bottom, or a side.  To change the position

(shown at the bottom, above), right-click over the Task Bar and select Panel Settings.  In the

Panel Preferences window, select the Edge Position you prefer.
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Function Description

1 Raspberry Applications Menu

2 Web Browser Chromium browser

3 File Explorer Navigate file system

4 Terminal Shell access to RSS

5 VNC VNC Server--use VNC Viewer to connect from another

computer.

6 Bluetooth Bluetooth enabled

7 LAN LAN/Wi-Fi active connections

8 Speaker Audio enabled

9 Clock Local time

10 Trash Delete files go here

11 Mumble Autostart Control boot behavior of Mumble client.

12 USB IO Assign name to USB cable for easy identification.

13 RigPi Start RigPi in Chrome browser. It is best to connect to RigPi

using an external browser, not the Raspberry Pi browser.  By

using an external browser the limited resources of the

Raspberry Pi can be heloed by sharing the load with another

computer.

Setting up the Raspberry Pi

When you first start RSS you will need to make changes to the Raspberry Pi to adjust to

your needs and location.  These settings are done through the Applications Menu (1)

>Preferences>Raspberry Pi Configuration menu item.  

The Configuration window has four tabs at the top: System, Interfaces, Performance, and

Localisation (sic).  
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In the System tab, click the Set Resolution button. Select the resolution appropriate for your

monitor.

In Localisation settings change: Locale, Timezone, Keyboard and Wi-Fi Country.

Change the font/icon size relative to the screen using the Appearance Settings in the

Preferences menu. Defaults are provided for large, medium and small screens.

Finally, if you want to enable Wi-Fi, click the up/down arrow button (7) on the right side of

the RPi menu bar.  Left-click, then click Turn On Wi-Fi and follow the instructions.

1.5 Universal Functions

Each RigPi window has functions that are present on all other RigPi windows.

Function Where is it Description

RigPi Logo Red "Pi" logo at

left end of the

RigPi Menu bar

Click to open the RigPi web site:

https://rigpi.net

RigPi Menu

Bar

Top of RigPi

window

A menu bar is provided to open RigPi windows.

Several menu items have drop-down lists

showing additional options. The SETTINGS

menu is shown in full for ADMIN users, access

level 1.  The Users and System options are not

shown for access level 2. The SETTINGS menu is

not shown at all for access level 3. The Keyer is

not shown for access level 4.

Callsign

Lookup

Right end of RigPi

Menu bar

Look up callsigns using the RigPi FCC Database,

or the optional QRZ XML subscription database.

Type a call and press Enter on your keyboard or

click the magnifying glass button to look up a

call. The focus call is carried from window-to-

window, and restored the next time you start

RigPi. (QRZ XML access requires an Internet

connection and a paid subscription.)

https://rigpi.net
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Function Where is it Description

Log Out Right end of RigPi

Menu bar

Log out from the current RigPi account.

Radio Status

Bar

Bottom of RigPi

window

The radio status bar at the bottom of each RigPi

window shows Main frequency, Sub frequency

(if Split is turned on), mode, the current user

and user name, and the current UTC time.

Callsign Lookup

The Callsign Lookup panel shows detailed information for the entered call.  The

information comes from the onboard FCC database, or if enabled with a username and

QRZ password, from the QRZ XML service. At the bottom of the panel you can control your

rotor by clicking Rotate or Stop.  Set up you rotor in SETTINGS>Rotor.  Note RSS comes

with the Hamlib Dummy rotor installed for you.
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Note: The distance and bearing are relative to your location.  If you have not entered your

location accurately, these values will not be correct.
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1.6 RSS on Mobile Devices

RigPi can be used on any mobile device that provides an Internet browser. Since RigPi uses

a browser, no app is required (other than Mumble for audio).  Here are several samples of

how the Tuner window appears on mobile devices.

iPad Pro

Single connection to one radio, landscape mode

iPhone
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One connection to RigPi, one radio, Tuner, portrait mode
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One connection to RigPi, one radio, Tuner, landscape mode

1.7 Security

One of the primary uses for RigPi is to allow you to control your station when you are away

from home.  Remote control requires that you open paths through your router to allow

incoming data to establish a connection with RigPi.  Without further safeguards RigPi's

password/account system is open to malicious attack that could render your RigPi useless.

While RigPi is technically capable to operate remotely across public networks like the

Internet, it's design and development to date has been focused on use within trusted

private networks (home and/or VPN.)  

RigPi 3.0 has been tested with the Joval vulnerability scanner and no vulnerabilities were

found.

https://jovalcm.com/topics/open-source-oval-scanner/

OpenVPN

A technology called OpenVPN is one way to increase protection since it uses an encrypted

key at both ends of a connection to prevent others who don't have the key from invading

your system.

https://jovalcm.com/topics/open-source-oval-scanner/
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Two links to sites that show simple ways to install OpenVPN on the RigPi server are listed

below:

http://www.pivpn.io/

https://www.youtube.com/watch?v=04EmeXSZo_0

The two approaches are similar, use either one.

Fail2ban

Fail2ban is installed on RigPi to help prevent intrusions.  Fail2ban attempts to alleviate

attacks by providing an automated way of not only identifying possible break-in attempts,

but acting upon them quickly and easily in a user-definable manner.  Please Google

Fail2ban for more details.

The maximum number of failed attempts and the length of time an associated IP is

blocked can be set in Fail2ban.  RigPi allows three failed attempts after which the IP is

blocked for one hour.  When one hour has lapsed the block is removed.  Fail2ban protects

five services in RigPi:

RigPi Web access

Mumble

PhpMyadmin

Web bots

SSH access

Real VNC provides its own intrusion protection so it is not necessary to use Fali2ban for this

purpose.

Raspberry Pi Updates

It is critical to keep Raspberry Pi files up-to-date for security reasons.  When vulnerabilities

are present your system can be hacked.  RigPi 3 updates Raspberry Pi files automatically.

Remote RigPi Without Port Forwarding

RigPi normally requires ports to be opened on your router because that is the only way to

connect to a server.  RigPi uses a web server for radio control and a VoIP server for

Mumble.  By using a remote server you can forget about opening ports, port forwarding,

and the security downsides to running a server on the Internet.

Real VNC (realvnc.com) provides the VNC software for the Raspberry Pi.  A VNC server is

installed that allows you to use VNC Viewer to access the Raspberry Pi desktop.  Real VNC

http://www.pivpn.io/
https://www.youtube.com/watch?v=04EmeXSZo_0
https://realvnc.com
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also provides a free way to use their server using a Home account limited to 5 computers. 

You must set up an account with Real VNC, but once that is done, you can connect the

server on your Raspberry Pi and any viewers to their server.  To establish the necessary

connections no port forwarding or knowledge of your Internet IP is required.

In VNC Viewer you can connect to the Raspberry Pi desktop.  From there you can run RigPi

or any of the digital mode programs.

You can find full instructions on the Real VNC web site.

The other server running on RigPi that requires port forwarding is the Mumble server for

two-way audio.  Murmur servers are also available on the Internet for little or no cost. 

Rather than connect to the server on RigPi, by using a remote server you will not need port

forwarding.

One popular Mumble server service is Mumble.com.  If you sign up for a 2-year account the

cost is under $4 per month.  There are many other servers available (over 55 in the US

alone), just check the list in Mumble>Public Servers.

1.8 Passwords

Using custom passwords is critical to the security of your RSS if you intend to connect to

and control your station from the Internet. There are a number of passwords used in RSS.

Here is a list with the default values and the procedures for changing them.

Name Username Default Password Default

RigPi Login admin blank (none)

VNC pi 7388

Raspberry Pi Login pi 7388

PhpMyAdmin root 7388

VoIP Server password

to join server

Use your own unique username

for each connection

7388

https://mumble.com
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Name How to Change Notes

RigPi Login SETTINGS > Accounts >

Edit

Once you enter a password

you can change it but not set it

back to blank. Usernames and

passwords can be any

combination of upper and

lowercase characters but no

spaces are allowed.

VNC VNC > Options >

Security

Uses the Raspberry Pi

credentials. Use VNC Viewer on

a remote computer to connect

to the RSS Desktop.

Raspberry Pi Login Raspberry Pi

Desktop>Applications

Menu>Preferences>

Raspberry Pi Config-

uration > System >

Change Password

The Username can't be

changed in Raspberry Pi Con-

figuration.

PhpMyAdmin PhpMyAdmin> User

accounts > Change

Privileges > Change

Password

PhpMyAdmin is used to access

and edit RSS databases.

VoIP Server password to

join server

From RSS Terminal: sudo

 nano /etc/mumble-

server.ini then look

for serverpassword

The Mumble server runs on the

Raspberry Pi. You can also use

remote Mumble servers. Users

logging into the server for the

first time must be told this

password.

1.9 Accounts

RigPi accommodates multiple user accounts. Each account must have a unique username

and can control one radio. Each account can have the same callsign as other accounts. Two

accounts can control two radios. The maximum number of accounts/radios is limited by the

computing resources of RSS. Tests have shown this limit to be 4 or 5 accounts/radios active

at one time.
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Each account is like a separate logging/control program. Accounts have the following

independent functions:

§ Log in and Out

§ Allow multiple users to access that account

§ Personal call sign

§ Assigned security level to limit access

§ Control a single radio

§ Control a single rotor

§ Programmable set of macros

§ Frequency/mode band memories

§ Key CW for the radio for that account

§ Maintain a log

§ Receive spots from a unique source

§ Search call books and display results

Log In and Out

The user name and password are entered in the Log In window to access an RSS account.

(Usernames can be any combination of upper and lower case characters, but no space

characters are allowed.) Click the Log Out button in the top right corner of any RSS window

to log out. Once logged out you can then log back in to the same account or a different

account using the user name and password (if any) for that new account.

When you create an account a password is not required. This is useful if you will not be

accessing RSS from outside your local network. Once you create a password for an account

you can edit but not remove a password through the Account Settings window.

Access Level Assignment

Access levels are assigned for each account.

Access Level Access

1 The most permissive, level 1 (admin) accounts can

create new and edit existing accounts and assign a

security level, user name and password for all accounts

2 Account and System Settings menu items in SETTINGS

are hidden

3 All settings are hidden

4 Transmission is not allowed. PTT is disabled and the

Keyer window is not available.
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Allow Multiple Users to Access that Account

By sharing the account username and password, multiple users can log in and use that

account. This is useful if you want to access your account through multiple devices or have

multiple RigPi windows open at the same time. All users signed in to an account control

the same radio, rotor, CW Keyer and call book database.  (It is also possible to share a

radio from different accounts.)

Personal Call Sign

Each account has an assigned call sign. The call sign is used in CW Keyer macros and Telnet

Spot access. An account can have the same or different call sign from that used in other

accounts.

Control a Single Radio per Account

One radio can be controlled in each account. If you have more than one radio, set up an

equal number of accounts, one for each radio. RSS uses the Hamlib library to provide a

wide selection of manufacturers and radio models. A particular radio may not be fully

supported by Hamlib even though it is listed. See the Technical Help Topic to learn more

about determining what radio features are supported.

Each account and external programs can share an account's radio using a Hamlib radio

called NET rigctl. See the Technical Help Topic for information on sharing radios.
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2 RSS Connections

The Raspberry Pi provides a number of connections. Here is a list:

· USB 2.0 (4), or 2-USB 2.0/2-USB 3.0 Raspberry Pi 4.

· Gigabit Ethernet

· 802.11ac/n wireless LAN (2.4 and 5 GHz Wi-Fi)

· Bluetooth 4.2 Bluetooth Low Energy (BLE)

· HDMI (micro HDMI for Raspberry Pi 4B) video/audio

· 3.5 mm audio out

· Micro USB (USB-C for Raspberry Pi 4B) power

The RigPi Audio and RigPi Keyer have their own connections described in the following

topics.  The drawings below are for the original RigPi.  RigPi 2 and later have a modified

design to accommodate connector positions.
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2.1 Radio Control

RigPi controls each radio through one of the four USB connectors on the Raspberry Pi.  If

your radio has a classic serial port, a serial-to-USB adapter is required.  Older Icom radios

provide CAT through a CI-V system.  A CI-V to USB adapter is required.  Most newer radios

use a USB connection for CAT control so no adapter is needed.

If you are using ADMIN as your callsign you can use the Express Radio Settings window to

configure the radio connection. Normally you will use SETTINGS>Radio>Basic or

SETTINGS>Radio>Advanced.  Advanced settings may be necessary if you have changed

any of the default settings on your radio.  If not, Basic settings will work best.

In Basic settings, select the Manufacturer, Model and Port from the drop-down menu lists.  

If the radio USB cable is the only one plugged in, the port will usually be /dev/ttyUSB0. 

You will also see the long name starting with /dev/serial/by-id...  Select the long name,

then click the Connect Radio button.
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If the radio doesn't connect, please see the Radio>Advanced topic in the Settings section

of this Help for troubleshooting support.

Power On/Off

Most radios are able to be powered on and off by means of special CAT commands.  Use

the PWR ON/PWR OFF macros to turn your radio on and off.  The power on commands are

also sent to the radio when you use the Connect Radio button and the radio is not turned

on already.  The power on cycle can take up to 40 seconds for some radios.

Connecting to a Radio through a TCP port

It is possible to connect to a radio through an Internet connection rather than through a

USB port.  For example, your radio may accept an Ethernet connection for CAT control, or

you may be using a serial-to-Ethernet or serial-to-Wi-Fi adapter.

For an Ethernet connection, enter the IP and port in the Port box in Radio Settings.  If I had

a radio connected to 192.168.1.80, port 4999, I would type the following in the Port box:

192.168.1.80:4999

You must type this information into the box, it does not appear in the drop-down list for

Port options.  When you save the Radio settings, the IP:Port value is saved.

2.2 Rotor Control

Important

RigPi uses your location and the location of a remote station to predict

the correct bearing.  You must enter your location's latitude and

longitude in SETTINGS>Accounts>Account Editor for this to work.

RSS controls each rotor through one of the four USB connectors.  If your rotor controller

has a classic serial port, a serial-to-USB adapter is required.

Use SETTINGS>Rotor to configure your rotor.

In Rotor settings, select the Manufacturer, Model and Port from the drop-down menu lists. 

 If the rotor USB cable is the only one plugged in, the port will usually be /dev/ttyUSB0. 

Save the new settings and restart the Radio connection.  The Rotor is initialized with the

radio at the same time.
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For rotors that connect via a USB cable, the long name for the connection may appear in

the port drop down list.  Select the long name to provide persistence after a reboot.

2.3 RigPi Audio

Audio to and from your radio is used for two-way audio (VoIP) for remote operation or for

digital mode programs.  Audio can be routed through the RigPi Audio board, an external

USB audio soundcard, or through audio CODECs built into many newer radios.

The default audio device for RigPi is selected from the device list shown by right-clicking

the speaker icon on the Raspberry PI desktop.  The RigPi Audio board uses the device

named snd_rpi_proto, while most radio CODECs are designated as USB Audio CODEC. 

Choose the one you want to use.

The instructions below assume you will be using the RigPi Audio board and not an external

CODEC. Instructions for using CODECs are provided later in this manual.

RigPi Audio can be used with VoIP or digital mode and spectrum analyzer programs. RigPi

Audio is connected to RSS through the Raspberry Pi GPIO header, is does not connect via

USB. Right-click the Speaker icon on the top right end of the RSS Desktop menu bar to

confirm that the RigPi Audio driver, snd_rpi_proto, is listed and selected. See the Alsamixer

Help Topic if you need to troubleshoot.

If you see an entry for audioinjector-pi-soundcard you will need to follow a simple

procedure to manually update RigPi.  The instructions for making the change are in the

RigPi Audio Update topic, Technical section, of this Help..

RX IN

Connect the audio out from your radio to the RX IN 3.5mm jack. The tip and sleeve

connections are isolated through a transformer to reduce the possibility of hum.

RX IN can be set up to provide a line or microphone input. The default is line input with a

maximum of 2-volts peak-to-peak. To accommodate lower level audio sources, the RX IN
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input can be switched to a microphone level input. This is done using a program called

Alsamixer. See the Alsamixer topic in Other Programs to learn how to use Alsamixer.

TX OUT

Connect TX OUT to your radio audio input. The tip and sleeve connections are isolated

through a transformer to reduce the possibility of hum. The TX OUT ring connection has

several purposes. Normally it is used to control the PTT connection on your transmitter. By

changing a jumper on the RigPi Audio board you can use it to turn on power to an Elecraft

KX3 radio. As shown below, the yellow jumper JP1 is in the normal PTT position. Connect

the jumper between pins 2 and 3 for the KX3 Power On position.

The easiest way to connect audio to a radio is through a rear-panel accessory (Data) input

jack. Most radios that provide this connection also require PTT at that jack to switch audio

input from the front-panel microphone jack to the accessory jack. The PTT connection on

the ring of the TX OUT connector can be used for this purpose.

I/Q IN

The I/Q input connection provides a way to connect the IQ signal from many radios such as

SDR and the Elecraft KX3 to perform spectral analysis. Similar to "Panadapters" that were

available years ago, an I/Q display shows a graph of signal level vs frequency over a wide

bandwidth. The bandwidth in RSS is limited to 96 kHz as determined by the sampling rate

of the audio chip used.

The I/Q input uses the left and right stereo inputs to the audio chip. The signals are not

transformer isolated. Use Alsamixer to make sure RigPi Audio is in the Line Input mode.

RigPi Audio with Mumble VoIP

Mumble is software that provides 2-way audio between your radio and a remote device,

such as an iPhone or Android mobile phone.  A Mumble server (named Murmur) is installed

on RSS and always runs in the background.  Mumble clients connect to Murmur for passing

audio.  One Mumble client is installed on RSS and is normally started on the Raspberry Pi

desktop when RSS boots.  Mumble clients on other devices connect to the same Murmur

server where input and output audio is heard by all connected clients.
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The Mumble client in RSS connects to your radio.  Receive audio is fed to the Mumble

client input and Mumble client output is fed to the radio mic input.  The radio audio is

provided to and from Mumble through the RigPi Audio board or a CODEC built in to the

radio.  If your radio has a built in CODEC for audio, the RigPi Audio board is not used.  In

this case, audio to and from the radio is carried over the USB CAT control cable.

Setting up the RigPi Audio Board for VoIP

RigPi Audio can accept audio through a microphone or line input source.  If your radio has

high output level (no more than 2-volts peak-to-peak) you should use the line input.  If

your radio audio output is low (no more than 200-mV peak-to-peak), use the microphone

input. RSS uses the microphone audio input to start. If you want to use line input, the input

selection is made through Alsamixer.

Use the RX IN connector for audio from the radio and TX OUT for audio to the radio.  You

can also use a cable customized for your radio from MFJ.  The custom cable connects to

the RJ-45 connector on the USB/Ethernet end of the RSS cabinet.  The left 

 is used for input and output.  These connections are transformer-isolated.  If you are using

an RJ-45 cable, you must also use a jumper header in RigPi to complete the connections. 

MFJ cables come with a prewired header for the radio you have specified.  A jumper

header is installed on the RJ-45 daughter board, as shown below.
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RigPi Audio does not have any onboard adjustments.  RigPi Audio levels can be set

through Application Menu (1)>Sound & Video>PulseAudio Volume Control, or through a

program called Alsamixer.

In PulseAudio Volume Control, use the Playback and Recording tabs to increase or

decrease levels.

Alternatively, start Alsamixer from the Terminal window on RSS Desktop.  Open Terminal

and type:

alsamixer<return>

Here is the alsamixer view for the RigPi Audio board:



43

RigPi Station Server Version 3 
 
                                                                                                                                                                                                                          © 2021 Howard Nurse, W6HN

RSS Connections

...and for a CODEC:

Note the following Alsamixer controls:

Use left/right arrow keys to move between settings

Playback options (F3)

1. Card: snd_rpi_proto (RigPi Audio), use F6 to select

2. Master gain set high, use up and down arrow keys to adjust
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3. Mic Boost set high, use up and down arrow keys to adjust

4. ADC High Pass On, use M key to toggle

5. Input Mux Mic, use up/down arrow keys to adjust

6. Output Mixer On (OO, use M key to toggle

Capture options (F4)

1. Line [Off, Off], use Space bar to toggle

2. Mic On, use Space bar to toggle

3. Mic Boost (high), up/down arrow keys adjust

4. Capture (high), up/down arrow keys adjust

Setting up CODEC audio for VoIP

Please see the Mumble topic  for details on using radio CODECs for audio.

Mumble Clients

On Windows, Macintosh and iOS, use the client named Mumble.  The client for Android

devices is named Plumble.  They all operate in the same way.  Start Mumble (or Plumble)

and open the Favorite Servers settings.  Click the + button to add a new Favorite.

Complete the Description, Address, Port, Username and Password settings.  The Address

holds the IP for the Murmur server, the Port defaults to 64738, Username can be your call,

and password 7388 (unless you have changed it).  The Username MUST be unique.  If you

have a tablet and phone, both running Mumble, one can use your call as Username and the

other must use something like <your call>-1.  You can also use phone as a username and

tablet as the second username.

Radio Quirks

Most radios provide audio connections that are straightforward.  Some radios, notably

Kenwood, can provide audio connections through a Data connection on the rear panel. 

You will find many more details on the RigPi forum.  Use the Search function to look for

information in Topics.  There are also a number of documents in the Files section that deal

with specific radio connections and setups.

Kenwood radios with a Data connector

Since the radio normally expects audio to come through the microphone connector,

a switch signal must be provided to the Data connector.  The switch signal is

normally PTT.  This means that you must make three connections if you are using the

rear panel Data connector: audio in, audio out, and PTT.

138
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Yaesu (HF models)

Some Yaesu radios only pass audio when in digital/PSK mode, such as the last
generation of HF radios (FT-817(ND), FT-818ND, FT-857(D), FT-897(D)).  For full
functionality, a microphone interface is needed.

Audio routing determined by menu settings

It may be necessary to change menu settings in your radio to provide an audio path

through a rear panel connector.  Some radios, such as the Yaesu FT-950, only allow

transmit audio to pass through the Data connector using the PSK mode.

Mumble Settings

See the Mumble topic in Other Programs for the necessary settings.

2.4 RigPi Keyer

RigPi Keyer is a versatile Morse code generator based on the popular K1EL WinKeyer3 IC. It

connects to the Raspberry Pi through the GPIO header and uses the onboard serial port,

ttyS0.

Keyer Connections

Connection Use Note

PTT Pull-down

when in

transmit

Can be

reconfigured

as a general

puspose

switch.
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PADDLE Connect a

paddle to

control the

keyer using

tip, ring and

ground

You can also

use a straight

key

connected

between tip

and ground.

KEY Connect to

you

transmitter

keying input.

RigPi Keyer can be used with a paddle or straight key plugged into the PADDLE jack with

or without a radio connected.  The KEYER SPEED control works when the keyer is not under

RigPi control and when using any of the main RigPi windows.

RigPi Keyer has a PTT switching circuit that normally follows PTT commands from RigPi. 

You can also use the WinKeyer3 PTT circuit independently through commands.

Independent control means that you can use the RigPi Keyer PTT for remote control

purposes, such as controlling a power switch. See the Technical RigPi Keyer PTT topic of

Help to learn more about extended uses of RigPi Keyer PTT.

Settings

The RigPi Keyer settings are located in SETTINGS>Keyer. Morse can be sent by typing on a

keyboard, through a custom Macro, or by means of a keying paddle. It is possible to use a

straight key as well as a paddle.

The WinKeyer3 IC has an extensive set of programming commands, many of which are

used in RigPi. You can also create Macros using these commands for special purposes.

Remote Keying

When away from home you can use your favorite hand key to send CW from your home

station.  A second RigPi, external Winkeyer/Raspberry Pi, or RigPi Hub with a Windows

program that can key RTS or DTR is required.  RigPi does not have to have an Audio board.

 You can use a paddle, bug, or straight key.  Please see the RigPi Remote Keyer topic  for

details.

168
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2.5 Internet Connections

RSS is designed to operate without Internet access. This feature makes it convenient when

taking RSS away from your home for portable or mobile operation. Several non-critical

features that do rely on Internet access are listed below:

1. QRZ XML Call look up service (Callbook)

2. World map (Web)

3. Update FCC Database (System settings)

4. Spots (Spots and Spots settings)

5. LoTW downloads and submissions

Even if you do not have an Internet connection you can use RSS Wi-Fi to connect to other

computers. It is easy to set up an ad hoc network so other computers or mobile devices can

communicate. Wi-Fi can also be used in lieu of an Ethernet cable to connect to a router.

Here is a link to several messages on Stack Exchange that give instructions for setting up

Wi-Fi ad hoc networks on the Raspberry Pi and for making the Raspberry Pi IP static so it

doesn't change when you reboot.

Click to see Static Instructions

2.6 Remote Connections

RSS can be accessed from anywhere via the Internet. Access must be made available

through RSS settings. All user accounts must be password protected before you allow any

access.

Four ports must be opened: one for a browser, a second for VoIP, a third for VNC viewer

and a fourth for the Video Camera (optional).

Service Normal Port Protocol

RSS Browser

access

80 TCP

Mumble (VoIP) 64738 TCP/UDP

VNC 5900 TCP

Video Camera 8081 TCP

https://raspberrypi.stackexchange.com/questions/37920/how-do-i-set-up-networking-wifi-static-ip-address/37921#37921
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Service Normal Port Protocol

Remote CW 30040 UDP

Browsers, by default, connect to port 80 on a server. This access port must not be blocked

by a router or firewall. Your router's advanced settings provides a way to forward

connections from the outside to a specific LAN IP and port.

The LAN IP for RSS can be found on the System settings page (SETTINGS>System). It will

be an address like 192.168.1.20. The RSS browser, Mumble, VNC and Video Camera

ports must be able to transverse your router. This is called Port Forwarding.

Many routers provide a way to translate an incoming port to a different port. This

translation provides a higher level of security than simply forwarding port 80. Set the

External Starting and Ending port to something like 7488. Set the Internal Starting and

Ending ports to 80. Your router will now accept an incoming connection on port 7488 and

forward it to port 80 on rigpi3.local. When away from home you would instruct your

browser to connect to port 7488. If your router does not provide port translation, open port

80 instead and you will connect to the default browser port, 80.

The default Mumble port is 64738. This port must be forwarded through your router. You

can use the same translation trick as with browser connections, but you must also tell the

mumble client which port to use if not the default.

VNC Viewer gives you access to the RSS Desktop from any device.  VNC Viewer clients are

available for most operating systems and devices.  To use VNC Viewer from a remote

location you must forward the port used by VNC.  The default port for VNC viewer is 5900.

Configure Your Router's Port Forwarding

The following instructions apply to a Netgear R8500 Router. The steps for your router will

be different.

Netgear routers do port forwarding by assigning port numbers to a "service" that is

associated with the application you want to run.

To open the ports for RSS:

1. Type the router's address in an Internet browser's address bar. (By default the

router's address is 192.168.0.1 or 192.168.1.1). The Setup Wizard appears

2. Enter the router's username and password
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3. Under Advanced, click Advanced Setup, then Port Forwarding on the left menu

bar (varies slightly by Router)

A Port Forwarding Screen appears 

4. Click Add Custom Service. The Custom Services window opens

5. Enter RSS for the service name

6. Select TCP in the Service Type drop-down

7. Enter 7488 in the External Starting Port box

8. Enter 7488 in the External Ending Port box

9. Remove the check for Use the same port range for Internal Port

10. Enter 80 in Internal Starting Port

11. Enter 80 in Internal Ending Port

12. Enter the LAN IP for RSS in the Internal IP address

13. Click Apply

14. To add Port Forwarding for Mumble, click Add Custom Service and follow the

same steps

15. Use Mumble for the name. TCP/UDP for the type and 64638 in the External Port

boxes

16. Enter 64738 in the Internal Port boxes

17. Enter the LAN IP for RSS in the Internal IP address

18. Click Apply

19.To add remote VNC viewer access to open RSS Desktop, click Add Custom

Service and follow the same steps

20.Use VNC for the name. TCP for the type and 5900 in the External Port boxes

21.Enter 5900 in the Internal Port boxes

22.Enter the LAN IP for RSS in the Internal IP address

23.Click apply

24.To add access to the RigPi Video Camera, click Add Custom Service and follow

the same steps

25.Use VideoCamera for the name. TCP for the type and 8081 in the External Port

boxes

26.Enter 8081 in the Internal Port boxes

27.Enter the LAN IP for RSS in the Internal IP Address

28.Click Apply

29. Click Logout to exit from router settings

With RSS running, open canyouseeme.org with your browser and confirm that ports

5900, 7488, 8081 and 64638 are open.

To connect to RSS using a browser when away from home, enter the WAN IP (from

SETTINGS>System) followed by a colon and 7488:

97.222.46.198:7488
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The WAN IP above is fictitious, use your own. Now you can log in and control your

radio from anywhere Internet access is available.

To connect Mumble on your remote client, open the Edit window for the rigpi server

connection and change the port to 64638.

Important Port Forwarding Note

Some Internet Service Providers supply a Modem that contains a single-port router. If you

use an external router with such a device, port forwarding will not work without extra

settings. Here is an article on the web that explains the 2-router problem. If port

forwarding doesn't appear to work for you, please read this article.

Click to Go to PortForwarding.com

Note: Port Forward is an excellent resource for help if you run into trouble with port

forwarding. They also sell programs to aid with the process. Most port forwarding issues

can be solved without the need for other programs.

Password Protection

Since RSS is now open to the Internet, add passwords to all accounts before proceeding.

2.7 Using a Dynamic DNS Service

Your Internet IP can change from time-to-time, especially if you reboot your Internet

modem. If you are away when this happens, you won't be able to access RSS remotely until

you know the new WAN IP. One way to solve this problem is to use a dynamic DNS service.

One such service is available from 

https:///www.dyn.com.

The Dyn product, Dynamic DNS Pro, costs from $55/year up to $220 for 5 years. You can

also find free services. With Dynamic DNS you can choose a domain, such as

w1aw.dyndns.org. When you connect from a remote location you use this URL. If your

Internet IP happens to change, the domain stays the same.

https://portforward.com/help/doublerouterportforwarding.htm
https:///www.dyn.com
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3 Views

A view is a web page viewed through any browser. Each view has common elements, a

navigation bar at the top and a status bar at the bottom.

Navigation Bar

· Navigate to https://www.rigpi.net by clicking the RigPi logo or RigPi name

· TUNER...WEB: opens window

· SETTINGS: contains a list of settings windows, click the down-arrow.

· Search box: enter call to look up in the FCC database or option QRZ XML online

service. Press enter or click the magnifying glass to look up

· Exit RigPi

Status Bar

· Main frequency (shows red when no radio connected)

· Split frequency (shows when radio is in the split mode)

· Mode

· User, user's call and account username

· UTC Time

https://www.rigpi.net
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3.1 Tuner

1: Navigation Bar

· Navigate to https://www.rigpi.net by clicking the RigPi logo or RigPi name.

· TUNER...WEB: opens window.

· SETTINGS: contains a list of settings windows, click the down-arrow.

· HELP: sources of help for RigPi.

· Search box: enter call to look up in the FCC database or optional QRZ XML online

service. Press enter or click the magnifying glass to look up.

· Exit RigPi.

2: Tuning Knob

https://www.rigpi.net
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· Tap/click the detent and rotate knob to tune higher/lower in frequency. The tuning

scale is determined by the underlined digit in the frequency readout of the

Frequency Panel.

· Tap/click/hold the plus or minus button to move up or down in frequency. Hold

tunes in the same direction at the rate of 2 steps per second.

· Tap/click/ the PTT button to engage the RSS PTT function The PTT button can be

configured as a toggle or momentary switch. 

· L is a frequency lock button.  Tap to lock the frequency.

When using the Macro Decimal mode to control external relays, a row of LED lights

appears below the Tuning Knob.  Tap/click a light to turn on an associated relay,

tap/click again to turn it off.  One slave connection is available for all accounts.  If

you attempt to connect more than one RigPi will show an alert telling which
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account is already using the slave connection.  A radio must be connected before

relays can be controlled.

3: Macro Bank

· 128 macros with 4 banks of 32 programmable macro buttons (SETTINGS>Macros).

Macros can be used to send CW, control the radio through Hamlib commands,

control the radio through Hamlib "w" commands unique to the selected radio,

control relays, look up web information, and send system commands (the system

command option is disabled by default).  Change the Macro Bank using the a

Macro Bank button (10) or a custom macro.

4: Status Bar

· Main frequency (shows red when no radio connected)

· Split frequency (shows when radio is in the split mode)

· Mode

· User, user's call and account username

· UTC Time

· Only the Main Frequency is displayed in narrow screens

5: Sliders

· Sliders are hidden if your radio doesn't support changing levels by CAT.

· 4 sliders are provided: AF (AF Level); RF (RF Gain); PWR (Power Output Level); MIC

(Mic Level).*  The sliders adjust the radio front panel controls, not the CODECs (if

appropriate for your radio) or Mumble.

· Sliders can be set with a maximum level or disabled (SETTINGS->Slider Overrides)

*If you find your radio is not responding correctly to sliders, analog level reading for that radio may not be fully
implemented.  In addition, some radios only support several fixed levels for a slider rather than a continuous
range.  Please post a note on the RigPi Forum to let us know of any problems you encounter.

6: Band and Mode

· Tap a Band button to change bands or a Mode button to change modes. Each

band has a memory for the frequency last used on that band.

· Band buttons can be disabled (SETTINGS->Band Filter)

7: Radio Connection and VFO
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· Connect Radio (Green: connected; Red: not connected; Rotating Arrows:

connecting)

· Disconnect Radio

· VFO/Memory operations

· See below for details

8: Frequency Panel

When screens are wide enough to display the RSS S-meter, the frequency panel, above, is

used.

For narrow screens, where the S-meter is hidden, this format is used.

· Displays the Main and Sub VFO frequencies, band, the current UTC time, operating

mode and receive/transmit status. 

· A keypad is included to set the frequency of selected digits. See below for all

tuning options.
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· The Main and Sub frequencies have bars above and below each digit. When a digit

is selected the bars above and below the digit are bold. Tap/Click a digit to select

it. The selected digit sets the tuning resolution for the Knob and typed digits. Click

the lower half of a digit after selection to tune down and the upper half to tune up.

· Change the color theme of the Frequency Panel using Account Settings

(SETTINGS>Accounts>Edit). Four options are provided: Orange, Night, LCD, and

High Contrast. This setting also affects the S-Meter.

Callout Use

1 Information for Main VFO

2 Current band

3 Time (GMT)

4 Main frequency

5 Mode and transmit/receive status

6 Sub VFO information

7 Keypad for entering digits

8 Sub label and radio name

9 Tap to open keypad

10 S-meter

9: S-Meter

· Shows signal strength when in receive and an optional reading when in transmit.

There is no way to adjust the calibration of the S-meter. Some radios may not

support S-meter and/or optional transmit queries through CAT. The S-meter is not

shown on narrow screens. See the Advanced Radio settings

(SETTINGS>Radio>Advanced) for more information on the optional transmit

readings.

· Change the color theme of the S-meter using Account Settings

(SETTINGS>Accounts>Edit). Four options are provided: Orange, Night, LCD, and

High Contrast. This setting also affects the Frequency Panel.
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10: Macro Bank

· Macro Bank to change the displayed bank

Radio Connection and VFO Buttons

Button Function

Connect Radio Connect the radio for this account. You must set the radio up the first

time in SETTINGS>Radio. Green: connected; Red: not connected;

Rotating Arrow: connecting.  The control will turn on radio power

before connecting if the radio is off (supported radios only).

Disconnect

Radio

Disconnect the radio for this account.

A>B Copy the Main frequency to the Sub frequency.

A>M Copy the Main frequency to the RSS frequency memory. This function

does not use the memory in the radio.

M>A Copy the frequency in the RSS memory to the Main VFO

A<>B Swap the Main and Sub VFO frequencies.

SPLIT Turn on split for the radio. The Main VFO is used for receiving and the

Sub VFO is used for transmitting. Some Hamlib radios do not support

slit operation. Others cause readout flicker when reading or setting

split frequency. Split polling can be turned off in Radio settings

(SETTINGS>Radio>Advanced).

Frequency Tuning

Tuning options allow you to tune both Main and Sub VFO's in many ways.
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Option Operation

Mobile

Device

Support

Knob Rotate to tune up or down. Click a digit to set

resolution.

Yes

Knob + Tune up one step, determine resolution by clicking

a digit.

Yes

Knob - Tune down one step, determine resolution by

clicking a digit.

Yes

Click digit Click digit to select, then click upper half to tune up

or lower half to tune down.

Yes

Mouse wheel

(or

Shift+Mouse

wheel)

Rotate to tune up or down, click digit to set

resolution.

No

Keyboard > Move selection to next digit to right. No

Keyboard < Move selection to next digit to left. No

Keyboard ^ Tune selected digit up. No

Keyboard ˅ Tune selected digit down. No

Keyboard [ Down one band No

Keyboard ] Up one band No

Type

frequency

Select starting digit, then type new frequency. No

Type

frequency (2)

Tap/click starting digit, then tap/click numbers in

the keypad.

Yes
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Push-to-Talk

Several ways to engage Push-to-Talk (PTT) are provided. PTT uses CAT and solid state

switches on the RigPi Keyer and RigPi Audio boards. See SETTINGS>Radio>Advanced for

PTT options. See also Keyer settings for alternative ways to use the RigPi Keyer board PTT.

PTT can be Latching (tap to transmit, tap again to receive) or Momentary (hold to transmit,

release to receive).

Option Operation

Mobile

Device

Support

PTT to right of

Tuning Knob

Latch or Momentary PTT Yes

T/R Macro

button

Latch PTT Yes

Space bar Latch or Momentary PTT No
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3.2 Keyer

1: Sent CW

· Displays CW already sent to transmitter. Only RigPi Keyer and WinKeyer support

this function.

· Clear the sent data by clicking/tapping CLEAR LEFT.

· In HOLD mode, use backspace to delete text you don't want to send.

2: Typed CW

· CW characters sent to the Transmitter or waiting to be sent. All keyers support this

function.

· Clear by click/tap CLEAR RIGHT.

3: CW Keyboard special characters
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· See below

Button Function

HOLD Allow type-ahead without transmitting.

REPEAT Repeat characters in 'to be sent' panel.

CLEAR LEFT Clear all text from the left panel.

CLEAR RIGHT Clear all text from the right panel.

WPM Slider to increase/decrease the current speed.

SK Send SK prosign.

KN Send KN prosign.

AR Send AR prosign.

BT Send BT prosign.

BK Send BK prosign.

@ Send @ sign.
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3.3 Log

1: Navigating

Use the Log navigation bar at the top left of the log under the RSS navigation bar to move

from page-to-page. Up to 25 QSOs are shown on each page. Navigate to any page in your

log using the drop-down page list.

2: Log Name and Log style

Each log has a name and a style. By using distinct names you can maintain separate logs,

such as for contests or different accounts.

The name and style are shown at the center of the Log navigation bar. The number after

the style shows the number of contacts for that log.

Each log has its own style appropriate for its use. A log can be designed for any purpose,

such as Field Day, a DX contest, or for general use. Use the Log Designer (SETTINGS>Log

Designer) to design or modify the fields and field order that appear in each log.

The log style can be changed to a different style from the Style (book icon) button. The Log

can be selected from the Log (folder icon) button.
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Log styles are created and edited in the Log Designer window. Accounts can share logs and

log styles.

3: Add a new Contact

Click the + (plus) button to add a contact to the current Log. The Log Editor window opens

where you can add details for the contact and load information from the Callbook Lookup.

See the Log Editor topic for details.

4: Filtering QSO's

Click the filter (funnel icon) button to show contacts matching the call in the Callbook

lookup box in the top right of the RSS navigation bar. Click the filter button again to show

all contacts.

5: Export/Import ADIF

Amateur Data Interchange Format (ADIF) is the data import/export standard for amateur

radio logs. It allows logbook data to be easily transferred from one program to another.

ADIF is also the basis for submission of logs to the ARRL Logbook of the World (LoTW) and

other online logging systems. All downloads compress the ADIF file to the ZIP format.

Export transfers the ADIF from RSS to the local downloads folder usually on another

computer. Import transfers an ADIF file to RSS.

Export to Downloads Folder

Download all QSO's in the current log to the Downloads folder. If using RigPi from the RSS

Desktop, the Downloads folder is the one for RSS. If connecting to RSS from a remote

computer, the Downloads folder for that computer is used.

The file is given a name like rigpi<YOURCALL><Logname>-<n>.zip. For example, a file

containing my Mobile log would be named rigpiW6HNMobile.zip (first download) or

rigpiW6HNMobile-1.zip (second download).

To download all QSO's from all logs, select the ALL Logs option from the Log list (folder

icon).

Export Selected Q's
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Download the selected QSO's. To select QSO's the Select column must appear in the Log.

The Select column can be added using the Log Designer opened from SETTINGS>Log

Designer.

Export for LoTW

Download all QSO's in the current log with a subset of fields appropriate for LoTW.

Export Selected Q's for LoTW

Download selected QSO's in the current log using a subset of fields appropriate for LoTW.

Import

Upload files must not be compressed and have an extension .adi. For example, my upload

file might be named W6HN-11-12-2018.adi. RigPi asks you to identify the file you wish to

upload. RigPi then proceeds to import the adi file into the currently open logbook.

6: Editing an Existing Contact

Click the Edit button on the left end of a logged contact to open the Log Editor for that

contact. See the Log Editor topic for details.

7: Delete Contacts

Click the Delete button on the right end of a QSO line to delete that contact.

Entire Log

In the drop-down menu, deletes all contacts from the currently open log. If ALL Logs is

selected, all QSO's are deleted from all logs.

Selected Q's

In the drop-down menu, deletes the selected QSO's from the currently open log. To select

QSO's the Select column must appear in the Log. The Select column can be added using

the Log Designer opened from SETTINGS>Log Designer.

Sorting Contacts

Click the Up/Down arrowhead in a column header to sort the log by that column. Click

again to sort in the opposite direction. To return to date order, click the Start header.
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3.3.1 Log Editor

Use the Log Editor to add new or edit existing contacts. The Log Editor is opened by

clicking an Edit button on the Log window, or by clicking the + button at the top to start a

new contact.

The Log Designer (SETTINGS>Log Designer) sets the fields, field order, and label for each

edit box. You can also set defaults for each field and select the contents you want to

appear in a drop-down list.

Fill fields from the callbook for the call in the Call field by clicking the down-arrow at the

top. The onboard FCC database is used unless you have enabled the online QRZ XML

(subscription) option.

The Rcv Freq, TX Freq, Band and Mode boxes are filled automatically from the radio when

you create a new contact.  If you wish to manually enter the data for these boxes,

disconnect the radio from RigPi using the Tuner or Radio settings window.
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Cancel any changes by clicking the stop button at the top.

Save the contact by clicking the cloud up-arrow at the top.

By putting a check in the Stay in Editor After Saving option, the Log Editor will stay open so

you can continue to add new contacts.

Information coming from a default setting in the Log Designer is designated by the label

for that field given a green color. If a field has been designated as "no edit," such as a

record number, the value is shown in red.

3.4 Spots

The RigPi spots shows DX spots provided by one of a large number of DX Cluster Telnet

sites. The site you wish to use is selected in SETTINGS>Spots. See the Settings Spots

window topic for details. Click a spot to tune instantly to the frequency and operating

mode reported for that spot.



68

RigPi Station Server Version 3 
 
                                                                                                                                                                                                                          © 2021 Howard Nurse, W6HN

Views

A band map centered on the Tuner frequency shows all nearby spots. Click a spot to tune

to the reported frequency and mode for that spot.

1: Spot Source

· RigPi is connected to this Telnet spot source.

2: Connect/Disconnect

· Connect to specified Telnet site, or disconnect.

3: Spot Filter and Spot Color

· Spots are filtered by the Band and Mode options selected in the Filter (funnel icon)

drop-down list.

· Spots are colored depending on the color rule selected in the Color (paintbrush

icon) drop-down list.

4: Color Rule

· Spots are colored depending on the color rule selected in the Color (paintbrush

icon) drop-down list.

· Call fields are colored by call rules.

· Entity fields are colored by entity rules.

Color Rule

None No color used

Teal Call worked before (logged)

Green Call confirmed

Orange Call worked before on this band (logged)

Red Call confirmed on this band

Teal Entity worked before (logged)

Green Entity confirmed
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Color Rule

Orange Entity worked before on this band (logged)

Red Entity confirmed on this band

5: Spot Filter

· Spots are filter based on Band and Mode by selections in this drop-down list.

Filter Rule

Band All Spots: all spots (no band filter)

Band Follow Me: spots on same band as Tuner

Band HF: HF spots

Band Low Bands: low band spots

Band High Bands: high band spots

Band WARC: spots on WARC bands

Band VHF/UHF: VHF/UHF spots

Band 160

Band 80

Band 60

Band 40

Band 30

Band 20

Band 17
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Filter Rule

Band 15

Band 12

Band 10

Band 6

Band 2

Mode Show All: all spots (no mode filter)

Mode Follow Me: spots using same mode as Tuner

Mode Only CW: only CW spots

Mode Only Phone: only phone spots

Mode Only Digital: only digital spots

6: Frequency

· Current operating frequency

7: Band Map

· Spots near operating frequency

8: Spots

· Click spot to tune to spot frequency and mode.

9: Spot List

· Spots from current DX Cluster Telnet site.

· Sort the list by clicking the header, again to show the opposite order.

· With the mouse pointer over a spot box the Filter, number of minutes since spotter,

and spotter are displayed in a tool tip.
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3.5 Web

Web page for W1AW obtained from FCC data

Web page for W1AW obtained from QRZ XML data
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Callbook data for the Web page is obtained from the FCC database installed on RSS (US

calls), entity databases installed on RSS (US and other calls), or QRZ data obtained through

the QRZ.com XML subscription service. When the QRZ service is used, more information is

included, especially for non-US calls. This extra information can be additional station

details, the primary photo, and biographical text (which can also include additional

photographs).

FCC Data

The FCC amateur radio database is provided with RSS. An update function is provided in

System settings (SETTINGS>System) that can be used periodically to update the data.

1: Contact Information

2: Entity Flag

3: World Map

· Centered on approximate coordinates 

· Zip code is used for US calls.

· Country center is used for non-US calls.

4: Additional Info

· RSS Entity databases provide this information.

QRZ Data

QRZ data is available on QRZ.com through a subscription service. More information on

their subscription plans can be found on the QRZ.com site. RSS requires a QRZ username

and QRZ password to utilize this service.

1: Contact Information

2: Entity Flag

3: Primary Photo

· This photo is the image shown when you look up a call on QRZ.
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4: World Map

· The map is centered on coordinates from the QRZ database. 

5: Biographical Info

· The text is taken from the Biography in the QRZ database for this call.

· The text may include images and animated gifs.
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4 Settings

RSS is customized using settings windows. The settings, except for System, are unique for

each account.

Many settings get their data from drop down lists.  It is not possible to directly edit the

contents of the text boxes associated with these lists so the text box contents have a gray

background as a reminder.

4.1 Account

All accounts having access to RSS are listed in the Account settings list

(SETTINGS>Accounts). The list shows whether or not the account is connected, the access

security level for that account plus more. Account Settings is only available for Access level

1 accounts.

Editing User Accounts

Edit any user account by clicking the green Edit button at the right end of each list line.

Deleting User Accounts

The primary account, ADMIN at first, can't be deleted. Accounts added after the primary

account can be deleted by clicking the red Delete button at the right end of each row in

the Account list.
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Creating new User Accounts

In the Account Settings window, click Add (plus button at top) to add a new account. Use

the guidelines above to complete the form. Once the account is saved the Login window

appears so you can test the new account or return to another account.

See the table below for information about each column in the Account Settings list.

Function Name Note

User connected On Y if that user is connected, otherwise N

Callsign Call Call for the account user

Access Security Access 1-4, 1 = Admin account with full privileges, 2 or

higher = Guest account with no access to settings

Account Username Username Username for that account

First name First First name for user

Last name Last Last name for user

User location QTH Location of user

Last time on Last Visit Date and time the account last accessed

4.1.1 Account Editor

The Account Settings window shows a list of all RSS accounts. When you start RSS the first

time, a single account named admin with callsign ADMIN is the only account in the User

list. Open the Account window from the SETTING Menu.

Personalizing the ADMIN Account
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The ADMIN account cannot be deleted, but it can be reassigned. You must edit the ADMIN

account to make it your own. Click the green Edit button on the right end of the ADMIN

line to open the Account Editor. Three fields are critical and should be changed: Call,

Username, and password.

Call Enter your callsign, replacing ADMIN. Your own call must be

entered to connect to spot clusters.

Username Use any Username you wish. Usernames must be unique and are

used to identify accounts. The Username is case insensitive and

there are no length restrictions except it must be at least one

character.

RigPi PWD Passwords are optional. If you will be opening RSS to the Internet

to operate remote, a password is essential. The password for

ADMIN is blank so you can easily sign in the first time. Once you

enter a password you will be required to use that password from

then on.

Other optional special fields:
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Access ADMIN has an access level of 1. All RSS settings can be accessed

through an account when the Access is set to 1 for that account. If

the Access is set to 2, the account does not have access to Account

or System settings. Access 3 blocks all settings. Access 4 prevents

the account from transmitting.  A guest account can be set up with

an Access value greater than 1.

Latitude/Longitu

de

Callsign lookup uses your latitude and longitude to compute the

distance to a DX station.  Longitudes west of 0 are negative

numbers. Latitudes south of the Equator are negative numbers.

Sync WSJTX Log Contacts logged in WSJT-X are automatically transferred to the

selected log for this account. See the WSJT-X Help topic for

details.

Sync Fldigi Log Contacts logged in Fldigi are automatically transferred to the

selected log for this account. See the Fldigi Help topic for details.

Deadman Limits transmit time to the number of minutes entered in the text

box.  This  prevents unwanted transmitting if remote control is lost

while in transmit.  Set Deadman to 0 to override this function.  If

transmit is blocked, reconnect the radio to reset the Deadman

timer.

Theme Select the Theme for the Tuner window. Four themes are provided:

Orange, Night, LCD, and High Contrast. Note: since this box can

only be filled from the drop down list it has a gray background.

QRZ User If you wish to use the QRZ XML subscription service to look up

calls, you must enter your QRZ username and QRZ password. QRZ

XML is a subscription service. If you do not have a QRZ account,

RSS uses the FCC database in RSS to look up info for US callsigns,

and an RSS entity database to find information about non-US

callsigns.

QRZ Password Password for QRZ XML service.

The remainder of the Account fields are self-explanatory and are optional.

Click the cancel (Stop icon) to reset any changes you have made. Click save (cloud up-

arrow button) to save the changes.
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4.2 Basic Radio

Two Radio Settings options are provided in the RigPi SETTINGS Menu. Basic Radio settings

take advantage of the Hamlib default settings for each radio. If you have made changes to

the radio default Baud rate, stop bits, or RTS/DTR settings in your setup, use Advanced

Radio settings. Advanced Radio settings also provide additional troubleshooting aids.

Most settings options use a drop-down list of options. Click the down arrow on the right

end of an option that uses a list from which to choose. Click the option you wish to set and

that option appears in the settings box.  Boxes that are filled from drop down lists are gray

since they cannot be filled manually.

To save changes, click the cloud up arrow at the top of the window. Use Disconnect Radio

followed by Connect Radio to apply changes.  Connect Radio also saves changes before

applying them.

Function Label Notes

Radio

Manufacturer

Manuf Select the company that manufactured your radio. A

special "Hamlib" manufacturer can be used for special

purposes, see the Technical>Sharing Radios, Rotors and

Keyers topic.
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Radio Model Radio Once you have selected a Manufacturer, the Model list

shows all supported models from that manufacturer.

Radio Name Name Enter the name you want to use for this radio. This radio

name appears in the Tuner window, in many alert dialogs,

and in your log. The Model name is added to the Name

box automatically, but you can change it. For example,

the model K3/KX3 appears in the Elecraft list. You can

change the Radio Name to KX3, K3 or K3s, depending on

your actual radio.

Radio Port R Port The Port drop-down list shows all active ports connected

to serial devices through a USB port. If you have a single

radio connected to RigPi, there will be one entry in the

list. With more than one radio or serial device, pull the

radio USB connector out, refresh the page, and see what

port is missing.  Rebooting RSS can cause the port

numbers to change. See the USB ID item in the Other

Programs Topic to see how to assign a name to the

connection that does not change after a reboot.  Normal

ttyUSB ports are listed along with any ports assigned with

USB ID (radio<n>).  In addition, the 'by-id' name for all

serial ports is included as shown in the screen shot for

Advanced Radio, above.  The 'by-id' names do not

change so offer an alternative to the USB ID names.

CW Keyer Keyer Select RigPi Keyer, via CAT, WinKeyer, or None from the

drop-down list. RigPi Keyer is available for one account.

Other accounts can choose one of the other options. The

WinKeyer option is used for a standalone K1EL WinKeyer

connected through a USB port. See the Keyer Settings

topic for more information about RigPi Keyer and

WinKeyer. 

K Port CW Port RigPi Keyer uses /dev/ttyS0 for control. Via CAT does not

require a separate port, it uses the radio port. WinKeyer

requires a separate USB port. See Radio Port, above, for

using the USB ID utility to name USB cables to prevent

them from being changed with a reboot.
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Transmitter

Power

TX Pwr The default power level used by your transmitter. This

value is used in logging.

Connect

Radio

Connect

Radio

Connect the defined radio and keyer to RigPi. The

Connect Radio button also saves any changes you have

made in settings.

Disconnect

Radio

Disconnec

t Radio

Disconnects the defined radio and keyer.

4.3 Advanced Radio

Two Radio Settings options are provided in the RigPi SETTINGS Menu. Basic Radio settings

take advantage of Hamlib default settings for each radio. If you have made changes to the

radio default Baud rate, stop bits, or RTS/DTR settings in your setup, use Advanced Radio

settings. Advanced Radio settings also provide additional troubleshooting aids.

Most settings options use a drop-down list of options. Click the down arrow on the right

end of an option that uses a list from which to choose. Click the option you wish to set and

that option appears in the settings box.  Boxes that are filled from drop down lists are gray

since they cannot be filled manually.
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To save changes, click the cloud up arrow at the top of the window. Use Disconnect Radio

followed by Connect Radio to apply changes.  Connect Radio also saves changes before

applying them.

Function Label Notes

Radio

Manufacturer

Manual Select the company that manufactured your radio. A

special "Hamlib" manufacturer can be used for special

purposes, see the Technical>Sharing Radios, Rotors and

Keyers topic.

Radio Model Radio Once you have selected a Manufacturer, the Model list

shows all supported models from that manufacturer.

Radio Name Name Enter the name you want to use for this radio. This radio

name appears in the Tuner window, in many alert

dialogs, and in your log. The Model name is added to

the Name box automatically, but you can change it. For

example, the model K3/KX3 appears in the Elecraft list.

You can change the Radio Name to KX3, K3 or K3s,

depending on your actual radio.

Radio Port R Port The Port drop-down list shows all active ports

connected to serial devices through a USB port. If you

have a single radio connected to RigPi, there will be one

entry in the list. With more than one radio or serial

device, pull the radio USB connector out, refresh the

page, and see what port is missing.  Rebooting RSS can

cause the port numbers to change. See the USB ID item

in the Other Programs Topic to see how to assign a

name to the connection that does not change after a

reboot.  Normal ttyUSB ports are listed along with any

ports assigned with USB ID (radio<n>).  In addition, the

'by-id' name for all serial ports is included as shown in

the screen shot, above.  The 'by-id' names do not

change so offer an alternative to the USB ID names.

Radio Port

Baud Rate

Baud The Baud rate for the selected radio. Hamlib defaults to

the highest Baud rate permitted by the radio. You can

change the radio Baud rate in the radio menu. Leave the
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RSS Baud rate set to default if you are using the fastest

Baud rate possible in the radio.

Radio Port

Stop Bits

Stop The stop bits for the selected radio. Leave this set to

default if you have not changed the stop bits from the

factory settings.

Radio Port

DTR

R DTR Determines the DTR state of the radio port. The options

are: default, high, and low. To use the Hamlib default for

the radio, select default.

Radio Port

RTS

R RTS Determines the RTS state of the radio port. The options

are: default, high, and low. To use the Hamlib default for

the radio, select default.

Icom CI-V

number

CI-V Icom radios are identified by a number unique to each

radio.  To use the Hamlib CI-V default number, enter

default.  You can use a hex number in the format \0xnn

where nn is the hex identifier, or in decimal format nnn. 

Decimal radio 23 would simply show the number 23. 

This identifier number only changes if you modify it

from the radio menu.

Hardware

PTT

H/W PTT Determines how the hardware PTT circuits respond. The

options are: None, ON when transmitting

(default),Hamlib GPIO, and ON when radio connected.

This option controls both Audio PTT and Keyer PTT

outputs.  See the Keyer Settings topic for more control

over Keyer PTT operation.  The Hamlib GPIO option is

designed for external programs, such as WSJT-X, that do

not support GPIO pin control for PTT, and radios that do

not support CAT PTT.  With this option the RigPi

hardware PTT switch can be used to control PTT through

an ACC connector on the radio.  RigPi CAT PTT is not

available when Hamlib GPIO is selected so the CAT PTT

selection is ignored.

CAT PTT CAT PTT Determines how the CAT PTT responds. The options are:

None, ON when transmitting (default), and ON when
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radio connected.  The CAT PTT selection is ignored

when you use the Hardware PTT GPIO option.

CAT PTT

Command

PTT Cmd Select the CAT command to be sent to the radio for PTT

On.  The options are: default, w TX1;, and Custom. Some

radios require TX1; to be sent to tell the radio to use the

rear panel Data connector for audio input.  If your radio

requires a special command, use the Custom option to

enter a Hamlib or custom radio command.  Custom

radio commands use the native CAT PTT command. 

Precede the command with a w<space>.

Transmit

Meter

Tr Mtr Select the parameter you want displayed by the Tuner

S-Meter when in transmit. The options include Output

Power, Output Power Default, SWR, ALC, Voltage,

Current, Mic Gain, and Meter. The readings supported by

Hamlib with your radio can be found in the capabilities

list shown when you click Radio Capabilities. Look in the

Get Level list. None, one, or all options may be

supported. Output Power Default shows the static

setting for maximum power output set in your radio.

See Mtr Cal, below, for calibrating the meter.

Meter

Calibration

Mtr Cal The value reported by the radio for the reading you

have chosen can be calibrated with this option. If your

transmitter has a maximum power output of 100 watts,

you have selected Output Power Default, setting the Mtr

Cal to 100 gives a full scale indication of 100. If you

have set the maximum power output to 50 watts, setting

Mtr Cal to 500 gives a reading of 10 on the meter. See

below. Each Tr Mtr selection has its own calibration

level.

PTT Delay PTT Delay Enter the number of milliseconds delay from when the

PTT button is toggled on the Tuner window to when the

transmitter is keyed.  This delay prevents the

transmission of receive audio fed back from the remote

device.
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Serial

Defaults

Serial

Defaults

Click to show the defaults used in Hamlib for connecting

to the radio.

Radio

Capabilities

Radio

Capabilities

Provides a list of all set and read capabilities for the

selected radio.

Disable Split

Polling

Disable

Split

Polling

Some radios, such as Icom, do not provide a way to

directly read the split VFO frequency. Instead, the

frequency is read by swapping VFO's. This causes

flickering on the split frequency readout. While the

flickering doesn't cause changes in frequency, it can be

disconcerting. Put a check in the Disable Split Polling

option to prevent the reading of the split frequency VFO

to stop the flickering. Keep in mind that any manual

changes to the split frequency made on the radio are

not known by RigPi. Split reading for some radios is not

supported by Hamlib even though the radio provides a

means of doing so. Use Radio Capabilities to determine

if your radio fits into this category.

CW Keyer Keyer Select RigPi Keyer, via CAT, WinKeyer, or None from the

drop-down list. RigPi Keyer is available for one account.

Other accounts can choose one of the other options. The

WinKeyer option is used for a standalone K1EL

WinKeyer connected through a USB port. See the Keyer

Settings topic for more information about RigPi Keyer

and WinKeyer. 

CW Keyer

Port

K Port RigPi Keyer uses /dev/ttyS0 for control. Via CAT does

not require a separate port, it uses the radio port. See

Radio Port, above, for using the USB ID utility to name

USB cables to prevent them from being changed with a

reboot. The CW Port parameters are not adjustable. The

WinKeyer3 IC and WinKeyer devices use 1200 Baud with

one stop bit.

Transmitter

Power

Tx Pwr The default power level used by your transmitter. This

value is used in logging.
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Slave Port Slave Port Port used for slave connection.  Set to None if slave port

is not in use or using the Band BCD or Macro Decimal

mode.  See text below for more information on the

slave command

Slave Baud Slv Baud Baud rate used for slave connections, not used for Band

BCD or Macro Decimal modes.

Slave

Command

Slv Cmnd Command format sent by RigPi when there is a

frequency change.  The Kenwood IF command sends 38

characters including current frequency.  The Kenwood FA

command sends 14 characters containing only

frequency. Band BCD is used for devices that are

controlled by BCD Band data, such as the Ameritron

RCS-12 Automatic Antenna Switch.  A special cable is

required, see below. Macro Decimal is used for

controlling the on/off state of up to 8 devices.  A special

cable is required, see below.

Macro Bank Macro Bnk The current macro bank for this account.  Each account

has 4 banks of 32 macros available for custom

programming.

Video

Control

Video One camera is supported by RigPi, but each account has

access to the video from that camera.  The options

include None (no video), Video -> S-meter (video

replaces S-meter panel), Video -> Frequency Panel

(video replaces Frequency panel).  See the Motion

topic in Other Programs to learn more about using

video with RigPi.

Connect

Radio

Connect

Radio

Connect the defined radio and keyer to RigPi. The

Connect Radio button also saves any changes you have

made in settings.

Test Radio Test Radio Attempts to connect to the radio using the settings

values and creates a report that is displayed. The report

can give helpful information when the radio isn't

connecting.  To share the report, select all the text, copy,

then paste it to a destination, such as an email. An

134
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comprehensive log can be found in /var/log with the

name rigpi-radio.log.

Disconnect

Radio

Disconnect

Radio

Disconnects the radio

Tr Mtr Example

Here is a list of the readings are supported by Hamlib for the TS-570S.  This list is extracted

from the Radio Capabilities button in Radio>Advanced.

PREAMP(0..0/0) ATT(0..0/0) AF(0..0/0) RF(0..0/0) SQL(0..0/0) RFPOWER(0..0/0)

MICGAIN(0..0/0) KEYSPD(0..0/0) AGC(0..0/0) SLOPE_LOW(0..0/0) SLOPE_HIGH(0..0/0)

STRENGTH(0..0/0) 

The only two readings that appear to apply to the TS-570S in transmit are RFPOWER and

MICGAIN.  The best option is the “Output Power Default” selection in Radio>Advanced>Tr

Mtr which is RFPOWER in the list above.  That is a static reading, it reads the max level the

radio is set to, not what is being transmitted.  The Mtr Cal sets the max level calibration of

the meter.  So if you enter 200 for Mtr Cal and you have your transmitter set to 100 watts

max, the bottom digit scale on the meter should be 50 when in transmit.

Slave Command

RigPi supports a single slave connection for all accounts.  If you attempt to connect a

second slave, RigPi shows an alert telling which account is currently using the connection.  

The RigPi Slave Command sends one of two CAT commands when there is a frequency

change in the connected radio, BCD Band data when the radio band is changed, or

manually triggered decimal commands..  The commands can be used with devices, such as

the SteppIR antenna controllers, a compatible power amplifier, or a Kenwood radio.  For

example, you may have an Icom IC-7300 as your radio, but you also have a Kenwood TS-

2000.  The Kenwood frequency tracks any changes in the Icom's frequency as you tune.

The Band BCD option sends Band BCD data through a special cable to tell external devices

what band the radio is currently using. The special cable is an FTDI C232HM (C232HM-

EDHSL-0). This cable has 10 wires that can be used for interfacing to other devices.  The

FTDI cable can be purchased from Mouser Electronics.  The 5th line in Band BCD mode

goes low when the radio is transmitting.
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The Macro Decimal option is used for Macros or a row of LED indicator lights below the

tuning knob.  Up to 8 external devices can be controlled using a Macro command !SWn-m,

where n is 1-8 and m is 0 (off) or 1 (on). Macro Decimal switch macros can be stacked, so

!SW1-1!SW3-1 turns devices 1 and 3 on.

 

Band BCD C232HM-EDHSL-0 wiring

Wire Signal Ameritron

RCS-12

Elecraft KPA-500 Elecraft KPA-1500

Red VCC 

Orange BIT/PIN 0 BCDA (pin 2) Band 0 (pin 13) Band 0 (pin 13)

Yellow BIT/PIN 1 BCDB (pin 1) Band 1 (pin 3) Band 1 (pin 3)

Green BIT/PIN 2 BCDC (pin 9) Band 2 (pin 9) Band 2 (pin 9)

Brown BIT/PIN 3 BCDD (pin 8) Band 3 (pin 14) Band 3 (pin 14)

Grey BIT/PIN 4 PTT (pin 7) PTT (pin 10) PTT (pin 10)

Purple BIT/PIN 5 

White BIT/PIN 6 

Blue BIT/PIN 7 

Black GND Ground (pin 6) Ground (pin 5) Ground (pin 5)

4.4 Rotor

One rotor can be assigned to and controlled through each account. 30 Rotor models are

supported by Hamlib from 21 manufacturers. The screen shot shows the rotor configured

for the Hamlib Dummy rotor which provides a rotor simulation.
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Most settings options use a drop-down list of options. Click the down arrow on the right

end of an option that uses a list from which to choose. Click the option you wish to set and

that option appears in the settings box.  Boxes that are filled from drop down lists are gray

since they cannot be filled manually.

To save changes, click the cloud up arrow at the top of the window.  If you make changes

to Rotor Settings while a radio is running, restart the radio in the Tuner, Radio Basic or

Radio Advanced windows.

Function Label Notes

Rotor

Manufacturer

Manuf Select the company that manufactured your rotor. A

special "Hamlib" manufacturer can be used for special

purposes, see the Technical>Sharing Radios, Rotors and

Keyers topic.

Rotor Model Rotor Once you have selected a Manufacturer, the Model list

shows all supported models from that manufacturer.

Rotor Port Port The Port drop-down list shows all active ports connected

to serial devices through a USB port. If you have a single

radio connected to RigPi, there will be one entry in the list

plus the rotor. With more than one serial device, pull the

rotor USB connector out, refresh the page, and see what

port is missing.  
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Rebooting RSS can cause the port numbers to change.

See the USB ID item in the Other Programs Topic to see

how to assign a name to the connection that does not

change after a reboot. 

For the Hamlib Dummy rotor use the value for Rigctl Port

in System Settings plus 1.  For example, to use Hamlib

Dummy, set the Man to Hamlib, the Rotor to Dummy, and

the Port to 4533.  

To share a rotor, use the Rigctl Port for that radio plus 1. 

For example, to share a rotor assigned to radio port 4534,

use port 4535 for the rotor, and Net rotctl for the Rotor.

Rotor Baud Baud Baud rate for the serial connection to the rotor.

Stop Bits Stop Number of Stop bits used by the rotor serial connection.

4.5 Keyer

The CW Keyer Settings window is used for the RigPi Keyer, or external K1EL WinKeyer.

These settings do not affect keying via CAT except for Speed. Once you have entered new

settings you can test the keyer by clicking the Test Keyer button.

The RigPi Keyer can be assigned to one account. Additional accounts can use keying via

CAT or WinKeyer. There are no limits to the use of the via CAT option or to the number of

external WinKeyers.

Remote Keyer provides a way to key your radio from a remote location using a paddle,

bug, or straight key. RigPi CW Keyer boards are required at both ends.  The Remote CW

Keyer board provides speed control and sidetone.  CW characters are sent by UDP data

packets.  Each packet contains the start or end time for a CW element.  The timing is used

to reconstruct the CW elements at the Radio RigPi to key your transmitter.

A simplified version of RigPi is available for Remote Keyer.  This minimized RigPi version

can be loaded on a Raspberry Pi 0 W or any Raspberry Pi from version 3 up.
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Most settings options use a drop-down list of options. Click the down arrow on the right

end of an option that uses a list from which to choose. Click the option you wish to set and

that option appears in the settings box.  Boxes that are filled from drop down lists are gray

since they cannot be filled manually.

RigPi Keyer and WinKeyer options

The Notes below are adapted from K1EL's WinKeyer3 IC data sheet.

Click to see WinKeyer Data Sheet

Function Label Notes

Keyer Speed (WPM) Speed

Paddle Keying

Mode

Paddle Md RigPi Keyer supports iambic A, B, Ultimatic, and

Bug keying modes. In iambic mode, RigPi Keyer

sends dits and dahs automatically based on which

paddle you press. In bug mode RigPi Keyer sends

the dits and you manually send the dahs. You also

can use bug mode to operate in straight key

mode or if you want to key through RigPi Keyer

with a different keyer, simply set bug mode and

use the dah input to key RigPi Keyer.

http://k1el.tripod.com/files/WK3_Datasheet_v1.pdf
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Keyer Sidetone (Hz) Sidetone The sidetone frequency is continuously adjustable

between 500 and 4000Hz

Keyer Weight Weight A value of 50 selects no weighting adjustment.

Values less than 50 reduce weighting and values

greater than 50 increase weighting. Note that

weighting does not affect sending speed because

any increase in keyed time is subtracted from

spacing time. Reduction in weighting results in a

thinner sounding keying while increased

weighting results in a heavier sound. Since

weighting tracks speed, a given weighting will

sound the same at all speeds.

Keyer PTT Lead-In

Time

Leadin RigPi Keyer provides a transmitter PTT output for

each key output that can be used to switch a

transmitter or linear amplifier over to transmit

mode in advance of actual CW keying. You have

control over the time delay between when PTT is

asserted and when CW keying starts, this is lead-

in. You also have control over how long the

transmitter will stay in transmit after keying has

stopped. The Tail setting determines the delay

used for CW sent by an internal message or CW

sent by RigPi.

Keyer PTT Tail Time Tail See Keyer PTT Lead-IN Time, above

Speed Pot minimum

WPM

Min WPM Min WPM and WPM Range set the limits for the

speed pot. Min WPM sets the lowest value

returned; WPM Range indirectly specifies the

maximum value returned. For example if Min

WPM=10 and WPM Range=15, the full pot swing

values, min to max, would be 10 to 25 WPM. Note

that the max value is Min WPM+WPM Range.

Speed Pot WPM

range

WPM Rng See Min WPM, above
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Keyer Keying

Compensation

Comp Keying Compensation allows a fixed amount to

be added to the length of all dits and dahs. QSK

keying on modern transceivers can cause

shortening of dit and dah elements which is

especially noticeable at high speeds. RigPi Keyer

can compensate for the shortening by adding a

uniform length to each dit and dah element. The

adjustments are made in one-millisecond steps

and the maximum adjustment allowed is 250 m

Secs. Key compensation is very similar to

Weighting in that an adjustment added to a dit or

dah is then subtracted from the spacing between

them so the overall speed is not changed. The

difference between weighting and compensation

is that compensation is independent of speed, so

if 10 m sec of key compensation is selected, 10 m

sec will be always be added regardless of speed.

Be aware that at high speeds, large values of key

compensation can reduce inter-element space to

zero.

Slow CW Farnsworth

maximum speed

Farns Farnsworth spacing is useful for CW practice

because it encourages you to learn characters by

sound not individual dits and dahs. When

Farnsworth is enabled, letters are sent at a fixed

rate of nn WPM while spacing between characters

is determined by the sending WPM rate. When the

WPM rate is set above the Farnsworth WPM,

Farnsworth is automatically disabled.

Paddle timing Paddle This setting controls when RigPi Keyer will start

looking for a new paddle press after sensing the

current one. If there is not enough delay, the keyer

could send unwanted dits or dahs. If there is too

much delay, the operator is held back because

they can't paddle ahead. The default value is one

dit time (50) and is adjustable in percent of a dit

time. Faster operators report a setting somewhat

less than default is optimal. If the paddle
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sensitivity is set to zero, dit and dah paddle

memory is disabled.

Dot/Dash ratio Ratio Modifies the ratio of dit time to dah time. The

standard ratio is 1:3 (dit:dah) when ratio = 50. The

formula to determine dah/dit ratio is: DAH/DIT =

33 would select 1:2, and a value of 66 would

select 1:4. This causes an intentional distortion of

the Morse waveform. Some ops use this option to

make their CW sound less “machine like” but a

little goes a long way!

Turn sidetone on/off Enable

Sidetone

Enable the RigPi Keyer sidetone for paddle and

RigPi keying.

Keyer PTT mode Enable

Keyer PTT

Keyer PTT is turned on when the WinKeyer IC

sends CW. To re purpose the WinKeyer IC PTT so it

can set PTT independently (through

programmable Macros), remove the Enable Keyer

PTT check.

Left/right paddle

swap

Swap

Paddles

Reverse the dit/dah paddle control. Useful for left

handed operation.

Keyer sending

autospace

AutoSpace Autospace works in the following way: If you

pause for more than one dit time between a dit or

dah, RigPi Keyer will interpret this as a letter-

space and will not send the next dit or dah until

the full letter-space time has been met. The

normal letter-space is 3 dit spaces. RigPi Keyer

has a paddle event memory so that you can enter

dits or dahs during the inter-letter space and

RigPi Keyer will send them as they were entered.

With a little practice, autospace will help you to

send near perfect Morse.
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Contest spacing CT Space Shortens the time between characters by one dit

space.

Control Keyer

Watchdog

Disable

Watchdog

RigPi Keyer has a paddle watchdog counter that

disables the key output after 128 consecutive dits

or dahs. RigPi Keyer assumes that this is an

unintended condition and keying outputs are

turned off. Sidetone remains on to alert the user.

Paddle watchdog is on by default but it can be

turned off by setting this mode bit.

Use PTT for other

applications

PTT ON

when

Radio

Connected

Forces PTT to turn on when a radio is connected

and under control. This is useful for antenna

bypass switches and similar applications. See

below.

Reset Defaults Reset

Defaults

Restores the original RigPi Keyer default values.

Test Keyer Test Keyer Sends two 'V' characters.

Remote Keyer

Function

Keyer Fn Selects Keyer mode. Options are Normal, Radio

Keyer, Remote Keyer. Normal is used when you

are not using Remote Keyer.  Select Radio Keyer

for the RigPi controlling your radio.  Select

Remote Keyer to use a paddle, bug, or straight

key from a remote location.

Remote Keyer Port Port The UDP port used by the Radio RigPi to listen for

a connection from Remote Keyer.  This setting

only appears for the Remote Keyer or Radio Keyer

RigPi. The default port is 30040.

Remote Keyer Radio

RigPi IP

IP The IP for the Radio RigPi when using Remote

Keyer. This setting only appears for the Remote

Keyer RigPi.

Invert Remote

Keying

Invert

Keying

Inverts the keying when using an external

electronic key.  
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Keyer PTT

RSS has “Normal PTT” and “Keyer PTT.” Normal PTT is what you expect when you tap PTT

on the Tuner window, push-to-talk. Keyer PTT can be used for other purposes.

Normal PTT from the Tuner PTT or macro switches does two things. It sends the CAT PTT

command to the radio and simultaneously controls the hardware switches on the Keyer and

Audio boards. The Keyer PTT switch goes from tip to sleeve (grounded) on the Keyer PTT

connector while on the Audio board it goes from ring to sleeve (not grounded).

There is an alternate way to control Keyer PTT on the Keyer board. This alternate PTT is

controlled by the K1EL WinKeyer3 IC. When PTT is “enabled” in Keyer settings, this PTT

operates whenever there is outgoing CW. You can set the lead-in delay and tail delay to

take care of amplifier switching. When PTT is “disabled” in Keyer settings, you can control

the WinKeyer3 IC PTT through software. This latter control can be is used by a macro and

by the “PTT when radio connected” option in Keyer settings.

Keyer PTT and RigPi PTT always engage the PTT on the Keyer board. Since RSS doesn’t

know when the CW Keyer is sending CW, the “PTT enabled” Keyer PTT is the only way to

control the radio or amplifier if switching is necessary. If that switching isn’t necessary,

“disabled” Keyer PTT can be used for other purposes.

Remote Keyer Connections

A paddle, bug or straight key is connected to Remote Keyer through the PADDLE

connector.  If using a bug or straight key, the Remote Keyer Paddle Mode (Paddle Md)

must be changed to Vibrobug.  The tip of the PADDLE connector is shorted to ground to

key Remote Keyer which is then passed to the Radio RigPi.

See RigPi Remote Keyer  for more details.

4.6 Log Designer

The Log Designer provides a drag-and-drop way to modify existing log styles, or to design

new ones. A log style is assigned to each log, but you can change the assigned style by

making a selection through a drop-down list in the RSS Log window.

168
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The top three boxes include one to select a style you wish to edit, a second to start a new

style, and a third to save a style with a different name.  If you add a new style, or save as an

existing style, press Enter to save or click OK.  Boxes that are filled from drop down lists are

gray since they cannot be filled manually.

The three lists include a master list of log fields (white, center), fields assigned to the

current style for the log (yellow, left) and finally a list to show the fields assigned to the log

editor (yellow, right). Items in the yellow lists can be dragged up or down to change their

order, or removed from that list by deleting. Items in the master list can be dragged and

inserted into either yellow list.

The fields at the bottom are for labeling and setting defaults for the selected field.

Function Label Notes

Field Label Label Appears in the column

headers for the Log, and at

the left end of the field for

the Log Editor.

Optional default for the

selected field

Default Add a default for this field.

The default is always

added to the field where it

can be edited.
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Function Label Notes

Field attribute Attr The Field Attribute

determines how the field is

used. See below.

List of options for drop-

down lists

List Determines a default list

for a list field, such as for

Mode. See below.

Field prompt Prompt Appears in each field as a

place holder unless there is

a default.

Field notes Note Description of the field

Field Attribute

Each filed is assigned an attribute depending on how the list is used.

Attribut

e

How it appears Note

None Field has label and text

box

No attributes assigned to this field.

Set Time Field has clock icon on

the right, click to set the

current time

Click the clock icon to enter the current time

into the field. The time may be edited.

Drop-Down

List

Drop-down list, click list

icon on left

Contents of drop-down list. Use the List

field to enter a comma-delimited list. For

example, CW,PHONE,DIGITAL for modes. If

a Drop-down list is not defined for modes,

all modes will be in the list.

No Edit Field is disabled Do not allow editing of this field. Used for

record numbers or for any field that should

not be changed.
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Attribut

e

How it appears Note

Caps Field converted to capital

letters

Use for callsign fields or any field that

should be in upper case.

Add

periods

Adds two periods to

frequencies

10 meter CW example: 28.027.123

4.7 Spots

The Spots function connects to a Telnet spot cluster using your callsign.  Enter your callsign

in SETTINGS>Accounts>Account Editor.

Spot Settings list contains an extensive list of known DX Cluster Telnet sites. Click a site to

use it as a source for spots in the Spots window. Retain Time is the number of minutes

before spots are deleted from the Spots window list.

If you wish to use a site close to your location, the Spot Site Filter (Funnel) has selections

for All Clusters, Closest to Me, and My US State. Closest to me uses the Grid Square value

entered for the current account in Account Settings. The US two-letter abbreviation is also

taken from Account Settings.
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Notes:

1. Spot clusters are not shown that 1) do not list a port number or 2) include a

reference to CW Skimmer spots.

2. Filter "Closest to me" uses the first two characters of the Grid Sq entered in

Account settings for the current account.

3. Filter "My US State" uses the 2-character state entered in Account settings for

the current account.

4.8 Band Filter

The Band Filter settings window provides a way to disable band selections in the Tuiner

window.  For example, a KX3 with a 2-meter accessory board cannot operate on 6, 1.25, 70
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or 23.  Select the bands you don't want activated.  In the Tuner window the disabled bands

are shown with a gray background.

Click Enable All to enable all bands.

4.9 Slider Overrides

Depending on the capabilities of your radio, up to four sliders are shown on the Tuner

window.  The Slider Override settings can be used to set the maximum level for each slider,

or disable one or more completely.  The settings above indicate that the AF Gain can be set

to a maximum of 21% and the Pwr output can be set to 12 watts maximum.

Set a slider to 0 to disable it.  Set the slider to 100 to provide the full range.
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4.10 Macros

RSS provides 128 programmable macro keys in 4 banks of 32 each. The keys are available

in the Tuner and CW Keyer windows. Each macro has a space to enter a button caption and

a command.  The total length of all macros is 2000 characters per bank per account.

Macros can be used in a number of ways:

· CW messages

· Hamlib Commands

· Direct radio commands

· Special commands

Macro Save/Restore

Each bank of macros can be saved and restored.  Use the "hamburger" icon button (upper

right) to save the current macro bank to the downloads folder or to restore a saved macro

bank.  The downloads folder is determined by the device or computer you are using to

connect to RigPi.  If you are using a desktop PC to connect to RigPi, macro banks are sent

to the downloads folder on the PC.  Select the Restore button to display a file explorer

window to find the macro bank file you want to restore.

Macro banks are downloaded as text (.txt) files.  You can modify macros in the .txt file

using any text editor.  The edited macro text file can then be uploaded to replace the

current set.
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The last-used Macro Bank in the Tuner and Keyer windows are restored when you reopen

either window.

CW Messages

CW Messages start with a $ character. The message can consist of ASCII printable

characters, special control characters, or a combination of both. RigPi Keyer and External

WinKeyer share the same control characters. The control characters are defined in the

WinKeyer3 data sheet.

Click to see WinKeyer Data

For example, one WinKeyer3 control character, 1bH, is used to combine consecutive

characters to create a prosign. The prosign BK is formed by the CW command $<1b>BK.

This is a combined ASCII printable and control character CW message.

A printable ASCII message might be $5NN TU for the signal report plus "Thank You."

Special CW keying characters that can be used in a RigPi Keyer or WinKeyer3 macro

(prefaced by $):

Character Result

'* Your call sign (apostrophe + asterisk)

'X DX call

<1b>AR AR

<1b>AA AA

<1b>BK BK

<1b>BT BT

http://k1el.tripod.com/files/WK3_Datasheet_v1.pdf
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Character Result

<1b>CL CL

<1b>KN KN

<1b>SK SK

<1b>AS AS 

<02>number

Set CW speed to 'number.'  To set the speed to 30 wpm, the command

is <02>30.  Use a value of 0 to set the speed to the last used speed in a

stacked speed macro.  

{<02>30}<02>20  sets the speed to 30 when a stacked speed macro

starts and 20 when the second part of the stacked macro is sent.

{<02>30}<02>0 sets the speed back to what it was before the macro

was started.

!ESC Stops a CW message that is being transmitted or stops the tune mode

!TUNE Key down (tap Tune again, or use ESC or CANCEL macro to stop)

Hamlib Commands

RSS uses the Hamlib library to control radios and rotors. The library is documented online

on the Hamlib developer's web site.

Click to see Hamlib Rigctl commands

The rigctld utility is used for radio commands while the rotctld is used for rotor commands.

Preface rigctld and rotctld command with * (asterisk). For example, to create a macro to set

the main VFO frequency to 14.222.220 MHz, use the macro *F 14222220. Note the space

between the F and 1. Many commands return a value from the radio.  For example, the

macro *f returns the current main frequency from the radio.  Return values are shown in a

modal alert box. If an invalid command is used in a macro and error message is displayed.

http://hamlib.sourceforge.net/html/rigctl.1.html
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Direct Radio Commands

A special Hamlib rigctld command, w, is used to send commands to radios when there is

no rigctld native command. For example, to set the squelch on an Elecraft KX3 to 50, use

the command *0w SQ050. The w command is prefaced by an asterisk and the number 0 or

1. Some radio commands elicit a response, others don't. Use 0 for commands for which the

radio doesn't respond and 1 if a response is expected. The command shown in the Macro

screen shot sets the frequency of a Kenwood or Elecraft radio to 15 meters. *0w

FA00021025000;  Commands that return values from the radio show the resulting data in a

modal dialog box.  For example, *1w FA; returns the current main frequency from Kenwood

and Elecraft radios.  If an invalid command is used in a w custom command an error

message is shown.

Some radios, such as Icom and many Yaesu radios, require the use of hex numbers in w

commands.  Use the notation \0xNN (NN=a valid hex number) for these radios.  Return

values will also be hex numbers and may not display in a meaningful way.

Stacking Macros

More than one macro can be inserted in a single macro slot.  For example, you can add a

mode macro to a frequency set macro. Hamlib and Direct Radio Commands (0w/1w) can

be stacked and mixed.

To add a second or additional macros to an existing macro, simply add the command and

any command prefixes.  Using Hamlib commands to set frequency, mode and passband,

use this format:

*F 14222220*M USB 3000

This macro sets the radio frequency to 14.222220 MHz, the Mode to USB and the passband

to 30000 Hz.  Here are some examples using Hamlib commands:

Command What Happens Note

*F 14055444*M CW 3000 Tune radio to 14.055.444

CW with a passband of

3000 Hz

Uses Hamlib commands

*S 1 VFOB*I 14058222 Set radio to split mode,

transmit on 14058222

Uses Hamlib commands
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Latching Macros

Many radio commands set a state such as on and off, or you may wish to program a button

that toggles between two frequencies.  RigPi Macros use a special format to determine the

command for each state and the color used for a button that has been clicked.

{command1}command2+btn-color

The command in '{}' is the first command executed when the button is clicked.  This starts a

stacked command.

The color determines the color of the button when first clicked.

If you don't provide a color, "Info" is the default color.

Here are several samples of how to use a Latching Macro.

Button label Command Notes

PWR ON/OFF {*PS1;}*PS0;+btn-danger Button is red ('danger') when power

is on.

HAMLIB TEST (F) {*F 21025000}*F 28035000+btn-

warning

Button is yellow ('warning') when

frequency is set to 21.025.000

Web Commands

Macros can be created to open web sites in a new browser wwindow.  Web commands

start with the backslash character ("\").  The DX Call, band and mode can be embedded in

the command.  This is useful for opening QRZ.com to the DX Call, or opening DX Summit

filtering on call, band and mode.  You can create your own web commands for other sites.

Button label Command Notes
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QRZ DX CALL /https://qrz.com/db/<dxcall> Look up 'dxcall' on QRZ

D

XS BAND &

MODE

/http://dxsummit.fi/#/?

include=<band>&include_modes=

<mode>

Look up all spots on DX Summit for

the current band and mode

DXS DXCALL /http://dxsummit.fi/#/?

dx_calls=<dxcall>

Look up all spots on DX Summit for

the current DX call

Function Key Shortcuts

Assign macros to F-keys for quick access from your keyboard.  Use a prefix of Fn: to assign

F-key n.  F1-F12 can be used. For example,

F1:$5NN TU

assigns F1 to a CW macro that sends 5NN TU.

System Commands

System command macros are disabled by default since they can be a serious security risk. If

you aren't careful, you can issue commands that will damage important RSS files. If you

wish to experiment, uncomment the exec line in programs/systemExec.php. Be careful! Do

NOT enable this function  for security reasons if your RSS is accessible from the

Internet.

Preface system commands with #. For example, to program a macro to reboot RSS, use the

command #sudo reboot.

Other Special Commands

Special '!' commands that can be sent using a macro key include the following:

Command What Happens

!BANK
Changes Macro Bank to the next higher bank.  Starts over after bank

4.  Current bank is shown by selected Macro Band button.

!T/R Toggles Transmit/Receive 
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Command What Happens

!ROTATE Turn your station rotor to the DX bearing

!RTR STOP Stop rotor immediately

!PTTON

Turns on RigPi Keyer and Audio board PTT.  A radio does not have to

be connected.  If using this to control an external power switch, turn

off hardware PTT in Advanced Radio settings>H/W PTT.

!PTTOFF

Turns off RigPi Keyer and Audio board PTT.  A radio does not have to

be connected. If using this to control an external power switch, turn

off hardware PTT in Advanced Radio settings>H/W PTT.

!SWn

The the !SWn command, macros can control on and off to up to 8

external devices through a special cable (see below). (Use !SW0 to

reset all 8 lines.)

!TUNER Engage internal tuner in radio.

!TUNETO A dialog allows you to set a frequency, mode and bandwidth.

Switching External Devices

Using the !SWn macro RigPi can control up to 8 external devices that can be turned on or

off with 5-volt signals.  For example, !SW1 can be used to turn on and off device 1. The

macro latches the current value, so successive taps turn the device on and off.  Use !SW0 to

reset all eight outputs.

This function requires a special USB cable:

FTDI C232HM (C232HM-EDHSL-0). This cable has 10 wires that can be used for interfacing

to other devices.  The FTDI cable can be purchased from Mouser Electronics.
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Wire Signal 

Red VCC 

Orange BIT/PIN 0 

Yellow BIT/PIN 1 

Green BIT/PIN 2 

Brown BIT/PIN 3 

Grey BIT/PIN 4 

Purple BIT/PIN 5 

White BIT/PIN 6 

Blue BIT/PIN 7 

Black GND 

IC-7610/IC-7300 Macros (tnx KK5VG)

Macro HEX COMMANDS

IC-7610 ON *1w \0xFE\0xFE\0x98\0xE0\0x18\0x01\0xFD

IC-7610 OFF *1w \0xFE\0xFE\0x98\0xE0\0x18\0x00\0xFD

NOISE REDUCTION ON *1w \0xFE\0xFE\0x98\0xE0\0x16\0x40\0x01\0xFD

NOISE REDUCTION OFF *1w \0xFE\0xFE\0x98\0xE0\0x16\0x40\0x00\0xFD

NOISE REDUCTION LEVEL 2 *1w \0xFE\0xFE\0x98\0xE0\0x14\0x06\0x40\0xFD

NOISE REDUCTION LEVEL 6 *1w \0xFE\0xFE\0x98\0xE0\0x14\0x06\0x1\0x10\0xFD

ROTOR

ROTOR STOP

NOTCH ON *1w \0xFE\0xFE\0x98\0xE0\0x016\0x41\0x01\0xFD

NOTCH OFF *1w \0xFE\0xFE\0x98\0xE0\0x016\0x41\0x00\0xFD

COMPRESSION ON *1w \0xFE\0xFE\0x98\0xE0\0x016\0x44\0x01\0xFD

COMPRESSION OFF *1w \0xFE\0xFE\0x98\0xE0\0x016\0x44\0x00\0xFD

PREAMP OFF *1w \0xFE\0xFE\0x98\0xE0\0x016\0x02\0x00\0xFD 

PREAMP 10 *1w \0xFE\0xFE\0x98\0xE0\0x016\0x02\0x01\0xFD
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PREAMP 20 *1w \0xFE\0xFE\0x98\0xE0\0x016\0x02\0x02\0xFD

CHANGE MAIN / SUB *1w \0xFE\0xFE\0x98\0xE0\0x07\0xB0\0xFD

ATTENUATOR OFF *1w \0xFE\0xFE\0x98\0xE0\0x11\0x00\0xFD

ATTENUATOR 6 DB *1w \0xFE\0xFE\0x98\0xE0\0x11\0x06\0xFD

ATTENUATOR 12 DB *1w \0xFE\0xFE\0x98\0xE0\0x11\0x12\0xFD

ATTENUATOR 18 DB *1w \0xFE\0xFE\0x98\0xE0\0x11\0x18\0xFD

VFO *1w \0xFE\0xFE\0x98\0xE0\0x07\0xFD

MEMORY *1w \0xFE\0xFE\0x98\0xE0\0x08\0xFD

ANTENNA 1 *1w \0xFE\0xFE\0x98\0xE0\0x12\0x0000\0xFD

ANTENNA 2 *1w \0xFE\0xFE\0x98\0xE0\0x12\0x0001\0xFD

RF -30%****************** *1w \0xFE\0xFE\0x98\0xE0\0x14\0x02\0x2\0x20\0xFD (???)

RF -50%****************** *1w \0xFE\0xFE\0x98\0xE0\0x14\0x02\0x1\0x90\0xFD (???)

RF 100%****************** *1w \0xFE\0xFE\0x98\0xE0\0x14\0x02\0x2\0x55\0xFD (???)

14.300 Mhz *F 14300000

50.525 Mhz *F 50525000

MONITOR ON *1w \0xFE\0xFE\0x98\0xE0\0x16\0x45\0X01\0xFD

MONITOR OFF *1w \0xFE\0xFE\0x98\0xE0\0x16\0x45\0X00\0xFD

RESET

NOISE BLANKER ON *1w \0xFE\0xFE\0x98\0xE0\0x16\0x22\0x01\0xFD

NOISE BLANKER OFF *1w \0xFE\0xFE\0x98\0xE0\0x16\0x22\0x00\0xFD

DUAL WATCH ON *1w \0xFE\0xFE\0x98\0xE0\0x7\0xC1\0xFD

DUAL WATCH OFF *1w \0xFE\0xFE\0x98\0xE0\0x7\0xC0\0xFD

PBT IN +150 *1w \0xFE\0xFE\0x98\0xE0\0x14\0x08\0x01\0x55\0xFD

PBT OUT -150 *1w \0xFE\0xFE\0x98\0xE0\0x14\0x08\0x1\0x00\0xFD

PBT IN .0 *1w \0xFE\0xFE\0x98\0xE0\0x14\0x07\0x01\0x30\0xFD

PBT OUT .0 *1w \0xFE\0xFE\0x98\0xE0\0x14\0x08\0x01\0x30\0xFD
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COMPRESSION LEVEL 3 *1w \0xFE\0xFE\0x98\0xE0\0x14\0x0E\0X00\0x0270\0xFD

COMPRESSION LEVEL 5 *1w \0xFE\0xFE\0x98\0xE0\0x14\0x0E\0X01\0x0220\0xFD

COMPRESSION LEVEL 7 *1w \0xFE\0xFE\0x98\0xE0\0x14\0x0E\0X01\0x0265\0xFD

COMPRESSION LEVEL 10 *1w \0xFE\0xFE\0x98\0xE0\0x14\0x0E\0X02\0x055\0xFD

RF POWER 8W *1w \0xFE\0xFE\0x98\0xE0\0x14\0x0A\0x00\0x21\0xFD

RF POWER 25W *1w \0xFE\0xFE\0x98\0xE0\0x14\0x0A\0x00\0x65\0xFD

RF POWER 50W *1w \0xFE\0xFE\0x98\0xE0\0x14\0x0A\0x01\0x30\0xFD

RF POWER 75W *1w \0xFE\0xFE\0x98\0xE0\0x14\0x0A\0x01\0x93\0xFD

RF POWER 100W *1w \0xFE\0xFE\0x98\0xE0\0x14\0x0A\0x02\0x55\0xFD

MIC GAIN 25% *1w \0xFE\0xFE\0x98\0xE0\0x14\0x0B\0x00\0x0165\0xFD

MIC GAIN 50% *1w \0xFE\0xFE\0x98\0xE0\0x14\0x0B\0x01\0x0230\0xFD

MIC GAIN 75% *1w \0xFE\0xFE\0x98\0xE0\0x14\0x0B\0x01\0x0193\0xFD

MIC GAIN 100% *1w \0xFE\0xFE\0x98\0xE0\0x14\0x0B\0x02\0x0055\0xFD

AGC SLOW *1w \0xFE\0xFE\0x98\0xE0\0x16\0x12\0x03\0xFD

AGC MID *1w \0xFE\0xFE\0x98\0xE0\0x16\0x12\0x02\0xFD

AGC FAST *1w \0xFE\0xFE\0x98\0xE0\0x16\0x12\0x01\0xFD

MANUAL NOTCH - ON *1w \0xFE\0xFE\0x98\0xE0\0x16\0x48\0x01\0xFD

MANUAL NOTCH - OFF *1w \0xFE\0xFE\0x98\0xE0\0x16\0x48\0x00\0xFD

MANUAL NOTCH WIDTH - WID *1w \0xFE\0xFE\0x98\0xE0\0x16\0x57\0x00\0xFD

MANUAL NOTCH WIDTH - MID *1w \0xFE\0xFE\0x98\0xE0\0x16\0x57\0x01\0xFD

MANUAL NOTCH WIDTH - NAR *1w \0xFE\0xFE\0x98\0xE0\0x16\0x57\0x02\0xFD

MACRO HAMLIB COMMANDS

IC-7610 ON *PS1;

IC-7610 OFF *PS0;
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NOISE REDUCTION ON *U NR 1

NOISE REDUCTION OFF *U NR 0

NOISE REDUCTION LEVEL 2 *L NR .2

NOISE REDUCTION LEVEL 6 *L NR .6

ROTOR !ROTATE

ROTOR STOP !RTR STOP

NOTCH ON *U ANF 1

NOTCH OFF *U ANF 0

COMPRESSION ON *U COMP 1

COMPRESSION OFF *U COMP 0

PREAMP OFF *L PREAMP 0

PREAMP 10 *L PREAMP 10

PREAMP 20 *L PREAMP 20

CHANGE MAIN / SUB

ATTENUATOR OFF *L ATT 0

ATTENUATOR 6 DB *L ATT 6

ATTENUATOR 12 DB *L ATT 12

ATTENUATOR 18 DB *L ATT 18

VFO *V VFO

MEMORY *V MEM

ANTENNA 1 *A 0

ANTENNA 2 *A 1

RF -30% *L RF .26

RF -50% *L RF .51

RF 100% *L RF 1.0

14.300 Mhz *F 14300000*M USB 2500

50.525 Mhz *F 50525000*M USB 2500

MONITOR ON *U MON 1

MONITOR OFF *U MON 0

RESET
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RESET IS A LIST OF
COMMANDS (IN ONE MACRO)
THAT CLOSE THE COMMANDS
THAT I MIGHT HAVE OPENED. 

*U COMP 0*U NR 0*V VFO*ANF 0*L RF 1.0*U MON 0*A 1*L
PREAMP 0*L ATT 0*Y 1*U NB 0*U DUAL_WATCH 0*L PBT_IN .50*L
PBT_OUT .50*L MICGAIN .51*U MN 0*L RFPOWER 1.0*L AGC 5

NOISE BLANKER ON *U NB 1

NOISE BLANKER OFF *U NB 0

DUAL WATCH ON *U DUAL_WATCH 1

DUAL WATCH OFF *U DUAL_WATCH 0

PBT IN +150 *L PBT_IN .60

PBT OUT -150 *L PBT_OUT .60

PBT IN .0 *L PBT_IN .50

PBT OUT .0 *L PBT_OUT .50

COMPRESSION LEVEL 3 *L COMP .3

COMPRESSION LEVEL 5 *L COMP .5

COMPRESSION LEVEL 7 *L COMP .7

COMPRESSION LEVEL 10 *L COMP 1.0

RF POWER 8W *L RFPOWER .08

RF POWER 25W *L RFPOWER .26

RF POWER 50W *L RFPOWER .51

RF POWER 75W *L RFPOWER .76

RF POWER 100W *L RFPOWER 1.0

MIC GAIN 25% *L MICGAIN .26

MIC GAIN 50% *L MICGAIN .51

MIC GAIN 75% *L MICGAIN .76

MIC GAIN 100% *L MICGAIN 1.0
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AGC SLOW *L AGC 3

AGC MID *L AGC 5

AGC FAST *L AGC 2

MANUAL NOTCH - ON *U MN 1

MANUAL NOTCH - OFF *U MN 0

MANUAL NOTCH WIDTH - WID

MANUAL NOTCH WIDTH - MID

MANUAL NOTCH WIDTH - NAR

   

4.11 System

System Settings provides information about system aspects of RSS and buttons to reboot

RigPi or shut it down. System Settings is only available for Access Level 1 accounts.

Reboot RigPi Restarts RigPi. Any active user accounts must be restarted along

with connecting radios.
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Shut Down RigPi Use the Shut Down button before disconnecting power to RigPi.

Wait for the green activity light to stop blinking for proceeding.

Not doing so could damage the RigPi memory card.

Get FCC Database Refreshes the FCC callsign lookup database loaded on RigPi. The

refresh process takes about 15 minutes to complete. Note the

entire FCC database is updated by the FCC once per week.

LAN IP 1 RSS can connect to the Internet through Ethernet and/or Wi-Fi. If

only Ethernet or Wi-Fi is used, LAN IP 1 is the IP address for that

connection. Use LAN IP 1 for the LAN IP if you are setting up port

forwarding in your Internet router.

LAN IP 2 If RSS is connected to the Internet through an Ethernet connection

and through Wi-Fi, the Ethernet connection is shown in LAN IP 1

and the Wi-Fi address is shown in LAN IP 2.

WAN IP WAN IP is the public IP of your connection to the Internet. This is

the IP you can use to connect to RSS when away from home. You

must set up port forwarding in your router for RSS and Mumble to

operate remotely.

RPi Temp Shows the temperature of the CPU chip on the Raspberry Pi. The

core temperature goes up as the Raspberry Pi gets more heavily

loaded. The maximum operating temperature is rated for 80-deg

C. If the temperature goes above 85-deg, the CPU is throttled.

Normally you will see the temperature under 50-deg C.

Rigctl Port The port used to control the radio for the current account. Use this

port number if connecting to another application (such as Fldigi)

and you want to have both RSS and the other application control

the radio. You can also use this number to connect a second (or

more) accounts to the current radio. Enter the port number in the

Port field in Basic or Advanced Radio settings.

CCM Port The port used to connect CommCat Mobile or CommCat to RSS to

control the current radio.

RSS Vers The current RSS version number

Update RSS Files Update the RSS files to the most recent version. The update is a

two-step process. The first step checks version numbers. If the
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version check shows an update is available, the second step installs

the files from the RigPi web site. See Update RSS Files in Other

Programs.

Get RSS Stats Provides a brief summary of RSS Statistics, including time since last

reboot, number of connected users, and system loading.



This  page i s  intentional ly left blank.
Remove this  text from the manual
template i f you want i t completely blank.
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5 Other Programs

Additional Ham software provided with RigPi Station Server is accessed through the

Raspbian PIXEL Desktop. Click Pi Menu>Ham Radio to access the added ham programs.

Mumble, WSJT-X and Fldigi use the Raspberry Pi audio system, either through CODECs in

the radio or through the RigPi Audio board.  Only one program can use the audio system at

a time.  Close Mumble before using WSJT-X or Fldigi.

Using RigPi Station Server with WSJT-X

WSJT-X is designed to provide reliable communications in extreme weak-signal conditions.

WSJT-X, written by Joe Taylor, K1JT, is installed on RigPi Server. Frequency and Mode data

are shared between RigPi and WSJT-X, and QSO information logged in WSJT-X is

automatically transferred to RigPi Log.

To start WSJT-X, from the Raspberry Pi Desktop, open the applications menu and select

Ham Radio>wsjtx. The first time you start WSJT-X you are invited to enter your callsign and

Grid locator.

Connect to a radio from the File>Settings>Radio panel. Start RigPi Station Server and

connect the radio. Use the following values:

1. Rig: Hamlib NET rigctl

2. Network Server: localhost: 4532. The port will be different depending on which RSS

account you are using. Radio 1 uses port 4532, radio 2 uses port 4534, and so on.

3. Audio: If using a radio that has CODECs, choose the alsa_input and alsa_output devices

in the Input and Output drop-down lists in WSJT-X File>Settings>Audio>Soundcard. 

(The CODECs in your radio may have a different name.)

If using the RigPi Audio board (your radio doesn't have CODECs), make the following

selections:

If you use incorrect audio devices, WSJT-X will display a dialog warning of a problem:
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Some selections may not display an error at first, but after clicking Tune, then restarting

WSJT-X, the follwing error appears:

This issue appears to be present in WSJT-X 2.4.  You must reboot RigPi to clear the error

before resetting the audio device selection.

Some radios do not have a PTT-by-CAT function.  Select Hamlib GPIO in the H/W PTT drop

down list in Advanced Radio settings for PTT.  The CAT PTT setting is not used when you

use Hamlib GPIO for PTT.

WSJT-X Manual: Click to open WSJT-X manual

WSJT-X User Forum:  User Forum

http://physics.princeton.edu/pulsar/k1jt/wsjtx-doc/wsjtx-main-1.7.0.html
https://groups.yahoo.com/neo/groups/wsjtgroup/info
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Using RigPi Station Server with Fldigi

Fldigi is a multi-mode digital communications program, written by Dave Freese, W1HKJ

and team.

1. Rig: Hamlib NET rigctl

2. Audio: Configure>Sound Card>Audio>Devices. use the audio selections as used in

WSJT-X, above.  Check Device supports full duplex.

Fldigi Manual: Fldigi Manual

Fldigi User Forum: User Forum

Logging WSJT-X and Fldigi contacts

When RigPi is controlling your radio, contacts logged in WSJT-X or Fldigi are transferred to

your RigPi log.  In SETTINGS>Accounts>Account Editor, put checks in the Sync boxes as

desired.

Using TQSL for LoTW Uploads

LoTW/TQSL Manual: tQSL Quick Start

LoTW/TQSL User Forum: tQSL Forum

5.1 Overview

Additional ham radio programs are installed on RSS. The Other Programs topic provides

information that relates to RSS and the program. For complete Help for each program,

please refer to the respective program's web site.

Most of these programs are provided on an 'as-is' basis.  Support for configuring, using and

updating these programs is provided by the program authors and their user communities.

§ WSJT-X

§ JS8Call

§ Fldigi

§ Flrig

§ Flarq

§ Message Aggregator

http://www.w1hkj.com/FldigiHelp/
https://linuxham.groups.io
http://www.arrl.org/quick-start-tqsl
https://groups.io/g/ARRL-LoTW
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§ TrustedQSL (TQSL)

§ USB ID

§ Motion (Video)

§ Mumble Autostart

§ RSS Updater

§ phpMyAdmin

§ Audacity

§ Alsamixer

§ Nano

5.2 Alsamixer

RigPi Audio doesn't have settings of its own, but a Linux utility named Alsamixer is included

with RSS for that purpose. You can also use the Audio Device Settings window opened

from the Raspberry Pi Desktop applications menu found in the Preferences menu item. The

driver used for RigPi Audio is snd_rpi_proto. 

To start Alsamixer go to RSS Desktop and open the Terminal. Type alsamixer followed by

return.  The screen shot below shows the typical settings for the RigPi Audio board set up

for Mic input.

· Left and right arrow keys select a setting

· M key toggles MM-OO settings

· Tab to change View (Playback, Capture, All)

· Up and Down arrow keys to change levels

RigPi Audio uses the Line or Mic Input depending on settings. The Line Input

accommodates input voltages up to 2-volt peak-to-peak. The Mic input is for input levels

up to .2-volt peak-to-peak.  The Line input uses the left channel, it is not stereo.  Input from

the I/Q jack is stereo as required for Panadapters.



124

RigPi Station Server Version 3 
 
                                                                                                                                                                                                                          © 2021 Howard Nurse, W6HN

Other Programs

5.3 Connecting to RSS with External Programs

Connecting Multiple Programs to RSS

RSS combined with CommCat provides another layer of flexibility. The screen shot below

shows RSS, CommCat and PowerSDR running on Windows.  All programs are linked

together. Not shown is CommCat Mobile running on an iPad also connected to RSS.  

Important note:  CommCat and CommCat Mobile have been discontinued as of October,

2020.  If you have CommCat or CommCat Mobile you can continue to use them with RigPi. 

CommCat is not required for RSS.  It is best to connect to RSS through a browser.

A frequency change in one program is reflected by all programs.

PowerSDR is connected to CommCat through a free Virtual Port program called RigPi Hub.

This program is available for download from https://www.rigpi.net. Here are the details on

how this is done.

The Kenwood TS-2000 CAT command set is used to connect CommCat to RSS via a

separate TCP connection through a local network. The use of "TS-2000," below, is used for

this purpose even though you may be controlling a completely different radio through RSS.

1. Open RSS in a Windows browser. RSS is controlling the radio.

2. Start RigPi Hub which in turn starts CommCat.

3. In CommCat>File>Settings>Radio A, connect to TS-2000 through Remote IP <RSS LAN

IP> on port <RSS CommCat Mobile Port>. In RigPi Hub open a serial port after putting

https://www.rigpi.net
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a check in the associated CAT box.  <RSS LAN IP> is the IP for RigPi.  <RSS CommCat

Mobile Port> is the TCP port provided by RSS.  You can see this port in RSS

SETTINGS>System.  It changes depending on the account being used in RSS.

4. Start PowerSDR and connect as a TS-2000 to a RigPi Hub COM port.

RSS, CommCat, RigPi Hub, and PowerSDR all show the same frequency and mode. Each

can control the radio connected to RSS.

CommCat Mobile (discontinued)

CommCat is an iOS app which was available for free from the Apple app store.  CommCat

Mobile was designed to work with CommCat and QSXer (both Windows programs), but it

can connect to and control RigPi.  To connect CommCat Mobile, start CommCat Mobile

and go to Settings>Remote Control. In Radio IP enter the RSS LAN IP address and the RSS

CommCat Mobile port shown in RSS SETTINGS>System. Select the TS-2000 (thru Internet)

radio. Now RigPi can be controlled from your iPad or iPhone using CommCat Mobile rather

than a browser.

CommCat Mobile Macros

CommCat Mobile Macros are different from the normal CommCat Mobile Macros when

you wish to do direct rig control.  Macros can use hex characters (such as for Icom radios)
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or ASCII characters (such as for Kenwood radios).  In addition RigPi hex delimiting is used

rather than the CommCat Mobile hex delimiting.  RigPi radio macros will not work on

QSXer or CommCat.

Here is a sample Icom macro to turn on split using hex format:

HEX0w \0xfe\0xfe\0x94\0x0e\0x0f\0x01\0xfd

If you expect data back from the macro, use HEX1w.

Here is a sample Kenwood macro to turn on split using ASCII format:

ASC0w FT1;

5.4 Contour ShuttleXpress

The Contour ShuttleXpress provides a convenient way to adjust the RigPi frequency and

control PTT using a Windows or Mac computer through a USB port.  (A ShuttleXpress driver

is not available for Linux.)  RigPi Preference files used to assign buttons and controls are

provided for Chrome, Edge and Firefox browsers.

1. Download and install the Windows or Mac Driver program:

https://www.contourdesign.com/shuttle-drivers/

2. Download and unzip the RigPi Shuttle preferences file:

https://www.contourdesign.com/shuttle-drivers/
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https://rigpi.net/downloads/RigPi-ShuttleXpress.zip

3. Start the Contour Shuttle Configuration Program (Windows)

4. Decide which browser you want to use, Chrome, Edge or Firefox.  (If you want to another

browser, you can create your own preferences file using instructions in the ShuttleXpress

manual:

https://mk0uniclone3cn8yi1ru.kinstacdn.com/wp-content/uploads/2019/02/shuttle-

product-manual.zip

5. Browser preferences are already included in the Application setting list.  The one you

want to use must be deleted, and the corresponding RigPi preferences file imported. 

For example, if you want to use Chrome to control RigPi, delete the Google Chrome

entry in the list.

6. Import the RigPi preferences file you want to use from the Options menu.

7. When your selected browser is in front the RigPi buttons and controls can be used.

https://rigpi.net/downloads/RigPi-ShuttleXpress.zip
https://mk0uniclone3cn8yi1ru.kinstacdn.com/wp-content/uploads/2019/02/shuttle-product-manual.zip
https://mk0uniclone3cn8yi1ru.kinstacdn.com/wp-content/uploads/2019/02/shuttle-product-manual.zip
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5.5 Fail2ban

Fail2ban is widely used program that helps prevent unauthorized access to RigPi.  Fail2ban

is installed and enabled on RigPi.

5.6 Flarq

Flarq is a messaging/file transfer program that works in conjunction with Fldigi. See the

Flarq web site for more information.

Flarq Web Site

5.7 Fldigi

Fldigi is a popular digital mode program that is preloaded on RSS. Detailed instructions

are beyond the scope of this manual, please refer to the Fldigi web site:

Fldigi Web Site

This Help topic covers use of Fldigi in RSS.

Radio Connection

RSS and Fldigi both use the Hamlib radio control library. Using the Hamlib "Net rigctl"

radio selection in Fldigi it is possible to have both RSS and Fldigi control the radio.

Connect RSS to your radio in SETTINGS>Radio. Go to Fldigi Configuration>Rig>Hamlib.

Select Hamlib NET rigctl (Beta) for Rig and localhost:<RSS Port> for Network Server. You

can now control frequency from Fldigi or RSS.

The <RSS port> is determined by the account you wish to use in RSS.. Use the port number

shown in RSS SETTINGS>Radio>Rigctl Port.

Logbook Connection

Contacts logged in Fldigi are automatically transferred to the active log in RSS for the

account specified by the sync option in RSS SETTINGS>Users>Edit>Sync Fldigi Log.

Audio Connection

http://www.w1hkj.com/
http://www.w1hkj.com/
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RigPi Audio or a radio CODEC is used for input and output audio for Fldigi. Since Audio is

limited to one application at a time, make sure the Mumble Client used for VoIP is not

running. Choose the audio capture and output devices in the Capture and Playback drop-

down lists in Fldigi Configuration>Audio associated with your setup.

Use these settings:

Using RigPi Keyer with Fldigi

Fldigi supports the K1EL Winkeyer for sending CW.  To configure RigPi Keyer, go to

Configure>Config Dialog>Modem>CW>WinKeyer.  Select /dev/ttyS0 for the Ser Port.  

Select other options as desired,  then click Connect.  The indicator light in the Connect

button turns yellow, and "Connected ti Winkeyer h/w/version 30" is displayed in Fldigi.  You

can now use Fldigi to send CW through the RigPi Keyer.  (Note: Fldigi will report that

Winkeyer version 31 or higher is required to use the RigPi Keyer for the Fldigi TTY mode if

an older chip is found.)

5.8 Flic Switch and iOS Shortcuts

Flic is a remote control switch that uses Bluetooth for communicating with phones, tablets,

and Mac computers. For purchase a Flic or more information go to: 

https://flic.io

https://flic.io
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The Flic has three modes: single, double, and long tap.  Below are the steps to take to

program a Flic for PTT on, PTT off, Power on and Power off.  You do not need a Flic Hub for

RigPi although using one means you don't have to use a phone or tablet at home.  Four

actions are described below, but the Flic has three modes.  You can use more than one Flic

to create combinations of actions.

1. Download the Flic app from the App store (for Apple devices) and the Play store (for

Android devices.

2. Agree to accept Notifications

3. Agree to the Terms of Service

4. Create an Account

5. Tap the PHONE tab at the top

6. Click Add Flic to Phone

7. Tap and hold the Flic until it connects

8. Tap Finish

You will see "My Flic" on your screen.

1.  Tap My Flic

2.  Change the name to RigPi

PTT On
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1.  Tap the red + button to enter a new Click action for PTT On

2.  Scroll down, open Advanced, and select Internet Request

3.  Add this URL*:

http://rigpi3.local/flic.php?n=1&u=admin 

4.  Tap your Flic once to send the PTT On command to your radio

PTT Off

1.  Tap the red + button to enter a new Double Click  action for PTT Off

2.  Scroll down, open Advanced, and select Internet Request

3.  Add this URL*: 

http://rigpi3.local/flic.php?n=2&u=admin 

(Substitute your username for admin)

4.  Tap your Flic twice to send the PTT Off command to your radio

Power On

1.  Tap the red + button to enter a new Hold action for Power On

2.  Scroll down, open Advanced, and select Internet Request

3.  Add this URL*:

 

http://rigpi3.local/flic.php?n=3&u=admin 

(Substitute your username for admin)

4.   Tap, double-tap, or hold to send the Power On command to your radio

Power Off

1.  Tap the red + button to enter a new Hold action for Power Off

2.  Scroll down, open Advanced, and select Internet Request

3.  Add this URL*: 

http://rigpi3.local/flic.php?n=4&u=admin 

(Substitute your username for admin)

4.  Tap, double-tap, or hold to send the Power Off command to your radio

Control Relay (see Relay Switching  )144
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1.  Tap the red + button to enter a new Tap action for Toggle Relay

2.  Scroll down, open Advanced, and select Internet Request

3.  Add this URL*:

 

http://rigpi3.local/flic.php?n=5&u=admin&p=n

(Substitute your username for admin, n is relay parameter x-y. X is the relay

number, y is 1 for relay on and 0 for relay off. 0-0 resets all relays. 9-1 turns on all

relays.)

4.  Tap to send the Toggle Relay command to RigPi

Send CW message

1. Tap the red + button to enter a new Tap action for Toggle Relay

2. Scroll down, open Advanced, and select Internet Request

3. Add this URL*:

http://rigpi3.local/flic.php?n=6&u=admin&p=<cw message>

(Substitute your username for admin, <cw message> is the desired CW text.)

4. Tap to send the CW Message command to RigPi

Frequency

1. Tap the red + button to enter a new Tap action for Toggle Relay

2. Scroll down, open Advanced, and select Internet Request

3. Add this URL*:

http://rigpi3.local/flic.php?n=7&u=admin&p=<frequency>

(Substitute your username for admin, <frequency> is the desired frequency to the

nearest Hz.)

4. Tap to send the Set Frequency command to RigPi

Set to FT8 on Band

1. Tap the red + button to enter a new Tap action for Toggle Relay

2. Scroll down, open Advanced, and select Internet Request

3. Add this URL*:

http://rigpi3.local/flic.php?n=6&u=admin&p=<cw
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http://rigpi3.local/flic.php?n=8&u=admin&p=<band>

(Substitute your username for admin, <band> is the desired band, such as 80, 40, or

20.)

4. Tap to send the Toggle FT8-on-Band command to RigPi

* The URL rigpi3.local is not recognized by Android devices.  Use the IP for RigPi instead. 

The IP can be found in RigPi>SETTINGS>System.

Use rigpi3.local or the RigPi IP when using Flic on the same network as RigPi.  For the Flic to

work when away from home, use the WAN IP shown in SETTINGS>System.  You may want

to use a second Flic for use when away from home.  Port 80 must be opened in your router

to use Flic away from home.

iOS Shorcuts

Apple iOS devices have a feature called Shortcuts.  Shortcuts can be used to trigger actions,

just as Flic switches.  The same command strigs are used.

     

Use iOS shortcuts on your local LAN without port  forwarding.  If you want to use Shortcuts

away from home, use your WAN (Internet) IP and open port 80 for forwarding.

5.9 JS8Call

JS8Call is a derivative of the WSJT-X application, structured and redesigned for message

passing.  It is not supported by, nor endorsed by, the WSJT-X development group.
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This Help topic covers use of JS8Call in RSS.

Radio Connection

RSS and JS8Call both use the Hamlib radio control library. Using the Hamlib "Net rigctl"

radio selection in JS8Call it is possible to have both RSS and JS8Call control the radio.

Connect RSS to your radio in SETTINGS>Radio. Go toJS8Call File>Settings>Radio. Select

Hamlib NET rigctl for Rig and localhost:<RSS Port> for Network Server. You can now

control frequency from JS8Call or RSS.

The RSS port is determined by the account you wish to use in RSS. Use the port number

shown in RSS SETTINGS>Radio>Rigctl Port.

Logbook Connection

Contact logged in JS8Call are automatically transferred to the active log in RSS for the

account specified by the sync option in RSS SETTINGS>Users>Edit>Sync WSJTX Log. Log

data are transferred using the N1MM Logger+ Broadcasts options in JS8Call12060

File>Settings>Reporting. RSS expects a connection on N1MM Server port number 12060.

Audio Connection

RigPi Audio or a radio CODEC is used for input and output audio for JS8Call. Since Audio is

limited to one application at a time, make sure Mumble used for VoIP is not running.

Choose default in the Input and Output drop-down lists in JS8Call

File>Settings>Audio>Soundcard.

5.10 Message Aggregator

Message Aggregator implements the server side of the message protocol used by WSJT-X.

WSJT-X is a client of the protocol.

5.11 Motion (Video)

Motion is an application for creating streaming video.  Motion is installed and configured

on RigPi.  The primary use for RigPi video is to keep an eye on your radio while operating

remotely.
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Motion can use most webcams.  Plug a webcam into one of the USB ports on RigPi and

Motion will find it.

Extensive control over Motion is provided through a configuration file.  To view and edit

this file, use the following command from Terminal:

sudo nano /etc/motion.conf

For example, if you wish to disable Motion if you will not use the video feature, edit the

line 'daemon on' to 'daemon off'.  The height of width of the camera image is determined

by the height and width parameters.  This affects the size of the capture image, not the

displayed image.  You can see the captured image in rigpi3.local:8081.   Increasing the

framerate will decrease the video lag time, but will increase the computing resources

required.

You can change the width and height of the image in the Tuner window by editing the html

in /var/www/html/index.php.  There are three places the size can be changed.

The Motion log is located in /var/log/motion/motion.log
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RigPi video can replace the Tuning Knob, S-meter or Frequency panel on the Tuner

window.  See the Advanced Radio  Settings topic for how to set the mode you wish to

use.

The view option you choose in Advanced Radio settings will affect the appearance of

video on a mobile device.

No Video: the Frequency Panel and Tuning knob are shown.

Video -> S-meter: The Frequency Panel, Video and Tuning Knob are shown.

82



137

RigPi Station Server Version 3 
 
                                                                                                                                                                                                                          © 2021 Howard Nurse, W6HN

Other Programs

Video -> Frequency Panel: Video and Tuning Knob are shown

 

For more help, go to 

https://motion-project.github.io/

https://motion-project.github.io/
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If the frame for the video shows with no contained video, check the ad blocker on the

browser you are using.

5.12 Mumble

Mumble is an open source VoIP system. A VoIP server called Murmur is installed on RSS

along with the Mumble client. The RigPi Audio board normally provides an input and

output path for Mumble client, although USB audio sound devices or radio CODECs can

also be used. One radio can be connected to the Mumble client. Remote Mumble clients

can also connect to the server and receive and send audio. Mumble clients are available for

all popular operating systems.

The Murmur Server is named RigPi VoIP Server and the configured Mumble Client is named

pi. Mumble can be started manually from the RSS Desktop Menu by selecting

Internet>Mumble. A utility named Mumble Autostart is in the Internet menu as well as on

the RSS Desktop. Run Mumble Autostart to have Mumble start automatically when RSS is

rebooted. 

When you start Mumble the Mumble window opens on RSS:

Mumble Settings

If you make any changes to Mumble settings, click Apply at the bottom of the settings

window to test.  When you are satisfied, click OK.  Restart Mumble to have the settings

stick.
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Mumble uses RigPi Audio for input and output audio, audio USB dongles, or CODEC's from

your radio. Set Device to Default Input in Audio Input and Default Output Audio Output.

Refer to Mumble Help for setting up Mumble. One setting that applies to Mumble in RSS is

found in the Audio Processing group of Mumble Configure>Settings>Audio Input. Set the

Audio Processing to Disabled. If Noise Suppression is enabled the normal background

noise on HF can cause distortion and clicking in the audio output. (See screen shot below.)

Mumble can send audio continuously, by use of a PTT key, or by detecting the presence of

audio.  The screen shots below are shown below to include all audio in and audio out

settings.  The settings shown are typical.  You will have to adjust them to maximize audio

quality with your RigPi.
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In Mumble Configure>Settings>Network enable the 'Reconnect automatically' and

'Reconnect to last server on startup' options.

Audio Input

Transmit: This lets you change what causes audio from your radio to be sent.  I

recommend "Continuous", but you can also have Mumble attempt to transmit only when

there is active audio from your remote device.

Audio Cue:  This causes a sound to play whenever you press or release the Push-To-Talk

key. Not active when Continuous Transmission is selected.

Idle action: This will cause Mumble to automatically mute the receive audio if there is no

radio audio for a certain amount of time. Dragging this slider all the way to the left will

disable this feature.

Quality: This is the quality at which Mumble will encode audio from your radio. I

recommend that you leave this at 40.0 KB/s. However, if the audio sounds distorted, you

can try raising or lowering this value.

Audio per packet: This is the amount of audio that Mumble sends at a time. A lower value

means less latency, but might potentially introduce quality loss, if too low. I recommend

that you leave this at 20 ms.

Noise Suppression: Mumble can automatically filter out static background noise. When set

to Speex, RNNoise or Both, a slider will adjust how aggressively noise is filtered. If filtering

is too aggressive, then your voice may become distorted. I recommend setting Noise

Suppression Disabled to remove all noise suppression.
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Max. Amplification: This setting controls how loud the receive audio is. 

Audio Output

Default Jitter Buffer: If your mic audio is distorted, metallic, or sounds like a robot, try

increasing this setting a notch or two.

Volume: Output volume. The volume at which audio is sent to the mic/audio input.

Output Delay: If your transmit audio is distorted or is breaking up, try increasing this value.

Attenuate applications by...: This setting determines how much Mumble will reduce other

applications' volume when people talk. A setting of 100% means to mute other

applications; 0% means to not do anything to other applications. Additionally, you can

select to attenuate when others talk, and/or when you talk with the "while other users talk"

and "when you talk" check boxes.

Loop back: This is a super handy feature for troubleshooting problems with your transmit

audio settings. You can set Mumble to "loop back" to you, so you hear what you are saying

the way other people will hear you. When troubleshooting, try setting this to "Server", and

then tweak options in Audio Input and Audio Output to get your audio sounding just right.

Remember to set it back to "None" after you're finished, or else nobody will be able to

hear you

Managing Accounts

If you wish to remove clients that have been registered, set up a new user with username

SuperUser. The SuperUser can delete registered accounts.

Using a Remote Server

RSS is can use an external Mumur server. If RSS is connected to the Internet and you expect

to have a large number of users, a remote Murmur server may be attractive.

Murmur servers are available for free or low cost. Commercial server companies typically

charge based on the number of "slots" you want to use. A slot is a unique user logged in to

the server. Server fees typically run less that $2 per month per slot. Details for connecting to

a remote server are beyond the scope of this manual, but instructions are usually given on

the server you choose.

Running more than one Mumble client
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Since RSS is multi-user, one wonders if it is possible to run audio from more than one radio

through RSS. The short answer is yes! RSS can serve multiple users for rig control AND

audio.

There are two requirements.

 

1. You need one (or more) audio IO devices in addition to RigPi Audio. This can

be done with a USB audio dongle. For my tests I used a Griffin dongle, but any

inexpensive USB/Audio device should work well. 

2. The second (and subsequent) Mumble clients must be started in a special way. 

Close any open Mumble clients on the Raspberry Pi desktop.  To start the first instance, go

to the RSS Desktop Menu and open Run... In the Run box, type 

/home/pi/mumble/build/mumble -m -n

then press enter.  The -m parameter signifies a multiple instance.  The -n parameter tells

Mumur to ignore security certificates.

Create a new Servername in the Mumble Server Connect dialog, such as "Radio2".  Edit the

connection and use a different Username, such as pi2.  Enter localhost for the Address. 

Click OK, then connect.  You will see ywo instances of Mumble on your desktop.
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Now you can log in. I used pi2 as the username. With two clients you see both users in the

client lists, pi and pi2. The user connected with its primary client is shown in bold. Assign

the audio dongle to the second client. Now you can connect the audio to/from two rigs.

Since all users hear all other users, you will hear audio from both radios. That has

interesting possibilities, such as monitoring 2 repeaters at once. You may want to keep the

audio from the two radios separate, in which case there is a way to do that. Mumble

provides channels, users can be assigned to channels, and the audio is separated.  From a

remote device you can create two accounts, one for each channel.  To switch from one

channel to the other, log out from the Mumble client on the remote device and log in to

the other account.

To create channels, log in to Mumble with the username SuperUser.  Superusers can create

channels and assign users to default channels.  Here are more details:

https://support.mayfirst.org/wiki/mumble-private-channel

Install Bonjour

The Mumble server requires that Bonjour be installed on your computer for clients to

connect.  If you are using a Windows computer, follow the instructions here .  Mac

computers already have Bonjour installed.

5.13 Mumble Autostart

Mumble Autostart is a program that controls how Mumble is started. Mumble can be

started manually through the Menu Internet>Mumble option or by having it start

automatically when RSS is started or rebooted.

The Mumble Autostart program icon is in the Internet menu, and also located on the RSS

Desktop.

162

https://support.mayfirst.org/wiki/mumble-private-channel
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5.14 Panadapter

IQ Panadapter software is not provided with RSS. Here is a link to AA6E's web page that

describes the Tiny Python Panadapter originally published in the April 2014 issue of QST.

An I/Q connection is provided on RigPi Audio to provide wide-band stereo audio to

Panadapter programs. 

AA6NE Panadapter

5.15 Relay Switching

The Sainsmart 8-channel 12V Relay Module is compatible with RigPi.  It is controlled from

one of the Raspberry Pi USB ports using a standard USB A/B cable.  It requires an external

12 V power supply.

The module can be purchased from Sainsmart, https://sainsmart.com

The relays are able to switch 28 VDC or up to 250 VAC at 10 amps.

There are several caveats...

§ When you power up the Raspberry Pi or reboot, the relays are toggled several times. 

According to Sainsmart, this is a characteristic of the FTDI chip used on the board.

§ Be careful when connecting a 12 V power supply to not reverse the polarity.  There is

no protection against reversed voltage on the board.

§ To control the Relay Module, select Macro Decimal or Band BCD in the Slv Cmnd

drop down list.  Set the Slave Port to None

§ After a reboot, a ttyUSBn port is shown for the relay board.  Once you send a

command to the board this port disappears.

§ The relay module can only be controlled by one account.

§ IMPORTANT: The switch must be the only one connected to RigPi that has an FTDI

chip set. (Use the command lsusb in Terminal to check.)

The relays can be toggled automatically in the BCD Band mode, or individually via macros

in the Macro Decimal mode.  You can also use a Flic switch to toggle relays.  Macros for the

https://aa6e.net/nw/index.php/notable-projects/13-tiny-python-panadapter
https://sainsmart.com
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Macro Decimal mode can be stacked, so !SW1-1!SW3-1 turn relays 1 and 3 on. !SW1-

0!SW3-1 turns relay1 off and relay 3 on.

See the Advanced Radio  topic for settings and the Flic topic  for Flic programming

instructions.

5.16 TrustedQSL

Open source libraries and utilities to support using digital signatures for Amateur radio

QSL information. It can be used to digitally sign and upload QSOs to the ARRL's Logbook

of the World (LoTW) online service and to manage the Callsign Certificates used when

digitally signing. TQSL accepts QSOs in a log file whose format is either ADIF or Cabrillo,

which RSS can create.

5.17 Update RSS Files

Updating the files for RSS is done automatically when a new version is detected, or

manually from the SETTINGS>System menu.  Updates provided on the https://rigpi.net

server are downloaded to RSS, unzipped and copied to the correct RSS folders.  Only files

newer than a corresponding file are updated.  The update retains all user settings and

databases.

To update manually:

1. In RSS go to SETTINGS>System and click Update RSS Files. If a new version is detected,

click OK to proceed.

2. When the update is done click OK to reboot RigPi to refresh all files.

Updating RSS files does not update any system files or other installed programs. See

Updating the Raspbian Operating System in the Technical>System topic.

5.18 USB ID

If you have more than one device (radio and/or rotor) connected through USB ports, the

port number assigned when you reboot may change. What was ttyUSB0 for radio 1 and

ttyUSB1 for radio 2 can be reversed. The list order can change because response timing

may vary when you reboot even though no changes have been made.  RigPi also allows the

use of USB long names, which is preferred over using USB ID.

A utility program is provided in the Ham Radio menu to rename the ports and make them

stable. The program is named USB ID.

82 129

https://rigpi.net
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The original port continues to be listed as ttyUSBx. Once you run USB ID, the connect for

that radio or rotor will be listed as radiox, where x will remain unchanged. You might see

radio1 which is the same as ttyUSB2.

Clearing the Radio list

At some point you may wish to clear the list of radios USB ID maintains to have a fresh

start.  Here is how to do that:

1. From RSS Desktop, open Terminal
2. Type sudo su <return>
3. Type cd /etc/udev/rules.d <return>
4. Type rm 99-hamdevices.rules <return>
5. Type touch 99-hamdevices.rules <return>

5.19 WSJT-X

WSJT-X is a popular digital mode program that is preloaded on RSS. Detailed instructions

are beyond the scope of this manual, please refer to the WSJT-X web site:

WSJT-X Manual

This Help topic covers use of WSJT-X in RSS.

Radio Connection

RSS and WSJT-X both use the Hamlib radio control library. Using the Hamlib "Net rigctl"

radio selection in WSJT-X it is possible to have both RSS and WSJT-X control the radio.  

Connect RSS to your radio in SETTINGS>Radio. Go to WSJT-X File>Settings>Radio. Select

Hamlib NET rigctl for Rig and localhost:<RSS Port> for Network Server. You can now

control frequency from WSJT-X or RSS. 

https://physics.princeton.edu/pulsar/k1jt/wsjtx.html
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The RSS port is determined by the account you wish to use in RSS. Use the port number

shown in RSS SETTINGS>Radio>Rigctl Port.

 If your radio requires PTT control on an ACC connector to switch audio routing, use the

H/W PTT Hamlib GPIO option in Advanced Radio settings.

Logbook Connection

Contact logged in WSJT-X are automatically transferred to the active log in RSS for the

account specified by the sync option in RSS SETTINGS>Users>Edit>Sync WSJTX Log. Log

data are transferred using the N1MM Logger+ Broadcasts options in WSJT-X

File>Settings>Reporting. RSS expects a connection on N1MM Server port number 12060.

Audio Connection

RigPi Audio or a radio CODEC is used for input and output audio for WSJT-X. Since Audio

is limited to one application at a time, make sure the Mumble VoIP program isn't running..

Choose default in the Input and Output drop-down lists in WSJT-X

File>Settings>Audio>Soundcard.

If your radio has internal CODECS, use these settings (may vary depending on your radio):
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6 Technical

Information about technical aspects of RSS are contained in this section.

6.1 Glossary

Term Definition

ARRL

The American Radio Relay League (ARRL) is a worldwide

organization of amateur radio operators with its headquarters in

Newington, Connecticut, USA.  

Account
RSS provides user accounts with usernames and passwords. Each

account manages a radio, keyer, and rotor.

Ajax

Asynchronous JavaScript and XML is a method of building

interactive applications for the Web that process user requests

immediately. Used in RigPi.

API Application Programming Interface

Bootstrap
An open source toolkit for developing web content with HTML, CSS,

and JS provided by Twitter. Used in RigPi.

CAT Computer Aided Transceiver. A protocol for controlling radios.

Client A computer or mobile device connected to RSS.

CSS
Cascading style sheets. Cascading style sheets are used to format

the layout of Web pages. Used in RigPi.

CW, Element

Based

Remote CW by sending timing of CW elements (dits and dahs).

CW, Character

Based

Remote CW by sending ASCII characters (A, B...)

Download Transfer data to a client, such as a PC, to RSS

GPIO
General Purpose Input Output, a connection used by the Raspberry

Pi for controlling external devices.
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Term Definition

Hamlib
A radio and rotor library developed to facilitate control of ham

equipment. Used in RigPi.

JavaScript
An object-oriented computer programming language commonly

used to create interactive effects within web browsers. Used in RigPi.

jQuery
A concise and fast JavaScript library that can be used to simplify

event handling, HTML document traversing. Used in RigPi.

LoTW
Logbook of the World, a service from ARRL that provides secure

electronic QSO confirmations.

MariaDB

A community-developed fork of the MySQL relational database

management system intended to remain free under the GNU GPL.

Used in RigPi.

MOMR Multiple-operator, multiple-radio, supported by RSS

MySQL
An Oracle-backed open source relational database management

system (RDBMS) based on Structured Query Language (SQL)

PHP

PHP is a server scripting language, and a powerful tool for making

dynamic and interactive Web pages. PHP is the acronym for PHP:

Hypertext Preprocessor. (It originally meant "Personal Home Page.")

Used in RigPi.

Port

Forwarding

Providing a data path through a router so devices on a LAN can be

accessed from the Internet.

Raspberry Pi
A small single-board computers developed in the United Kingdom

by the Raspberry Pi Foundation 

RSS RigPi Station Server

Upload Transfer data from a client, such as a PC, to RSS

TQSL
Trusted QSL provides secure transfer of logs to and from the

Logbook of the World
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Term Definition

VoIP

Voice over IP, the technology used to provide 2-way audio to and

from RSS for remote operations. RSS uses the free, open-source

program Mumble to provide VoIP.

6.2 Installing the latest Hamlib

The Hamlib control library is constantly updated by the maintenance team.  Hamlib must

be updated in RigPi manually using these steps:

1. Open the Raspberry Pi Desktop

2. Open the browser by clicking the Globe in the toolbar.

3. Navigate to the Hamlib folder in Github to get the latest Beta version (you can also

select the latest release version):

https://github.com/Hamlib/Hamlib

4. Click the green Code button, then Download ZIP.

5. Right-click over the Hamlib-master.zip button at the bottom of the browser and select

Show in folder.

6. In the Downloads folder right-click Hamlib-master.zip and select Extract here.

7. Close the Downloads folder and the browser.

8. Open Terminal by clicking the >_ black icon at the top of the Desktop.

9. Type these commands:

cd /home/pi/Downloads/Hamlib-master

./bootstrap

./configure

make

sudo make install

Let each command complete before entering the next command.  The make process will

take several minutes.

Once the make install command is complete you are good to go.  Start RigPi and use

Connect Radio.

If you installed the Hamlib to pick up a new radio, you need to add that radio to the RigPi

radio database. To get the values for the list below, open Terminal and type the following:

rigctl -l

https://github.com/Hamlib/Hamlib
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(lower-case L)

Look for the radio you want to add in the resulting list.

1. Start phpMyAdmin from the Raspberry Pi desktop app menu, Programming.

2. Use username root and password 7388.

3. Expand the station database by clicking the +.

4. Open the Radios table.

5. Click Insert, then add the following values:

OLDNUMBER Hamlib ref number for this radio

NUMBER Hamlib ref number for this radio

SAMEAS Hamlib ref number for this radio

MANUFACTURER Name

MODEL Model number

VERSION Hamlib version for this radio

STATUS Hamlib status

Click Go at the bottom left and close phpMyadmin.  The newly added radio appears in the

Radio list in Advanced Radio settings.

6.3 Panels

The Graphics User Interface (GUI) used in the RSS Tuner window is based on a commercial

product "Perfect Widgets" by Perpetuum Software. The Frequency, S-meter and Tuning

Knob panels use HTML5 JSON technology to provide a modern look.  This is proprietary

software.

Perfect Widgets site

It is possible to modify RSS code to set your own values in each panel. By means of an

online inspector, you can see the tree structure of the respective JSON object.

JSON code inspector

The Perfect Widgets development tools are proprietary. The RSS panels are developed

using a "Developer's License." A limited free version of Perfect Wiglets is available on the

Perpetuum web site.

Perfect Widgets 2.0

EULA - End User License Agreement
 

http://perfectwidgets.com/Main
http://perfectwidgets.com/inspector/
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End User License Agreement for Perfect Widgets

Perpetuum Software LLC

Perfect Widgets

SOFTWARE COMPONENT PRODUCT

Copyright (C) 2012 Perpetuum Software LLC

END-USER LICENSE AGREEMENT FOR PERFECT WIDGETS SOFTWARE COMPONENT

PRODUCT

IMPORTANT - READ CAREFULLY: This Perpetuum Software LLC End-User License

Agreement ("EULA") is a legal agreement between you, a developer of software

applications ("Developer End User") and Perpetuum Software LLC (Vendor) for Perfect

Widgets SOFTWARE COMPONENT PRODUCT, its relevant controls, source code, demos,

intermediate files, media, printed materials, and "online" or electronic documentation

("PRODUCT") contained in the installation file.

By installing, copying, or otherwise using the PRODUCT, the Developer End User agrees to

be bound by the terms of this EULA. The PRODUCT is in "use" on a computer when it is

loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard

disk, CD-ROM, or other storage device) of that computer. If the Developer End User does

not agree to any part of the terms of this EULA, THE DEVELOPER END USER CAN NOT

INSTALL, USE, DISTRIBUTE, OR REPLICATE IN ANY MANNER, ANY PART, FILE OR PORTION

OF THE PRODUCT, OR USE THIS PRODUCT FOR ANY OTHER PURPOSES.

The PRODUCT is licensed, not sold.

LICENSE GRANT.

Upon acceptance of this EULA and subject to the payment of the fee required and the

terms and conditions herein the Vendor grants the Developer End User a personal,

nonexclusive license to install and use the PRODUCT on compatible devices for the sole

purposes of designing, developing, testing, and deploying application programs the

Developer End User creates (Final Application). If the Developer End User is an entity, it
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must designate one individual within its organization to license the right to use the

PRODUCT in the manner provided herein.

The Developer End User may install, use the PRODUCT, and distribute final application

programs as permitted by the license type purchased. The license type purchased is

specified in the product receipt.

a) Website License. Under Website license, the Developer End User is hereby granted one

(1) license per one (1) high-level domain name where the Final Application can be

deployed and unlimited number of developer licenses to use the PRODUCT for the purpose

of developing software applications. Developer End User must purchase another separate

license to the PRODUCT for each and any additional domain name where the Developer

End User intends to deploy the Final Application.

b) Developer License. Under Developer License the Developer End User is hereby granted

one (1) license as one (1) designated user to use the PRODUCT for the purpose of

developing software applications and unlimited number of licenses for deploying the Final

Application on high-level domains. Developer End User must purchase another separate

license to the PRODUCT for each and any additional Developer. There is no limit or

restriction on the number of installations of PRODUCT, which may be on different

machines; provided, however, that the PRODUCT may not be used by anyone other than

you as a single developer. For example, if a company has five developers using the

PRODUCT, the company needs to purchase five licenses, irrespective of how the Software is

accessed or how many installations are accessed.

c) Enterprise License. Under Enterprise License, the Developer End user is hereby granted

with unlimited number of developer licenses for the purpose of developing software

applications and unlimited number of domain licenses for deploying the Final Application

on different domains.

DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS.

Not for Resale Software.
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If the PRODUCT is labeled and provided as "Not for Resale" or "NFR", then,

notwithstanding other sections of this EULA, the Developer End User may not resell,

distribute, or otherwise transfer for value or benefit in any manner, the PRODUCT or any

derivative work using the PRODUCT. The Developer End User may not transfer, rent, lease,

lend, copy, modify, translate, sublicense, time-share or electronically transmit the

PRODUCT, media or documentation. This also applies to any and all intermediate files,

source code, and compiled executables.

Limitations on Reverse Engineering, Decompilation, and Disassembly.

The Developer End User may not reverse engineer, decompile, create derivative works,

modify, translate, or disassemble the PRODUCT, and only to the extent that such activity is

expressly permitted by applicable law notwithstanding this limitation. The Developer End

User agrees to take all reasonable, legal and appropriate measures to prohibit the illegal

dissemination of the PRODUCT or any of its constituent parts and redistributables to the

fullest extent of all applicable local, federal and international laws and treaties regarding

anti-circumvention, including but not limited to the Geneva and Berne World Intellectual

Property Organization (WIPO) Diplomatic Conferences.

Rental and Transfer.

The Developer End User may NOT permanently or temporarily transfer ANY of his/her

rights under this EULA to any individual or entity. The Developer End User may not rent,

lease, or lend the PRODUCT. Regardless of any modifications which the Developer End

User makes and regardless of how the Developer End User might compile, link, and/or

package his/her programs, under no circumstances may the libraries, redistributables,

and/or other files of the PRODUCT (including any portions thereof) be used for developing

programs by anyone other than the Developer End User

Intellectual Property

All intellectual property rights such as but not limited to patents, trademarks, copyrights or

trade secret rights related to the PRODUCT are property of the Vendor.

Developer End User shall not modify, translate, reverse engineer, decompile or disassemble

the PRODUCT or any portion of it or attempt to derive source code or create derivative

works. Developer End User are not allowed to remove, alter or destroy any proprietary,
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trademark or copyright markings or notices related to the PRODUCT. Developer End User

must not remove copyright headers, links and markings from any files included in the

PRODUCT. Developer End User must obtain permission by the Vendor if Developer End

User needs to incorporate the Software or any portions of it open source projects.

Non-Compete

THE DEVELOPER END USER MAY NOT USE THE PRODUCT TO CREATE ANY TOOL OR

PRODUCT THAT DIRECTLY OR INDIRECTLY COMPETES WITH THE PRODUCT.

WARRANTY

The Vendor represents and warrants that:

(i) The Vendor has all rights, authorizations or licenses to provide the PRODUCT to the

Developer End User;

(ii) The Vendor will use its best efforts to prevent the PRODUCT from being infected with

any "worms", "viruses", "Trojan horses" or other programs or programming devices that

might be used to modify, delete, damage, deactivate or disable the software, computer

hardware or data of the Developer End User;

LIMITATION ON AND EXCLUSION OF DAMAGES.

THE DEVELOPER END USER CAN RECOVER FROM THE VENDOR ONLY DIRECT DAMAGES

UP TO THE AMOUNT THE DEVELOPER END USER PAID FOR THE SOFTWARE. THE

DEVELOPER END USER CANNOT RECOVER ANY OTHER DAMAGES, INCLUDING

CONSEQUENTIAL, LOST PROFITS, SPECIAL, INDIRECT, INCIDENTAL OR ANY OTHER

DAMAGES.

This limitation applies to claims for breach of contract, breach of warranty, guarantee or

condition, strict liability, negligence, or other tort to the extent permitted by applicable

law. It also applies even if repair, replacement or a refund for the software does not fully

compensate the Developer End User for any losses; or the Vendor knew or should have

known about the possibility of the damages.

DISCLAIMER.

EXCEPT AS OTHERWISE DEFINED HEREIN, THE VENDOR EXPRESSLY DISCLAIMS ANY

WARRANTY FOR THE PRODUCT. THE PRODUCT AND ANY RELATED DOCUMENTATION IS

PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
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INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY,

FITNESS FOR A PARTICULAR PURPOSE, OR NONINFRINGEMENT. THE ENTIRE RISK ARISING

OUT OF USE OR PERFORMANCE OF THE PRODUCT REMAINS WITH THE DEVELOPER END

USER.

NO LIABILITIES.

To the maximum extent permitted by applicable law, in no event shall the Vendor be liable

for any special, incidental, indirect, or consequential damages whatsoever (including,

without limitation, damages for loss of business profits, business interruption, loss of

business information, or any other pecuniary loss) arising out of the use of or inability to

use the PRODUCT or the provision of or failure to provide Support Services, even if the

Vendor has been advised of the possibility of such damages.

Termination.

Without prejudice to any other rights or remedies, the Vendor will terminate this EULA

upon the failure of the Developer End User to comply with all the terms and conditions of

this EULA. In such events, the Developer End User must destroy all copies of the PRODUCT

and all of its component parts including any related documentation, and must immediately

remove ANY and ALL use of the technology contained in the PRODUCT from any

applications developed by the Developer End User, whether in native, altered or compiled

state.

GENERAL PROVISIONS.

This EULA may only be modified in writing signed by you and an authorized officer of the

Vendor. If any provision of this EULA is found void or unenforceable, the remainder will

remain valid and enforceable according to its terms. If any remedy provided is determined

to have failed for its essential purpose, all limitations of liability and exclusions of damages

set forth in the Limited Warranty shall remain in effect.

The Vendor reserves all rights not specifically granted in this EULA.

The Vendor reserves the right to make changes in this EULA at any moment by publishing

the appropriate alterations on http://www.perpetuumsoft.com 20 calendar days prior to

the moment these alternations take effect.
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ACKNOWLEDGMENT.

THE DEVELOPER END USER ACKNOWLEDGES THAT IT HAS READ AND UNDERSTANDS

THIS AGREEMENT AND AGREES TO BE BOUND BY ITS TERMS. THE DEVELOPER END USER

FURTHER AGREES THAT THIS AGREEMENT IS THE COMPLETE AND EXCLUSIVE

STATEMENT OF THE AGREEMENT BETWEEN THE DEVELOPER END USER AND THE

VENDOR, AND SUPERCEDES ANY PROPOSAL OR PRIOR AGREEMENT, ORAL OR WRITTEN,

AND ANY OTHER COMMUNICATIONS RELATING TO THE SUBJECT MATER OF THIS

AGREEMENT.

Last modified on September 07, 2012.

6.4 Programming

The following languages and tools were used in the development of RigPi.

Programming Languages

The following languages are used in RSS. They are all free tools with widespread support

on the Internet.

· CSS

· HTML5

· Bootstrap4

· PHP7

· JavaScript/jQuery

· AJAX

· MySQL/MariaDB

· TCP API for controlling RSS

· Python 3

Programming Tools

I used the following tools while developing RigPi. I have no relationship with the authors of

any of these applications.

FileZilla
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FileZilla is a free client program for ftp file transfers. It is available for most platforms

including Windows and Mac OS X/macOS.

Here is the link for further information about FileZilla:

FileZilla

phpMyAdmin

phpMyAdmin is used for editing, modifying, and backing up MySQL databases. It is

installed on RigPi. Access phpMyAdmin through a browser:

http://rigpi3.local/phpmyadmin

Username is root, password 7388. These must be changed if you open RigPi to the Internet.

Here is the link for further information about phpMyAdmin:

phpMyAdmin site

Coda

Available for the Mac and iOS mobile devices, Coda by Panic Inc. is a powerful text editor,

previewer and file manager. It is a commercial product, not free.

Here is the link for further information about Coda:

Coda site

Perfect Widgets

A tool to create dynamic HTML5 gauges. Designed for Windows. It is a commercial

product although there is a free personal/non-commercial version. 

Here is the link for further information about Perfect Widgets:

Perfect Widgets site

Help+Manual

https://filezilla-project.org/
https://www.phpmyadmin.net/
https://panic.com/coda/
http://perfectwidgets.com/Main
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Help+Manual is a commercial program to write and publish Help files using Windows.

Here is the link for further information about Help+Manual:

Help+Manual site

Safari with Developer extensions

Developer tools, especially the JavaScript console, are provided with Safari.

6.5 Raspberry Pi Settings

You may wish to change many Raspberry Pi settings such as screen resolution.  There are

two ways to proceed:

1. From the Raspberry Pi Desktop, click the Menu button (raspberry) at the top left.  Select

Preferences>Raspberry Pi Configuration or >Screen Appearance, or,

2. From Terminal, enter

 sudo raspi-config

6.6 Resetting RigPi

If you want to sell your RigPi in the future there are a few steps you should take to make it

easier for the new user.

The RigPi login credentials can be reset to the factory defaults by following these steps:

1. Start phpMyAdmin from the Raspberry Pi applications menu>Programming

2. Sign in with username root and password 7388.

3. Expand the station Table list by clicking the + mark.

4. Select the Users table.

5. Click Edit at the left end of the data line.

6. Enter the following to restore the Admin user account to default:

a. Access_level: 1

b. MyCall: ADMIN

c. Username: admin

d. Password: delete so field is blank

7. Scroll to the bottom and click Go.

8. Exit phpMyadmin

You should now be able to log in with username admin and no password.

Use the RigPi>SETTINGS>Users window to remove all but the ADMIN account.

https://www.helpandmanual.com/index.html
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In RigPi>SETTINGS>Advanced Radio change the radio to Hamlib Dummy and set all the

fields to "default."

6.7 Rigpi.local on Windows computers

The domain rigpi3.local can be used as an easy way to connect to RigPi using a browser on

another computer.  Many operating systems automatically support the use of .local

addresses with the exception of Windows.  Bonjour may already be installed on your

Windows computer, especially if you have installed Apple iTunes in the past.

Apple Bonjour, one popular way to add .local support to Windows is available as a free

download from Apple.  Search for Bonjour for Windows and you will find the site providing

the download.  Except for Microsoft Edge, most browsers will open RigPi using rigpi3.local

once Bonjour has been installed.

If you are using Microsoft Edge, a program called Fiddle can be run at the same time as

Edge so the .local addresses will work.  Here is a link to the Fiddler download site:

Fiddler

To start Fiddler, use the Search function in Taskbar to find fiddler.  Then right-click and

select Run as Administrator.  Once Fiddler is running, navigate to rigpi3.local in Edge.

6.8 RigPi Audio Update

Early versions of RigPi used a settings file named audioinjector-wm8731-audio for the

RigPi Audio board.  If you don't have a RigPi Audio board installed in your RigPi, it is not

necessary to proceed with the recommended changes.

If you have one of the early RigPi servers, follow the steps below to update.  Right-click

Speaker icon on the Raspberry Pi Speaker icon.  If the drop down list includes

"audioinjector," it is strongly recommended you proceed with this change. If the list already

includes snd_rpi_proto, please confirm the audio settings steps below for Audio Device

Settings.  Even if you are using your radio's CODECs to provide input and output audio, it is

best to make these change for the RigPi Audio board.

This topic also includes information on how to change audio levels and switches in

Raspberry Pi settings for the new overlay. 

This update changes a file called a “device tree overlay” to a new one that is better suited

for the RigPi Audio board.  The new overlay provides significant improvements for the

decoding of FT8 signals in WSJT-X and Mumble audio quality for weak signals.

https://www.telerik.com/fiddler
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Because this change requires elevated file access permissions it will be done manually.  A

file will be edited from the Raspberry Pi Desktop.

Open the Raspberry Pi Desktop by:

1. Attaching an HDMI Monitor (micro HDMI for Raspberry Pi 4B), USB mouse and USB

keyboard to RigPi, or….

2. Using VNC Viewer from another computer to open the Raspberry Pi Desktop in a

virtual window.

Start Terminal by single-clicking the black icon in the Desktop toolbar. Enter the following

commands:

cd / boot <Ent er >
sudo nano conf i g. t xt <Ent er >

Scroll to the end of the config.txt file using the down arrow key.

Replace the second to last line (containing audioinjector-wm8731-audio) with this:  
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dt over l ay=r pi - pr ot o 

Save and exit

Ct r l +o<Ent er >
Ct r l +x<Ent er >

Reboot using

sudo r eboot  now<Ent er >

to have the change recognized.

After rebooting, Right-click on the Speaker icon at the top right-hand end of the Desktop

and select snd_rpi_proto for the following steps.

We will now use the Raspberry Pi Audio Device Settings to set levels and input/output

connections.

Click the Raspberry Applications Menu icon in the top left corner of the Raspberry Pi

Desktop, then select Preferences>Audio Device Settings.
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· Confirm that Card: snd_rpi_proto (Alsa mixer) is the selected card.

· Use these settings for using the Mic or Line Input and Line Output.  If the audio levels are

too low, use the Mic settings in the Options tab.

Audio Device Settings, Selections:

Click the Select Controls... button at the bottom. Put checks in the following options:

1. Master

2. Line In

3. Microphone

4. Mic Boost

5. Capture

6. Input MUX

7. Output Mixer HiFi

Audio Device Settings, Levels and options:

Control Value Notes

Playback

Master 2/3 maximum change to suit

Mic Boost Maximum change to suit

Capture

Capture 2/3 maximum change to suit

Switches

Line-in checked

Microphone Checked

Output Mixer HiFi Checked

Options

Input Mux Line In Select Mic for low level audio input
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Finally, click the Make Default button at the bottom and close the Audio Devices Settings.

After testing with your transceiver you may find it necessary to change some of the Audio

Device Settings window options and levels.

Other settings

Any program that uses audio from RigPi Audio, a radio CODEC, or an external USB sound

card should be set to [default] for input and output devices except for Mumble.  The

default is set by using the Speaker right-click menu.

If you wish to use a digital mode program (Fldigi, JT8Call, WSJT-X) use [default] for all

audio input and output devices.

In Mumble client, use [sysdefault:CARD=sndrpiproto] snd_rpi_proto, Default Audio Device

if using the RigPi Audio board.  If using a radio CODEC, use [default].

6.9 RigPi Keyer PTT

The WinKeyer IC used for CW keying has an independent PTT capability that can control

the PTT output from RigPi Keyer. This special Keyer PTT operates in parallel with the

normal RigPi PTT.  To use RigPi Keyer PTT, the Keyer must be assigned to the account for

which you want to use it.

RigPi PTT, configured in Radio settings, controls the PTT jacks on both boards, RigPi Keyer

and RigPi Audio.  Keyer PTT also controls the PTT line on RigPi Keyer, no matter whether

RigPi PTT is on or not.  Keyer PTT can be used to control an external device, such as a

remote power switch or an antenna bypass switch.

Keyer PTT is controlled by custom macros. Two macros are pre-programmed in the RigPi

Macro bank to accomplish this: SWITCH ON ($<18><01>) and SWITCH OFF ($<18><00>).

 In SETTINGS>Keyer, remove the check from Enable Keyer PTT to switch to independent

control using Macros.
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RigPi PTT Macro Switch Audio PTT Out Keyer PTT Out

On On On On

On Off On On (Off with

jumper 201

removed)

Off On Off On

Off Off Off Off

RigPi PTT (Radio Settings) has 3 options: None, ON when transmitting, and ON when radio

connected.  This third option overrides Key PTT since it is on whenever the radio is

connected.  Keyer PTT and Audio PTT are both on continuously.  If RigPi PTT is set to None,

Audio PTT never turns On, and Keyer PTT is controlled by the Macros. By removing jumper

201 on the RigPi Keyer board, RigPi PTT has no control over the Keyer PTT.

The Keyer PTT can be used to control an external power switch.  Candidate power switches

include:

MFJ-1172

Digital Loggers IoT Control Relay
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6.10 RigPi Remote Keyer

The RigPi Remote Keyer feature allows you to operate CW from a remote location using a

paddle, bug or straight key.   A RigPi containing a modified Keyer board is required at the

Radio end.  One of several keying options can be used at the remote end:

At radio end:

1. Radio RigPi 1 or 2

A. RigPi 3 software

B. Raspberry Pi 3B+ or 4B

C. Audio Board (for VoIP) and CW Board

At remote key end (3 options):

1. RigPi  0

A. RigPi 0 software

B. Any Raspberry Pi

C. Key GPIO pin with straight or electronic key, or use RigPi Keyer board.

D. Requires RigPi browser on mobile device plus VoIP Mumble client.

Or
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2. RigPi 1 or 2 (same as radio end)

Or

3. RigPi Hub Windows program

A. RigPi Hub 1.05 or later

B. Control radio RigPi with your favorite logging program

C. Send CW with most logging programs, straight key, mouse button or electronic

key.

D. Requires Mumble client for VoIP.

Both RigPi Keyer boards must have two added jumpers (see schematic below). 

RigPi Keyer can serve one of three functions as determined by Keyer settings:

Normal Key your radio from any

browser using macros or the

Keyer window.

Radio Keyer Key your radio from a

remote paddle, bug or

straight key.  The Radio

Keyer is controlled by the

Remote Keyer.

Set the port used for Keyer

data, normally 30040.  Set

Paddle Md (Paddle Mode)

to Vibrobug.

Remote Keyer Connect your paddle, but or

straight key to the Remote

Keyer RigPi when away from

home.  The Remote Keyer

controls the Radio Keyer.

Set the port used for Keyer

data, as above. Set the IP

address for the Radio Keyer

RigPi.  Use the LAN IP (when

at home) or the WAN IP

(when away).  When away

you must also set up port

forwarding on your home

router for the Keyer data. If

using a bug or straight key,

connect the key using the tip

and sleeve of the PADDLE

connector.

Select the Keyer function in the SETTINGS>CW Keyer window.

Getting Started with Two RigPi's
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Confirm that the RigPi Keyer is working correctly in each RigPi using the Normal Keyer

function.

Radio Keyer

§ Start the Radio RigPi in any browser.

§ In Settings>Advanced Radio enter the settings for your radio.  

§ Select RigPi Keyer in the Key list. 

§ In Settings>Keyer, set the Keyer Fn to Normal and put a check in the Enable Sidetone

check box.

§ Connect a cable from the RigPi KEY connector to the CW keying jack on your radio.  

§ Click Test Keyer.  You will hear two Morse V characters indicating the Keyer is

functioning correctly.

§ Click Connect Radio on the Tuner window. The frequency shown should be the same

as shown on the radio.

§ Connect a Keyer paddle to the PADDLE connector, open the Keyer window and send

a few characters.  If you wish to use a Bug or straight key, connect it between tip and

sleeve on the connector and set the Paddle Md to Vibrobug.

§ The Radio Keyer is now set for the Normal mode.

Remote Keyer

§ RigPi is running using rigpi3.local on the Radio and Remote RigPi's.  This will cause a

conflict when both are connected to the same LAN. To resolve this conflict, open the

Raspberry Pi desktop.  Go to Menu>Preferences>Raspberry Pi Configuration.  Enter

rigpi3.local in the Hostname, click OK, and give permission to reboot.  From now on

you can access the Remote RigPi by using rigpi3.local.

§ Start the Remote RigPi in any browser.

§ In Settings>Advanced Radio select the Hamlib>Dummy radio.  

§ Select RigPi Keyer in the Key list.

§ In Settings>Keyer, set the Keyer Fn to Normal and put a check in the Enable Sidetone

check box.  

§ Click Test Keyer.  You will hear two Morse V characters indicating the Keyer is

functioning correctly. 

§ Click Connect Radio in the Tuner window. The frequency shown should be 145.000

MHz.   

§ Connect a Keyer paddle to the PADDLE connector, open the Keyer window and send

a few characters.  If you wish to use a Bug or straight key, connect it between tip and

sleeve on the connector and set the Paddle Md to Vibrobug.

Setting up Remote Keying with Two RigPi's
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Once both keyers are working using the Normal function, we will set up the remote keyer

connection through your local network.  A dedicated port is used for the CW data.  The

default port is 30040.

Radio Keyer

§ In Settings>Keyer select Radio Keyer in the Keyer Fn list.

§ Enter a port in the Port box (30040 is recommended, must be the same as used in

Remote Keyer).

§ Click Test Keyer to register the new settings.

§ In Tuner, click Disconnect Radio and Connect Radio to start the Radio Keyer function

with the new settings.

Remote Keyer

§ In Settings>Keyer select Remote Keyer in the Keyer Fn list.

§ Enter a port in the Port box (30040 is recommended).

§ Enter the Radio RigPi LAN IP in the IP box.

§ Click Test Keyer to register the new settings.

§ In Tuner, click Disconnect Radio and Connect Radio to start the Remote Keyer

function with the new settings.

You are all set for Remote CW.  Tune your radio to the CW portion of a band and turn on

VOX.  With the Keyer window open on the Remote Keyer RigPi, try sending some

characters.  You will hear the sidetone on both keyers and your radio should transmit.

Note the following:

§ If running Remote and Radio RigPi near each other, turn off the Radio Sidetone to

hear the Remote RigPi Sidetone more easily.

§ Keying speed at the Radio RigPi is determined by the speed on the Remote RigPi.

§ When using Remote RigPi away from home you must set up UDP port forwarding for

the port you have assigned.

§ When using Remote RigPi away from home you must use the WAN IP instead of the

Radio RigPi LAN IP.

§ To control your radio, open any browser at the remote location and connect to

rigpi4.local.

RigPi Keyer Board Modifications

Two jumpers must be added to the RigPi Keyer board to allow remote keying, see below.

Later production
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Remote Keying without a Second RigPi Keyer Board

Using only a Raspberry Pi board you can use an electronic or straight key for CW from a

remote location.  Connect the keyer from physical GPIO pin 19 to ground.  In RigPi

SETTINGS>CW Keyer Settings put a check in Inverted Keying.  It is best  to use an electronic

keyer, such as the Winkeyer by K1El, since the Raspberry Pi does not have a built in

sidetone.  The settings for Remote Keyer, above, apply.

Remote Keying from a Windows Computer

Remote CW can be keyed from most Windows logging programs through a RTS or DTR

keying input to RigPi Hub.  RigPi Hub 2.0.1 is a Windows Virtual Port program that can

control RigPi from up to 4 Windows programs.  It is available for free from the RigPi web

site:  https://rigpi.net

Morse Keyer is a Windows programs that can connect to RigPi Hub.  Using Morse Keyer

you can send CW through RigPi Hub on the remote radio using a straight key, paddle, bug

or even mouse buttons.  A sidetone is provided.  Select a free port in RigPi Hub, open it,

then connect Morse Keyer to that port.

You can use a decommissioned mouse to connect to a physical key.  It is possible to

connect two mice to a computer although they control the same mouse pointer.  The

downside to this approach is that you must move the mouse pointer over the "keypad" on

https://rigpi.net
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the Morse Keyer window to send through using a key through the recommissioned mouse. 

Select a free port in RigPi Hub, open it, then connect Morse Keyer to that port.

Using two USB-to-serial adapter cables you can key Morse Keyer through a USB port and

key RigPi Hub.  See the Morse Keyer web Help page for details on connecting your key to

Morse Keyer using a USB/serial connection.

https://morsepower.blogspot.com/2016/08/cwcom-getting-started-

connecting.html

RigPi Hub can use a physical serial port in addition to virtual ports.  Jumper the keying

output from Morse Keyer (pin 4 on a DB-9 connector) to the CTS input on the second

cable.  See RigPi Hub Help for details.

Using remote CW with RigPi Hub

RigPi Hub 2 can be used with RigPi to send CW from a Windows program through a virtual

port.  Two ways to send CW are provided with RigPi Hub: element based (start and end

times for each element are sent); character based (ASCII characters are sent to RigPi where

they are converted to CW).  

Element based keying

Element based keying requires a second port for keying purposes.  The default port for

element based keying in 30040.  You must use a RigPi CW board at the radio end, set up

for Radio Keyer in SETTINGS->CW Keyer->Keyer Fn.  Open port 30040 for UDP in your

router when operating away from home.

Configure your program to use DTR for keying CW.  Assign a RigPi Hub virtual port to the

CW keying function of the external program.

The following programs have been tested using element based CW:

CommCat

Ham Radio Deluxe/Digital Master

N1MM

DXLog

Morse Keyer

RigPi Hub can connect to a physical port for keying from an external device such as an

electronic keyer, straight key or bug.  Select the serial port you want to use in the CW group

and click Connect.

https://morsepower.blogspot.com/2016/08/cwcom-getting-started-connecting.html
https://morsepower.blogspot.com/2016/08/cwcom-getting-started-connecting.html
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You can use a USB-to-serial adapter to gain access to the RTS, DTR or CTS control lines. 

Here is an adapter I have tested. It works well by grounding the CTS line through the

external key.

https://www.amazon.com/gp/product/B07TXVRQ7V/ref=ppx_yo_dt_b_asin_title_o0

1_s00?ie=UTF8&psc=1

Character based keying

Character based keying does not require a separate port, it uses the standard RigPi Hub

port 30001.

Send CW from one of several popular logging programs.  The program must support

Winkeyer-compatible keying.  Set up a RigPi virtual port for this purpose at 1200 Baud. 

Connect to this port from the Winkeyer interface in the program you are using.

The following programs have been tested using character based CW:

CommCat

Ham Radio Deluxe/Digital Master

N1MM

WK3 Demo by K1EL

Ham Radio Deluxe (character mode)

Confirm that CW is working in RigPi.  No special RigPi settings are required to use character

mode remote CW.  

Start RigPi Hub and set up one virtual port for radio control at 38400 Baud and a second

virtual port for CW at 1200 Baud.  

Start Ham Radio Deluxe using a Kenwood TS-2000 radio selection. Start DM780.

https://www.amazon.com/gp/product/B07TXVRQ7V/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1
https://www.amazon.com/gp/product/B07TXVRQ7V/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1
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In DM780 Modes, select CW (WinKey). 

In Winkey->Keyer settings, select the port you configured for 1200 Baud.  Click Connect.

In DM780->Winkeyer->Speeds, remove the check in Track Changes if there. 

In DM780->Winkeyer->Keyer, click Test.  The RigPi Keyer should send TEST DE DM.  Close

Winkeyer settings.

Use the CW functions in DM780 as you normally would.  There is no sidetone when

operating in this way.  You can turn on your radio's sidetone and hear it through Mumble.

The RigPi CW indicator in the lower right hand corner of the RigPi Hub window shows

when CW is being sent. 

N1MM (character mode)

Confirm that CW is working in RigPi.  No special RigPi settings are required to use character

mode remote CW.  

Start RigPi Hub and set up one virtual port for radio control at 38400 Baud and a second

virtual port for CW at 1200 Baud.  

Start N1MM using a Kenwood TS-2000 radio selection.

In Config->Configure Ports, set up a separate port for WinKeyer.  Put a check in the WinKey

box.

In Config->Winkey, select Ignore Winkey Speed Pot.

In Winkey->Keyer settings, select the port you configured for 1200 Baud.  Click Connect..

Use the CW functions in N1MM as you normally would.  There is no sidetone when

operating in this way.  You can turn on your radio's sidetone and hear it through Mumble.

The RigPi CW indicator in the lower right hand corner of the RigPi Hub window shows

when CW is being sent. 

K1EL WK3 Demo (character mode)

Confirm that CW is working in RigPi.  No special RigPi settings are required to use character

mode remote CW.  

Start RigPi Hub and set up a virtual port for CW at 1200 Baud.  
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Start WK3 Demo..

In Setup->Com Port Settings, select the virtual port you set up for 1200 Baud.  Click Done.

Click the Open button to initialize the keyer.

Use the CW functions in WK3 Demo as you normally would.  There is no sidetone when

operating in this way.  You can turn on your radio's sidetone and hear it through Mumble.

The RigPi CW indicator in the lower right hand corner of the RigPi Hub window shows

when CW is being sent. 

CommCat (character mode)

(Note: CommCat has been discontinued.)

Confirm that CW is working in RigPi.  No special RigPi settings are required to use character

mode remote CW.  

Start RigPi Hub and set up one virtual port for radio control at 38400 Baud and a second

virtual port for CW at 1200 Baud.  

Start CommCat using a Kenwood TS-2000 radio selection.

In File->Settings->Radio/Ant->CW, select Winkeyer and the port you set up for 1200 Baud.

Use the CW functions in CommCat as you normally would.  There is no sidetone when

operating in this way.  You can turn on your radio's sidetone and hear it through Mumble.

The RigPi CW indicator in the lower right hand corner of the RigPi Hub window shows

when CW is being sent. 

6.11 Schematics

Schematics for the RigPi Audio and RigPi Keyer boards can be downloaded through the

following link:

RigPi Schematics

https://rigpi.net/downloads/RigPi_Schematics.pdf
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RigPi Audio Circuit Description

The RigPi Audio board is based on the Cirrus Logic WM8731 (U1) low power stereo codec.

 It supports a stereo input and mono output.  The left input and output channels are

transformer isolated for hum reduction.  Both stereo input channels are available for I/Q

signal processing.  This input path is not transformer isolated.

The WM8731 is controlled through the Raspberry Pi GPIO connector.

GPIO 1 (Pin  12) BCLK: Digital Audio Bit Clock, Pull Down,

GPIO 19 (Pin 35) LRC: DAC Sample Rate Left/Right Clock

GPIO 20 (Pin 38) ADCDAT: Digital data out

GPIO  21 (Pin 40) DACDAT: Digital data in

SDA (Pin 3) SDIN: 3-Wire MPU Data Input / 2-Wire MPU Data Input

SCL (pin 5) SCLK: 3-Wire MPU Clock Input / 2-Wire MPU Clock Input

The WM8731 can convert input data with up to a 96kb sample rate.

Additional GPIO pins used for RigPi Audio:

GPIO 17 (Pin 11): PTT

GPIO 27 (Pin 13) DS: Clock for KX3 Power On voltage doubler

GPIO 22 (Pin 15): KPTT: Toggle for KX3 Power On

Connectors:

J1: Raspberry Pi GPIO connector

J2: 3.5 mm jack for I/Q  input (stereo, unisolated)

J3: 3.5 mm jack for left channel audio input (tip, transformer isolated)

J4: 3.5 mm jack for audio (tip), PTT (ring), and KX3 (ring) power on signal

J5: Connector to route audio to the RigPi jumper board

 

Jumpers:

JP1: KX3/PTT (1-2 for KX3 Power On pulse, 2-3 for normal PTT)

JP2: Audio In selection (1-2 for stereo -no transformer isolation-, 2-3 for left mono -

transformer isolated- input)

Elecraft KX3 Power on circuit
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Transistor Q1 inverts and buffers a clock from the GPIO connector to feed a voltage

doubler diode pair, D3.   Q2 turns on emitter follower, Q3, to supply a short 7-volt pulse to

turn on a KX3 through the ring connector on the KX3 microphone input. 

RigPi Keyer Circuit Description

The K1EL WinKeyer3 CW Keyer IC provides all of the programming for its many features. 

The keyer is controlled through the internal serial port on the Raspberry Pi, ttyS0.

RXD (Pin 8): Receive data (from keyer)

TXD (Pin 10): Transmit data (to keyer)

Connectors:

J201: Raspberry Pi GPIO connector

J202: 3.5 mm jack, PTT out (tip is PTT, ring is 5V pull-up)

J203: 3.5 mm jack, Paddle input (tip is DOT, ring is DASH)

J204: 3.5 mm keying output (tip keys, ring not used)

J205: speaker connection

J206: PB-NET (allows external switches to play back internal memory, not used)

J207: Programming connector, not used

Jumpers:

JP201: PTT enable (1-2 enables GPIO PTT, otherwise, GPIO PTT not used)

GPIO pins used for RigPi Keyer:

GPIO 9 (Pin 21): Data to radio keyer (only used at remote end)

GPIO 10 (Pin 19): Data from remote keyer (only used at radio end)

GPIO 17 (Pin 11): PTT

RXD (Pin 8): Receive data from keyer chip

TXD: (Pin 10): Transmit data to keyer chip

6.12 Sharing Radios, Rotors and Keyers

Radio

RSS allows multiple radios to be connected and controlled. Each radio is connected

through a unique USB port. One rig is assigned to each account. Another account can share

the same radio, but the connection is slightly different.
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There are two ways to share a radio in use on another account.

1. Open a new browser window and sign in using the other account's username and

password. The keyer and rotor assigned to the main account are always available in

newly opened browsers connected to the same account.

2. Instead of a physical radio and USB port (ttyUSBn) in Settings>Radio>Basic or

Advanced for the second account, select Hamlib, NET rigctl, as the manufacturer and

radio. In Port, enter the port number for the main account's Radio number you want to

use. Port numbers start with 4532 for Radio 1, and go up 2 for each Radio number.

Radio 2 will be 4534, etc. So if account 3 wants to use the radio already connected for

account 2, enter 4534 as the port number. You can also see the rigctl port to use in

SETTINGS>System>Rigctl Port.

Use option 2 if you wish to use Hamlib in another program, and have RSS connected to the

same radio. Fldigi and WSJT-X, provided with RSS, can be the primary rig control program.

Once Fldigi/WSJT-X are running and in control of the radio, connect RSS to Hamlib Net

rigctl with the same port, usually 4532, used by the other program.

You can do it the other way around. RSS can be the controlling program, set up Fldigi or

WSJT-X so they follow RSS by using Hamlib Net rigctl in the other program with the port

number as above.

Rotors

Each account has a unique rotor. If you have more than one rotor but only one radio, you

can set up a second account using Option 2, above, and assign the second rotor to that

account. Rotors use a port one above the radio port. If the radio port is 4532, the rotor port

is 4533.

Keyers

RSS supports the internal RigPi Keyer, keying through radio CAT commands, and external

K1EL WinKeyers.

Only one account can use RigPi Keyer. If you log into that account with a second or third

browser (option 1, above), the assigned keyer will do fine. If you have an account for a

second or third radio, use CW keying via CAT, or use an external WinKeyer connected

through a USB port.
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CAT CW Keying does not echo characters back to RSS so the Transmitted CW box in the

Keyer window will remain blank. Not all prosign CW characters are accepted by CAT

Keying.

6.13 Supported Radio Features

Hamlib supports over 200 radios. Not all controllable features are supported. Custom

macros can be created using Hamlib commands, but only if that particular feature is

supported. You can also use the special "w" Hamlib command in a macro to send native

commands directly to a radio, but even this approach may not be supported for a

particular command.



181

RigPi Station Server Version 3 
 
                                                                                                                                                                                                                          © 2021 Howard Nurse, W6HN

Technical

Go to RigPi SETTINGS>Radio>Advanced and use the Radio Capabilities button to show a

list of all features for the selected radio supported by Hamlib.
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The Hamlib library is in a constant state of improvement and enhancement. New radios are

frequently added. Here is a link to the Hamlib forum where these developments are

discussed:

Hamlib Forum

6.14 System

Swap Space

Usually the Linux Swap Space is not used in RSS. Many programs requiring compiling (such

as Fldigi) require at least a 512 MB swap space. Providing swap space when not necessary

can reduce the life of an SD card. See this link for further details on managing Swap Space:

Swap info

Backing up and Upgrading the RigPi Memory Card

The Micro SD memory card for the Raspberry Pi has a limited lifetime.  Write cycles are

usually more critical in determining the life of an memory card because the space to be

taken by a write must be cleared first. 'Wear leveling' is used to distribute write cycles so

one portion of the memory space is not used constantly. It is suggested that you use a

memory card having at least two times the space needed to leave room for wear leveling.  

To provide insurance against corrupting a memory card, it is wise to back it up to a second

card, a USB memory stick, or as an image to a fixed drive. The simplest way to back up the

SD Card is by using the SD Card Copier program available through the Accessories menu

on the RSS Desktop.

The SD Card can be backed up to a USB memory stick or to another SD Card.  The latter

requires a spare card and SD Card USB adapter. Plug the USB stick or adapter into a spare

USB connector on RSS.

Select the Raspberry icon to open the Applications Menu.  Select Accessories, then SD Card

Copier.  Follow the instructions given in SD Card Copier Help.

Minimum microSD Card specifications:

Type: Micro SD

Size: 16GB (or larger)

Class: 10

Speed: 80MB/s or faster

https://sourceforge.net/p/hamlib/mailman/hamlib-developer/
http://www.kalitut.com/2017/11/raspberry-pi-swapping.html
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RigPi makes intensive use of the memory card.  Cards designed for video applications are

able to handle large amount of data with continuous recording.  Manufacturers claim up

43,800 hours (5 years) endurance.  The Samsung PRO Endurance 32 GB card is

recommended as an upgrade for RigPi.

Optimal microSD Card specifications:

Type: microSDXC

Size: 32 GB (or larger)

Class: --

Speed: 100/30 MB/s

Providing more space on the Memory Card

Here are some suggestions for increasing the free space on your memory card.

§ Remove all unnecessary programs.  You probably aren't using all the programs on

your RigPi.  For example, removing Wolfram and Open Office can clear over a GB of

memory space.

To remove a package, open Terminal and use the following command:

sudo apt-get purge -y <packagename>

Here is a list of removal candidates:

sudo apt-get purge -y wolfram-
engine

680 MB

sudo apt-get purge -y libraoffice 245 MB

sudo apt-get purge -y oracle-java 160 MB

sudo apt-get purge -y scratch 140 MB

sudo apt-get purge -y scratch 91 MB

§ Make sure all of your memory card is being used.  This is especially important if you

are moving to a larger memory card.

1. Open Terminal from the Raspberry Pi desktop

2. sudo raspi-config
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3. Select the Advanced option

4. Expand memory space

§ Transfer RigPi to a larger microSD card.  See the previous section, Backing Up and

Upgrading the RigPi Memory Card.  Be sure to expand the memory space as

described above.

§ Logs are rotated and deleted by the logrotate utility.  Logrotate is configured in the

file /etc/logrotate.conf.

Updating the Raspbian Operating System

Updates to the Raspbian operating system occur often.  To keep current, RigPi has an

automatic update feature that updates your system in the background once per week.  You

can also update manually using these commands in Terminal:

Update system package list:  sudo apt-get update

Upgrade software: sudo apt-get dist-upgrade

6.15 Troubleshooting

Radio won't connect

When you try to connect a radio by using the Connect Radio button and the connection

fails, take a close look at the error message to get clues. The normal failure is "Connection

Refused" with a suggestion to check settings.

First verify that the radio is on and the USB cable associated with that radio is plugged in

to RSS. Check the Port option in SETTINGS>Radio to make sure the radio com port is in the

drop-down list.

Try rebooting RSS from SETTINGS>System>Reboot RigPi to see if that fixes it.

The Connect Radio and Disconnect Radio buttons on the Tuner window require the radio

to be set up in SETTINGS>Radio first. If it hasn't been set up, RSS won't be able to connect.

(RigPi is initially configured with a "dummy" radio simulation so you can use Connect

Radio with no further settings required.)

If you have more than one USB device connected to RSS (several radios, rotor controls or

an external WinKeyer), the port assigned to each cable can change when you reboot. What

was /dev/ttyUSB0 connected to radio A may now be connected to radio B, and radio A
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is /dev/ttyUSB1. In SETTINGS>Radio>Port you can select another port to see if the radio

will connect.

RSS has a utility program that will prevent port changes from happening in the future. See

the Help topic Other Programs>USB ID  for more information on USB ID.

Next try starting the rig connection manually. This requires the use of the Raspberry Pi

Desktop Terminal. The manual connection uses the Hamlib model number for your radio.

In SETTINGS>Advanced Radio click the Radio Capabilities button. 

At the top you will see 'Caps dump for model: xxx,' where xxx is the model number. Make

note of this number.

To clear any radio control remnants, reboot RSS from the System Settings window.

Open Terminal by double-clicking the black prompt icon in the Raspberry Pi Task Bar and

type the following (373 happens to be the model number for the Icom IC-7300):

rigctl -m 373 -r /dev/ttyUSB0

145
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This command assumes you have made no changes to the default settings in the radio.  If

you have changed Baud rate to 115,200, use this command:

rigctl -m 373 -r /dev/ttyUSB0 -s 115200

The resultant report should give more clues, which might simply be "Timed out." More

diagnostic information can be obtained by using the "v" parameter such as below:

rigctl -m 214 -r /dev/ttyUSB0 -vvvvv

 If nothing is learned, we need to check that the port is correct. Get a list of available ports

by typing (lower-case L):

ls /dev/ttyU*

If more than one USB port is listed, try the rigctl commands with the other ports.

Once you are able to get rigctl started, a prompt "Rig command:" is shown. Type f

followed by Enter and see if the reported frequency is correct. Type Ctrl+C to exit and stop

the rigctl process.

If you are able to connect to and control the radio, we can start the RigPi using a special

test mode. Starting the test requires that a file in RigPi be edited with a text editor. This can

be done from RSS Terminal using the Nano text editor with these commands:

cd /var/www/html

sudo nano RigDo.php

Near the top you will see a line that reads "$tUser=$argv[1];" which we need to modify. Use

the cursor arrow keys to move the insertion point to the front of $argv, then enter the

characters 1;//.

Slightly further down, after "}else{," you need to change the variable $tUsername='admin';

so that is shows your username.

Type Ctrl+O to save the file and Ctrl+X to exit Nano.

Start hamlibDo by typing this line:

php hamlibDo.php

See if there are any error reported. If there don't appear to be any errors, open a RigPi

browser and see if you can control the radio.
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The report shown in Terminal includes the command to start rigctld. Try entering the

complete line in Terminal and press Enter. See if there are any error reported.

If none of these steps gets the radio connected, it is time to check the USB cable and radio

for problems. This can be done running a control program on another computer by moving

the USB cable to that computer.

For a helpful guide providing additional information, here is a link to the Hamlib FAQ:

Hamlib FAQ

Radio Control Logging

The Test Radio function in Advanced Radio settings also starts a log for recording radio

status and commands.  You will find this log in /var/log/rigpi_radio.log.  It is cleared each

time you use the Test Radio function so only the most recent session is kept.   You can use

the edit program nano from the Raspberry Pi terminal to view the log.

sudo nano /var/log/rigpi-radio.log

Rotor Control Logging

The Test Radio function in Advanced Radio settings also starts a log for recording rotor

status and commands.  You will find this log in /var/log/rigpi_rotor.log.  It is cleared each

time you use the Test Radio function so only the most recent session is kept.   You can use

the edit program nano from the Raspberry Pi terminal to view the log.

sudo nano /var/log/rigpi-rotor.log

User Access Logging

A log of all users accessing RigPi can be found here:

sudo nano /var/log/rigpi-access.log

No RigPi Audio

RigPi uses the RigPi Audio board for VoIP, digital modes, or even for a spectrum analyzer

(panadapter). If RigPi Audio doesn't appear to be working, there are a number of tests we

can use to isolate the problem.

https://github.com/Hamlib/Hamlib/wiki/FAQ
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RigPi Audio can receive/send audio through the RJ-45 connector on the USB end of the

RigPi unit or from the 3.5 mm jack end. We will use the 3.5 mm jack end. If using the RJ-45

connection, remove that cable for now.

RigPi Audio uses a Linux device driver named snd_rpi_proto. All drivers and settings

required for RigPi Audio are initially set and do not require changes.

Right-click the Speaker icon at the top of RSS Desktop to make sure snd_rpi_proto is shown

as the selected device. If it isn't in the list, try rebooting RSS from the RigPi

SETTINGS>System menu. If it fails to appear, the RigPi Audio board may have a problem.

To look for errors on booting, open RSS Terminal and type the following:

dmesg | grep audio

You will see a list of possible errors. The last line should say 

[  4.xxxxx] snd-rpi-proto soc:sound: wm8731-hifi <-> 3f203000.i2s mapping ok

which says the board is connected. If not, the RigPi Audio board probably needs repair.

Next we will try some audio tests using Linux programs through RSS Terminal.

Plug in a high impedance set of ear buds to the TX OUT connector. Type the following

command (c2 says 2 channels):

speaker-test -c2

You should hear pink noise in the left ear bud, then silence, followed by pink noise.

Here is a tone test:

speaker-test -t sine -f 2000 -c2

You will hear a 2000 Hz tone in the left ear bud.

Finally, a voice test:

speaker-test -t wave -c2

You will hear a woman's voice in the left ear bud.
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If any of these test fail, we can use the Linux program named Alsamixer from RSS Terminal

to check the settings. Type

alsamixer

The following settings are used for RigPi Audio:

Master Gain 86<>86 (adjust to

suit)

Master Playback OFF (MM)

Sidetone 0

Mic Boost 0

Playback Deemphasis OFF (MM)

ADC High Pass Filter ON (OO)

Input Mux Line In

Output Mixer HiFi ON (OO)
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Line L R Capture

Mic Boost 0

Capture 18<>18 (adjust to

suit)

Can't connect to Mumble server

Mumble server starts automatically when RigPi boots. First we can make sure Mumble

server is actually running, then we'll check the Mumble log.

To confirm the Mumble is running:

In Terminal, type: 

ps -ef | grep mumble-server

The command should show:

mumble-+  582   1 0 12:22 ?    00:00:00 /usr/sbin/murmurd -ini /etc/mumble-

server.ini

The results confirm that the murmur (mumble server) daemon is running, using the

mumble-server.ini initialization file.
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To make sure we can connect to the default Mumble port, type: 

nc -vz rigpi3.local 64738

You should see this response:

Connection to rigp2i.local 64738 port [tcp/*] succeeded!

If these tests are successful, we can check the Mumble server log. Type:

sudo cat /var/log/mumble-server/mumble-server.log

Here is the response:

...

<W>2019-01-23 12:22:25.792 Initializing settings from /etc/mumble-server.ini

(basepath /etc)

<W>2019-01-23 12:22:25.815 Meta: TLS cipher preference is "ECDHE-ECDSA-AES256-

GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES128-GCM-

SHA256:ECDHE-RSA-AES128-GCM-SHA256:AES256-SHA:AES128-SHA"

<W>2019-01-23 12:22:25.815 OpenSSL: OpenSSL 1.1.0j 20 Nov 2018

<C>2019-01-23 12:22:25.850 Successfully switched to uid 116

<W>2019-01-23 12:22:28.784 ServerDB: Opened SQLite database /var/lib/mumble-

server/mumble-server.sqlite

<W>2019-01-23 12:22:28.814 Resource limits were 0 0

<W>2019-01-23 12:22:28.814 Successfully dropped capabilities

<W>2019-01-23 12:22:33.835 OSInfo: Failed to execute lsb_release

<W>2019-01-23 12:22:37.123 Murmur 1.2.18 (1.2.18-1) running on X11: Linux 4.14.79-v7+:

Booting servers

<W>2019-01-23 12:22:45.343 1 => Server listening on [::]:64738

<W>2019-01-23 12:23:32.814 1 => Announcing server via bonjour

<W>2019-01-23 12:23:33.002 1 => Registration needs nonempty 'registername',

'registerpassword' and 'registerurl', must have an empty 'password' and allowed pings.

<W>2019-01-23 12:23:33.003 Object::connect: No such slot

MurmurDBus::userTextMessage(const User *, const TextMessage &)

If connection attempts have been made they are included at the end of the log. Check

these line for an indication of why the connection was not made.

Mumble gives access to more settings through an account named SuperUser. Try logging in

using that username with password 7388.
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Finally, visit the Mumble Help pages to additional help. Here is a link to the instructions for

logging into a Mumble server:

Mumble Help

RigPi Audio Input Level Too Low

RigPi audio can be high level line-input of up to 2-volts peak-to-peak, or low level

microphone input (200-mV peak-to-peak). In addition, the input levels can be adjusted.

These settings are done through Alsamixer. See the Alsamixer topic in Other Programs.

https://www.mumble.com/support/how-to-connect-to-a-mumble-server.php
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